EMC not starting properly on Windows 10

For the last 3 days, EMC has not started properly on Win 10.

Here is what it does:

  1. It starts up
  2. It says it didn’t shut down properly last time and checks the database
  3. This is where it stops
    a. The program is “running properly according to Win 10”. It is in the Task Manager, and the taskbar has a little underline under the EMC icon
    b. BUT when I hover on the icon, it just shows me a small screen icon and it is black (blank)
    c. I click on the icon and it does nothing

I can still get into my outlook mail through the browser, but I liked EMC client for how it handles email.

Please help me fix this.

Thank You,

Mike LaPointe

Since updating to V 8.1 I see the following odd behaviour that seems to be related to your problem:
I am using V 8.1.857 on Windows 10 Pro, Version 20H2, build 19042.630.
When I try to exit the program using the X (top right on the menue bar), the program window closes but the background process (Hintergrundprozess) remains open. When I then try to launch eM Client again, nothing happens. I have to manually quit the background process via Windows Task Manager. However eM Client doesn’t seem to “like” this and starts a lengthy database check every time I start the program, saying the program was not shut down properly.
This does not always happen, but more than half the times I exit the program.

It seems that exiting eM Client via Menue>Exit works more reliably.
Could it be that an old bug is raising its ugly head again?

I opened a ticket with support today and am looking forward to their reply.

1 Like

Yes, it seems just like what we experienced in some versions of 7.x :sob:

As you correctly remember, Menu > Exit was more reliable. Thanks for the reminder.

8.1.876 (234bb7a)
Win10 Pro 20H2

Getting the same and also when using Menu > Exit.

As time goes by it seems to be getting more frequent. This did not happen with the version I was “upgraded” from.


Any response to your support request? This is becoming a PITA…

:thinking: I am not experiencing this problem and wonder if it is related to Windows 20H2 which I have not upgraded to as yet.

Yes, support responded very quickly:
“It’s possible that there is some interference from the system or other apps (security apps, monitoring, cleaning apps…) If you are using any of these, can you add eM Client as an exception to them?
Can you please try out if the same happens when you let your PC close eM Client?”

My security apps are exactly the same that never caused any problems with V8.0. The problem persists. In 50% of all instances shut down does not work properly, no matter whether I use Menue>Exit, the X button or exit Windows with eM Client still running. I cannot see any reason why it sometimes works and other times not.

I am running Windows 10, Version 20H2 since mid October but updated to eM Client 8.1 on Dec. 3rd. V8.0 worked perfectly with Win 20H2.

I reported all this back to support. My ticket is not yet closed.

1 Like

That would indeed be interesting to discover as I have not had this issue since way back in version 7. Then one day it just disappeared and I have not seen it since, even with 8.1.

I am in the same position as yourself. Win10 20H2 and any installed software was working fine with EMC v8.0 which I did not even upgrade to until mid-November. This started occurring immediately after I was prompted by EMC to update to 8.1 and did so. The only change to my system was the EMC update.

I will add that one of the first things I noticed after updating was that after some system boots and then opening EMC, EMC would report that it had previously not been shut down properly. It’s as if there is an EMC process that does not actually quit when the program is closed.

This is the properties dialog of the stubborn process that remains running and seems to stop EMC client from starting again.

I have also noticed that when EMC fails to close it can leave the “ghost” of a “Close” tool-tip on the desktop. By this I mean that when trying to close EMC by clicking the “X” in the top-right of the program window, a yellow “Close” tool-tip appears as the mouse passes over the “X”. When EMC is closed this way, but fails to do so completely, a faint “Close” tool-tip remains until the process is killed.

I am not familiar with how this forum is used. Does anyone from the company ever read / respond to any of these posts or is it user-to-user support only?


Similar post on this forum.

EMC 8.1 on Win10 20H2 is unusable as despite closing the program a process remains in the background that does not die and prevents the program from starting again.

So far the only solution I have found for this is to uninstall EMC 8.1 and delete the database when doing so (not compatible with EMC 8.0). Install EMC 8.0 and restore from backup.

Ticket #121285 raised

Can you point me to where you heard about database incompatibility between 8.0 and 8.1? Haven’t heard or seen anything along those lines…


When I first uninstalled EMC 8.1 I selected the option to keep the database just to save setting up my accounts all over again. When I then installed 8.0 and opened it EMC did two checks and errored on the second database check saying it was incompatible. That’s why I then uninstalled both the program and the db, installed again and restored from an auto-backup.

I assumed that this was an 8.0 to 8.1 compatibility error. If I have got that wrong I apologise…

Appreciate the explanation as I was concerned that I might have missed something with the flurry of 8.1 issues being reported.

I will admit that I have assumed it was incompatible by design rather than incompatible due to some kind of uninstall error. To be honest I was not undertaking the downgrade in any kind of “forensic” manner. I have wasted so much time due to this bug that I had just had enough and went into “nuke from orbit” mode :slight_smile:

Re: EM Client not closing in the background when you press X or Menu / Exit

I and my bro are running the latest EMC 8.1.876 & Win V10 20H2 Build 19042.685 and Em Client closes 100% every time within a few seconds for us in the Task Manager whether we click X or Menu / Exit. See example screenshots below.

I suspect the problem is either some other program running in the background interfering with EMC shutdown or a problem with Windows installation.

I would first for a test, (disable everything in the startup) of Windows and then see if EMC closes in the background. If it does then enable the startup items one at a time and reboot till you find the culprit. If disabling all background programs has no effect on the problem, then you would have to save all your files etc and do a “clean new install of Windows”.

(Opened EM Client)

(Clicked X on EM Client and EMC task closed within 1-2secs later)

With version changes like 8.0 to 8.1 there is usually a database structure change. That means an 8.1 database cannot be read by an 8.0 application. Sometimes it also happens between minor versions, but not so often.

Unbelievable that something like that would not be front and center in the release notes, even notes that are as minimalistic as those found on the release-history page.

When trying to downgrade I have found that this “stuck” process also occurs with v8.0.3499 but apparently not with v8.0.3385, which is the version I was using before moving to v8.1.x.


Thanks for the suggestion but eMClient worked fine with this system with all versions up to and including v8.0.3385. The upgrade to v8.1.x occurred with no changes taking place to the system setup and I have no problems with any other program. In your screenshot eMClient disappears from “Apps” and it does on my system as well. However it moves a single thread it fails to terminate to the “Background Proccesses” section which is further down in Task Manager.

In my opinion eMClient no longer works with this system rather than this system no longer works with eMClient. Furthermore should I find that eMClient suddenly will not close properly due to, say, my existing security software or existing office software, should I remove those just to let eMClient start working properly again? I do not have any kind of esoteric set-up and it also seems that I am not the only one experiencing this. I’ll stick with an older version and possibly try later releases but, to be honest, on this system the email client is possibly the least important installed package.


What Security Software are you running ?

Bitdefender, which has been working OK with eMClient since at least v6.x. It is not complaining about eMClient (MailClient.exe).


Here is a screen cap from Procmon. Note that the capture starts at around 09:26. This is about ten minutes after eMClient was closed down and was then unable to be restarted. Task manager shows a background task for MailClient.exe and Procmon shows that it is continually opening and closing threads.

As stated previously this bug begins, for me, from emclient-v8.0.3499 onwards. There is a single fix published in the release info for the emclient-v8.0.3499 which was to do with the yahoo! auth process. I don’t use anything yahoo!.