Version 8 does not show new mail in folders

I just took the offered update to version 8 and am sorely regretting it. There are at least a couple of changes in default behaviour which severely impact my workflow and I can’t see how to adjust them. Any advice GREATLY appreciated.

I use eM Client on a Windows PC to manage my Outlook (live.com) account. I have an extensive structure of nested folders set up and rules that move much of my new mail on arrival to folders (eg, eBay messages, auction reminders, transaction notifications and mass mailings are all moved on arrival to my ‘eBay’ folder)

In eM Client 7 when a ‘Refresh’ was performed - either automatically or manually - I saw folders have bold numbers appear alongside them to indicate a number of new messages. ALL new messages would be listed in the ‘Unread’ folder under ‘Favorites’ at the top of the left-hand column; I could therefore step through the ‘Unread’ folder to make sure I’d paid attention to everything that had arrived regardless of whether it remained in my ‘Inbox’ or had been moved to one of my folders. That worked perfectly for me.

In eM Client 8 - I’m currently running 8.0.2951 (e2fe9f0):

[1.] I see 6 default folders (‘Inbox’, ‘Sent’, ‘Trash’, ‘Drafts’, ‘Junk E-mail’ and ‘Archive’) but the rest of my folder structure is hidden (collapsed) under ‘More’. I can’t see a way to have that list un-collapsed and fully displayed by default as it used to be on eM Client 7. This makes manual filing of emails by dragging just a bit more onerous than normal - requiring an extra click to un-collapse my filing structure before I drag a mail to its new home. I guess I’ll get used to this but it is a retrograde step for me.

[2.] Occasionally a legitimate email gets sent to ‘Junk E-mail’. I select this mail, right-click and select ‘Move to Inbox’ >> ‘Move to Inbox and remove blacklisted email’ The new message pops back to ‘Inbox’ and disappears from ‘Junk E-mail’ but the bold number to the right of ‘Junk E-mail’ does not update - it remains as ‘1’ rather than disappearing! Used to work fine in eM Client 7. I’ve had one of these phantom ‘1’s next to Junk E-mail’ for 3 hours this morning - though interestingly in the title bar when the folder is selected it says ‘Junk E-mail - xxxx.xxxx@live.com (0/2) - eM Client’, correctly reflecting that the folder contains 2 read and 0 unread mails.

[3.] A more serious issue: on a refresh, not all new unread emails are visible in ‘Unread’!

Consider an example where I have 7 new emails, two of which have been moved on arrival to ‘eBay’

Old behaviour (eM Client 7): ‘Unread’ shows bold ‘7’ to its right; ‘Inbox’ shows bold ‘5’; ‘eBay’ shows bold ‘2’. I can see, read and curate all 7 new emails from the ‘Unread’ folder.

New behaviour (eM Client 8): ‘Unread’ shows bold ‘5’ to its right; ‘Inbox’ shows bold ‘5’; ‘eBay’ shows bold “…”. There’s no evidence alongside the collapsed ‘More’ that the underlying folder structure holds any new emails. When ‘More’ is un-collapsed folders (in this example the ‘eBay’ folder) with new mail only have a bold ellipsis, ‘…’, alongside them. Only if you click on the folder or ellipsis does it change to a number. In this example if I click on the ellipsis next to ‘eBay’ it changes to a bold ‘2’ and only then does the number next to ‘Unread’ change from ‘5’ to ‘7’ and include the two new messages from eBay.

So in order to know what new mail has arrived, I now have to open up my entire filing folder structure (which eM Client now collapses by default) and scroll all the way through it to hunt for bold ‘…’ signs that indicate if I have any new messages that have been auto-filed. I have to click on each such folder/ellipsis to ensure they have been registered. By contrast I previously could simply look at ‘Unread’ and see everything.


Can anyone out there suggest anything I might be missing that can be tweaked in settings to solve any of the above?

I’ve come to love this handy program but [3.] is sort of a deal-breaker for me.

Here’s a picture showing the problem [3.] in my main post. My folder state shown (1) immediately after refresh/sync and then (2) after clicking on ‘eBay’ and (3) clicking on ‘Foregin Policy’.

You can see how the numbers of unread emails are revealed by the folders and are added to the total of ‘Unread’. This all used to happen automatically!

I am experiencing the same issue with version 8.0.2951

Other IMAP clients (i.e. my smartphone) are able to retrieve new email from the server, so I assume the issue is with eM.

1 Like

Agreed.

To be fair, the problem I am describing is not that eM Client does not retrieve the new messages in folders but rather that it needs to be “tickled” by actually selecting the folder for the new messages to become visible in the ‘Unread’ folder. In eM Client 7 this happened without any need for additional interaction from me!

I haven’t yet used eM Client 8 enough to encounter the other problems users have reported on this forum, but I’m already close to doing a fresh install of v7.

Please tell me someone has found a solution to this issue, I am just going to use a different client if I cannot see how many emails I have unread in a folder. Version 8 is a complete dumpster fire so far.

2 Likes

Afraid I have yet to find a solution to seeing unread emails in folders.

I did find how to have the folders on display indstead of hidden under ‘More’ - which was my problem in the first of my 3 issues. If you right-click on a folder you can choose one of ‘Show’, ‘Show if unread’ and ‘Hide’. By default v8 has each folder set to ‘Hide’ so just flip any of them to ‘Show’ and that folder is back on permanent view (as they all were by default in v7) rather than collapsed under ‘More’. Quite a nice feature, but undocumented for unlicensed users, so a bit of a learning curve…

However, as described in my initial query, new emails in folders are definitely not picked up properly under ‘Unread’ and require the folder to be clicked to properly update from the three dots ‘…’ to a number of new messages that are added to the total in 'Unread…

Plus a number of other errors such as crashing on startup and attachments not being downloadable are now appearing as I use v8 more.

Dumpster fire is about right… I think I’ll downgrade to v7 again. Or try another client.

I don’t use all the capabilities you used in v7, but I sure noticed the local folders hid themselves in V8 under ‘more’. a poster solved the problem for me a few days ago. he said click more to show the folders and then right click on the folder. there should be a checkmark next to ‘hide’. If you change the setting to ‘show’, the folder will remain visible at the next emclient restart. my local folders are nested (I have about 30 of them), I only had to change the 2 highest level local folders to ‘show’ to get them all to show.

So for me, the problem was completely mitigated.

Yeah I just bit the bullet and just downgraded back to 7, just need to figure out how to stop the prompt to update now lol

Ha! Exactly the same thing here. Not sure you can stop the prompt. Do share if you find a way.

Just a few hours of being back on v7… and it’s like the end of a nightmare…

How do you downgrade to v7

Easiest and quickest way is to uninstall Version 8 including the database (as you can’t launch 7 with 8’s database) and reinstall 7 but that means rebuilding your database but it is the quickest. I’m sure someone has an easier way but all I had to do was log into my accounts and everything is there, folders and all…

I’m a bit concerned that if I uninstall v8 I won’t be able to install v7. What do you mean by I’ll have to install my data base. I’m not a expert user

When you uninstall it, it will say do you want to save your database, just say no and install 7. I had that fear too and it came true because I said yes to saving the database… so I had to delete it all when 7 failed to work (I just had to go to %appdata% Roaming/ and delete the emclient folder. So this shouldn’t happen to you.

Frankie,

It is likely your old emails, contacts etc are kept on a server by your provider. For example I have a live.com email account and all my data are on a Microsoft Exchange server.

eM Client creates a copy of your data locally on your PC. When you upgrade from v7 to v8 the format of this database is updated - while v8 can read an old v7 database, v7 cannot read the new format of a v8 database. Unless you keep back-up copies of your data and, in particular, kept a copy of your last v7 version of this database, you’re likely out of luck.

Hence the only way to proceed is to uninstall v8, choose not to save your database if prompted, (optionally) reboot the PC and then install v7 - which you can get from here: https://www.emclient.com/dist/v7.2.40748/setup.msi
If you have a license the PC should remember it. Then - depending on how large your store of old emails is - you wait for some time while v7 copies all your emails from the server.

I hope it goes well; I am back down to v7 and all is working splendidly.

I’m not confident enough to do that. I have passed the log on the failure to eMclient so I’ll have to wait until I hear from them. But thanks for you help and suggestions

Just wondering if anyone who was experiencing eM Client v8 not acknowledging/revealing all new unread emails in sub-folders as I described in my original two posts, has tried the newest update?

Intrigued to know if it solves the problem - but not brave enough to go through the upgrade and downgrade process again myself yet! :grin:

We tried the latest version and are still seeing this exact issue.

1 Like

I’m a new user, but here is how I resolved the issue:

Folder > Properties > Make available offline

Once I checked that, the ellipses were replaced by the number of items in the folder.

Jerry

1 Like

Just FYI - I had the same or similar issue a couple of days back. Once moved from my Inbox, new messages seemed not to be contained in the target IMAP sub-folder containing 1,800+ mail items. When I searched for them explicitly, though, they were properly shown in the resulting filter window. All folders are marked for offline availability, including attachments.

I was about to trash and reinstall version 8 when I incidentally clicked the header of the “Received” column upon which all mails were shown! The issue obviously was an inadvertent or erroneous change of the usual sort order. This might be the reason for occurrences of subject error reported by other users.

-nothing follows-

1 Like