Signatures don't display properly when sending a file via Windows 10 context menu

Issue description

When creating a new mail message with a file attached using Windows 10 context menu HTML signatures don’t display properly.

Steps to reproduce the issue

  1. Right click any file in Windows File Explorer
  2. Choose Send To > Mail Recipient

What’s the expected result?

Signatures using HTML render properly.

What’s the actual result?

Only the signature text renders with Email Signature text above it ignoring all markup.

One thing to check is that your messages are not being composed in plain text.

I’ve got mail format set to HTML.

I am not able to preproduce this.

What version of eM Client are you using? Check if you have the latest version from the Release History.Upgrade if necessary and see if there is any difference.

If you have a Pro License, you should open a support ticket directly with eM Client.

I’m on version 8.0.3385 (83a873c).

Turns out when you compose a message using the context menu it auto switches format to plain text. Switching it back to HTML renders the signature properly but you have to do it manually regardless of the settings.

1 Like

Setting mail format for reply to HTML solves this issue.
eM Client autodetects message format as plain text by default when attaching a file using the context menu.

1 Like

That is interesting.

I am using an 8.1 internal build and it works fine with the default setting as in my screenshot. Wonder why the reply format has anything to do with it? Maybe this is something that has now been fixed and will be in the next release.

It might be due to OS language as the default message that appears when composing mail using the context menu is localized. I have eM Client language set to English but my OS is in Polish.

Yeah, maybe the difference between our environments explains why I am not seeing it.