Program update does not complete

I am trying to update EM Client, but the update stalls with the message: “The feature you are trying to use is an a network resource that is unavailable.” It asks me to update the source from C:/Users/Dick/AppData/Local/Temp/lmhvppcw. How can I find or get a copy of this source file? Dick

@dick82, Sounds like a Windows registry problem.

Have a look at this article below from Windows Central which has a few suggestions for “Network Resource Unavailable” when installing. If your not confident editing your registry, have a IT tech look at it.

How to fix Windows 10 ‘network resource unavailable’ errors

If you’re installing software on Windows 10, you could encounter an issue with network resources being unavailable for access. Here’s how to fix the problem.


1 Mar 2017 9

When you install and remove software on Windows there are a number of processes that take place, and most of them are not shown in the GUI. Unfortunately, due to the complexity of the OS and underlying software, things can sometimes go wrong. Should you be installing some software and see an unexpected error that states, “The feature you are trying to use is on a network resource that is unavailable,” you’ll usually need to close down the wizard, because the install or uninstall process is unable to progress past that stage.

Searching around Microsoft’s online resources brings up a few potential fixes. We’ll go through them in this guide to get you back on track.

Check Windows Installer

First, you should check that the Windows Installer service is actually running. Here’s how to make sure everything is working:

Best online learning tools for kids: ABCmouse, Reading IQ, & more

  1. Hit Windows Key + R .
  2. Type in “services.msc” .
  3. Hit OK .
  4. Check if “Windows Installer” is enabled .
  5. If disabled, double-click the listing .
  6. Change Startup type to “Automatic” or “Manual” .

If the Windows Installer service is already enabled (set to automatic or manual) and working fine, or you activated it manually and things still aren’t going well in the software installer, you’ll need to move onto another possible fix.

Run Troubleshooter

The Windows Installer troubleshooter suite will automatically check and attempt to fix any detected issues that may be preventing you from adding or removing software.

Download the Windows Installer Troubleshooter

Here’s a list of the things this tool can fix:

  • Corrupted registry keys on 64-bit OSes.
  • Corrupted registry keys that control the update data.
  • Problems that prevent new programs from being installed.
  • Problems that prevent existing programs from being completely uninstalled or updated.
  • Problems that block you from uninstalling a program through Add or Remove Programs (or Programs and Features) in Control Panel.

Simply run the downloaded executable and let the tool do its thing. Hopefully, this should pick up on what’s going wrong. If it finds nothing to fix, you’ll need to move onto the final step which involves making edits to the registry.

Edit the Registry

This may work for you if all other options fail, but it should be a last resort. You should always take extra care when dealing with the Windows Registry, because deleting the wrong thing can negatively impact system stability.

  1. Hit Windows Key + R .
  2. Type in “regedit” .
  3. Hit OK .
  4. Navigate to “HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products” .
  5. Manually select each listing within this folder until you come across any with the software name under “ProductName” .
  6. For any of these entries you find, right-click on each one .
  7. Choose “Export” .
  8. Once again right-click the listing .
  9. This time, choose “Delete” .

Finally, you should reboot your PC and then re-run the installer executable.

I tried steps 1 and 2 without success. I found on the Add and Remove Programs screen that I have 2 versions on EM Client installed. I tried to remove the older one, nd to repair the newer one. In both cases I got a “resource not available” screen as before. This suggests some problem with a prior update. Any other suggestions, or should I try editing the registry?