Disabling of line wrap in outgoing plain text mails

I’m using eM Client 6. The virtual line wrap in incoming text mails works fine. But  — how could I disable the PHYSICAL line wrap in outgoing plain text mails? 

E.g. Windows Live Mail has a Registry Key “Plain Character Line Wrap”, where can be set line wrap at FFFFFFFF (4294967295) chars… that is practically off

Thanks for answer

Hi,
not really sure what do you mean by the virtual line wrap, but if you mean the line included while replying or forwarding a message, the line is only displayed to you when composing plain text messages, but in fact for plain text view/display a ‘>’ sign is displayed before each line of the message instead of the indent line.

If you do not want to indent your replies/forwards, go to Tools > Settings > Mail > Replies and Forwards.

Hope this helps,
Paul.

Hi Paul, 
thanks for the reply, but that was not my question. 

Your unclarity, the two kinds of line breaks/wraps are:

  • VIRTUAL line wrap depends on the variable size of the window, text box, etc. only.
  • PHYSICAL line wrap is a pilgrow, generated by using of the Enter Key.

Try out, what I mean: 

  1. Send a plain text mail (Menu Tools > Format > Text only) with maybe 100 words to your own or to other accessible adress.
  2. Open the mail there in the in-box (every email app possible)
  3. You see the problem: eM Client have inserted Physical line wraps during send without prompting. The lines have (depending on wordlengths) lengths of 60 til max. 71 chars.
  4. Look in the out-box of eM Client in the source code of this mail and you see, “=20” pilgrows were setted without using of Enter-Key.

And now read my primary question in the 1st message again please — I hope you understand the problem now.

Hi, I tried to replicate the issue, but I’m really not sure what you’re referring to, can you please make a screenshot of the “physical line wrap” issue?
Also what version of eM Client are you currently using?

Thank you,
Paul.

Hi Paul, thanks for the answer.

I can’t understand, why you don’t ask a programmer of eM Client: “At which place inside of program code is set the text wrap for outgoing plain text mails at 71 chars”

… That will give the answer to the topic

Hi, can you please make a screenshot of the “physical line wrap” you’re referring to?

Thank you,
Paul.

Screenshot - just made ​​as described Sept 4th in point 4

Hi again, not really sure what are you suggesting, are you having some issues with how the message is displayed? Can you please make a screenshot of the displayed image. From screenshot of the source, I can not really tell what’s bothering you.

Thank you for understanding,
Paul.

S. Bley, is this problem solved for you? I’m still having issues with plain text mails.

My attempt to explain the problem:

Step 1: Write a plain text email. The editor window lets you type lines as long as you want. The text is wrapped at the end of the window. Everything is ok. Please note: The long text in the screenshot has been typed without using the Enter Key. The text is automatically wrapped by the editor. With every resize of the
window the line wraps are re-calculated. Again: So far, everything is working ok.

Step 2: Send the mail and view the source code of the email (still within emClient). Here we see the “Physical line wraps”: emClient has added “=20” to the text every ~70 characters.

Step 3: In the example, I sent the email to myself. So I can view it in emClient. The email looks normal: Again, with every resize of the mail viewing window the line wraps are recalculated. This is what I intended - the text flows naturally, a big screen shows long lines and a small screen shows short lines.

Very nice. So far.

Obviously, emClient ignores the “physical wraps” (=20) prodced by itself in plain text emails. Within emClient, everything seems to ok. BUT : There are other email apps that DO HONOR these hard coded line breaks! Lets take a look at the very same mail in another email app:

Please notice the line wrap at every position of the “=20” in the plain text email. This is quite ugly.

One could argue that emClient isn’t responsible for the handling of its plain text “=20”-line breaks in other apps. Or that RFC 5322, Section 2.1.1 states that line lengths “SHOULD be no more than 78 characters” or whatever. But as OP pointed out, in other mail apps there ARE ways to change this setting.

All I want is writing plain text emails that behave “normal” on the recipients screen. (Without having to convice the recipient to use emClient or another “=20”-ignoring app).

Could we please have a “Plain Character Line Wrap” setting somewhere in emClient?

Thank you,
Manuel.

1 Like

Having the same issues I tried to explain the problem with my words (and pics). Please see post below.

I was struggling with a similar issue (i.e: outgoing messages appearing just fine within em-client, but when viewed in “sent” in the web email client or on the recipient’s end there are line-breaks approximately every 70 characters resulting in absolutely horrendously formatted text). After some testing, I realized that at least for me, this issue does not plague all mails but only replies and forwards to specific (thou numerous) email addresses, probably depending on what client the other end was using. For me the issue was fixed by going:

Menu -> Settings -> Mail -> Compose -> Set: “Mail format for reply” to “HTML” (or “Plain text” if you want) instead of “Auto-detect”

Hope that helps

2 Likes

Fillip, I have tried the setting you suggest and it doesn’t seem to help.

Who else is still struggling with this? The forced line-wrap for outgoing messages at a max of 71 characters per line is glaringly different than any other email client I’ve ever seen and makes all outgoing messages display really badly in all other email clients.

Can we please have some help with a means to disable this?

Hi Deviantollam,
Unfortunately, you are right. I though I fixed it but after few weeks I noticed that it is still happening sometimes. Oddly, it is not consistent even when messaging the same person, sometimes there are breaks and sometimes there aren’t. I brought it up with two people I message very often and both told me that it is seems fine on their end (not sure whether they were not just trying to be polite thou). It still bugs me to see fragmented messages in my outbox and wonder whether that important mail I was writing really looks like it was written by 6-year old.

If someone has solution which would fix it for good, I would also greatly appreciate it

1 Like

I’m glad I’m not the only one frustrated by this. Your description of “emails look like they were written by a 6-year-old” hits home. It’s most unfortunate.

When you said you thought you had fixed it, may I ask what you tried? Was this some setting you attempted or did you submit a pull request?

Literally no other email client I can think of does this so I am not sure why eM Client inserts hard line breaks this way. :-/

bumping this… can we please get an answer here? there is no other mail client that does this, as far as i can tell, and it’s wildly annoying.