Delete unwanted email addresses suggestions

When typing and address in the “To:” box of a new email, eM Client presents a drop down list of suggested compatible addresses. Some of these are old and no longer correct and are no longer in my Contacts information. I see no way to delete the incorrect information. I have tried, as suggested in another conversation, to “Clear recipient history” under Tools>Settings>Mail>Compose>[Recipient History]. This does not accomplish anything that I can see. Any suggestions? Any help? Thanks, NHG

Hello Norman, clearing the recipients history should allow you to remove the old addresses that have been cached by eM Client, you can also use the option “show recipients to review the cache”, if this doesn’t help, make sure these contacts are not saved within one of your contacts folder as if there are no recipients included in the recipients window, the contact has to be saved in one of your contacts folders.

Cached recipients should also show a red cross in the dropdown which also allows you to clear the recipient from the eM Client cache/database.

Regards,

Thanks for your reply, Paul. I have repeatedly “Cleared recipient history” and my “Recipient History Cache” is empty. I have done a search of my entire computer for any incident of the incorrect address and find none. Yet the incorrect address keeps coming up in the drop down options not once but three times. Any other suggestions as to where to go from here?

Thanks again,

NHG

Hello Norman, what mail service are you using with eM Client and what version of eM Client are you currently running on your computer, can you please check the exact release number in Help > About?

Thank you,

Hello again,
I am using Gmail. eM version is 6.0.22344.0

NHG

Hello Norman, unfortunately there’s no other option how to clear the recipients history, the recipients are only saved in the above mentioned cache which you can clear from the application settings, all other contacts displayed by auto-complete while composing a new message are fetched from your Contacts folder.

Only other case would be a Global Address Book, which is usually located on your mail server and is shared for all users on domain, if however you’re using a public Gmail account, you don’t have this feature available, thus my best suggestion would be clearing your Contacts folder.

Regards,

Here is the answer from one who was unwilling to accept empoyee’s answer.

menu - settings - mail - privacy -show whitelist - delete defunct ones - apply and voila —these are no more.  

This works on those rogues ones what do NOT have an “x” in the To dropbox.

Az

Well done. Kudos!

Amazing!  This was the answer I was looking for.  Thank you!

Another way to change the name, my daughter-in-law’s maiden name kept coming up but her email address was unchanged: Copy the email address to a text editor. Update the name:
“First Last” <some@email.com>
and send a message. Close eM Client and restart, the name will be fixed since it is associated with the email address. I was going crazy since I could not find the cache settings area… However, knowing about this whitelist is extremely helpful, thank you Az!

I just tried this, and it did remove the old email from popping up, however, it also wiped out all of the previous emails from this person, so that when I do a search to find an email from his original email, it no longer comes up. Looks like I just shot myself in the foot with this “fix” because now I can no longer search for old emails using his previous email address.

What I had wanted was to just remove the old email from popping up as a suggestion when creating a new email.

Is there any way I can once again find the emails from his old email address? I did not actually delete the emails.