Automatic Backups are not running?

I’m on Version 8.2.1237 (b402cf3) and Automatic Backups are not running, the backup works fine if I manually start it within the program but other than that dead as a dodo. Quite worrying that there was no error popup about it not working, I only found out recently that it hadn’t been automatically backing up for the last 6 months.

I’ve checked the backup settings in eM Client and also checked in the Windows 10 Task Scheduler. Everything is as it should be but i don’t get a backup. The Task Scheduler even shows it supposedly ran yesterday but when I check the backup folder there’s nothing.

Is there anything I can try to troubleshoot the backups not running?

How about changing the location of the backup?

1 Like

Running same version, works perfect for me.

Wait until the automatic backup has supposedly run, then go to Menu > Operations and look in the Log tab where there will be an entry announcing the backup beginning, and one for it ending successfully. If there is any reason why it did not run, then that will be given there.

Some things to consider are that you may be looking in the wrong directory for the backup, or that your hard disk doesn’t have enough space to process and create the new backup file.

Checking the log is a good tip.
I have it backing up to a custom location, it was backing up there fine and still was working fine if I initiated a manual backup.

Thanks, I’ve done that, hopefully it “wakes” things up.

Changing the backup location hasn’t helped and the log shows no backup attempt or error that I can see.

This is sounding more like there is a ‘problem’ with the Task Scheduler entry.

See if there is anything in this post that may help: Automatic backup not working in V8

I got this error when I tried disabling and then re-enabling Periodic Backups:

Perhaps this will be of some help… or not.

Thanks, I tried re-installing Emclient, also tried deleting the Task Scheduler entry and then re-enabling it.
Nothing worked but triggering manual backups from within Emclient still work fine.

Is there anything else I can try, it must be something permissions related?
I noticed when I try manually run the Backup via the Task Scheduler entry nothing happens, it should run there fine when triggered manually via the Run command?

It’s hard to say remotely, but if I were having this problem, I would try the following:

  • Open EMC, make sure periodic backup is not checked. Close EMC.

  • In Task Scheduler, if the task exists, check which account is used to run the task. I would check to see if it’s the same account as the one I’m currently logged into Windows as. If you have multiple Windows accounts, the task might have been created while logged into the 2nd account.

  • In Task Scheduler, if the task exists, delete it. If the task is owned by the 2nd user, login as that user first.

  • If I can’t delete the task, run Task Scheduler as administrator and try again.

  • Open EMC and check Enable periodic backup.

  • If checking Enable periodic backup results in an error, close EMC and run it again, this time as administrator.

  • Check Windows event logs.

These are things that I would do to try and isolate the problem. I don’t know what your tech level is, so I don’t know if all of this makes sense to you. Hopefully so.

  • Again, check Windows event logs. Might be some helpful info.

Just some feedback, I gave up and then tried to tackle it again today and it had started working again.
I had a few biggish Windows OS updates in the interim so maybe things were flushed clean.

Thanks again to all that gave tips and advice, much appreciated.