Yahoo "Password Required"

New installation of eM Client. I first tried the version downloaded from the eM Client main webpage. Then after problems, I learned of the FIXED! Yahoo Accounts and eM Client webpage and downloaded and installed version 7 from there. Same problem keeps occurring:
I keep getting message “Password Required” when attempting to connect.
I tried the App Password suggestion. Generated a password and pasted it in the password fields of the CardDAV and CalDAV tabs, the only places I can find to insert a password. Still same problem.
I am currently set up for POP3.
Any suggestions?

miércoles 25 noviembre 2020 :: 0935hrs (UTC +01:00)

The following by @Olivia_Rust explains what you need to do.

¡Saludos desde la soleada España!

Skybat

emc_forum@compucall.com

Thanks for the reply, but I’ve done that. I am running version 7.2.50007.0, which is supposed to fix the Yahoo problem.
When attempting to log in, a Yahoo window pops up with “Password required for (my email address)”. and “Uh oh, Looks like something went wrong. Please try again later.”. I close the pop-up, which causes another pop-up “Authentication process is not finished. Do you really want to cancel the process?”. Clicking No just brings me back to the same original pop-up.

miércoles 25 noviembre 2020 :: 1807hrs (UTC +01:00)

Hi @MikeONeill

I’m not an expert, just an eMC user with no experience of Yahoo other than I have read here and it seems to be a frequent problem on these pages.
Is the password you enter when asked your eMC or your Yahoo one? I believe they are different, and in any event it might be worth a try.

¡Saludos desde la soleada España!

Skybat

emc_forum@compucall.com

Thanks for the reply. I first tried my usual Yahoo password. Then, per the suggestion on the “Fixed Yahoo Account” page, I got an app password from Yahoo and tried it. Same problem.
What seems odd to me is that under Accounts, there is no username or password field in either the POP3 tab or SMTP tab. These fields do appear in the CardDAV and CalDAV tabs. I wonder if this is a bug in the program.
In Windows Live Mail, that I am trying to move from, the username and password fields appear on the same tab as the POP3 and SMTP servers.
If you are using IMAP, could you verify whether there is a password field in the Accounts>IMAP tab?

Well, I got it working. Uninstalled eMC 7.2.50007.0, and installed 8.0.3499, which I got from the FIXED! Yahoo Accounts and eM Client webpage. The Yahoo window popped up, and instead of an error message, it gave the the opportunity to enter an access code, which it sent to my iPhone.

I notice the version 7 on that page has been updated since yesterday, to 7.2.50008.