Windows 10 won't accept eM Client as default app when using scanner and send as email.

Hi!

I can’t get Windows 10 to accept eM client as the default e-mail client.

eM Client IS set as default app, but when scanning to email, the scanner won’t recognize that this is the default e-mail client.
As I try to set default program, there is a progress-bar that pops up and stops midway thru.
When I click the eM Client icon I get a blue square that says: “If you would like to change default app go to settings > system > default app” and then just a OK button. When I click OK the progress-bar continues, but no changes are made.
I’ve tried all ways to set default program but no luck.

Any ideas?

Hello Frederik,

We’re sorry you’re experiencing this issue. Could you please check that the program is set as default in Control Panel -> Programs -> Default Programs -> Set your default programs? Windows’ Default Apps is sometimes not completely reliable.
If this doesn’t help, could you please go to the ‘Turn Windows features on or off’ window (you can get there by searching this name through the start menu search) and make sure the .NET Framework 3.5 box is checked?

Regards,
Maurice

Hi, new user here.  When I go to “Set Program Access and Computer Defaults”, Windows10 refuses to go through with the procedure and eM pops up a message that says “To change your default apps, go to Settings > System > Default apps.”  which is where I am as far as I’m aware.

When I go into “Set Default Programs”  eM Client is listed in the side bar and says “this program has all its defaults” on the right side.  Yet I can’t click the “Make default” button within eM because it also pops up the same error message as before: “To change your default apps, go to Settings > System > Default apps.”  

I went to “Windows Features” and installed/turned on “.NET FRamework 3.5” as per above, and I still get the same problem.

Please help.

You can’t have eM Client change the default app in windows 10. It must be done in Windows. In Windows, go to Settings/All settings/Default Apps and verify there that eM Client is the default app. In addition, click on “Set defaults by app” (bottom of screen) and find eM Client in the left panel. Select it an then select “choose defaults for this program” and check “select all”

Please note that usually eM Client still will not report itself as the default in eM Client settings (menu/tools/settings/general/general), but it will act as default.

Can you please let me know about taking backup and from em client and how to add backup file to another em client

Hi Maurice!

I tried your first suggestion but no luck. It is set as default program.
I checked the .NET Framework 3.5, it was already set, unfortunately that didn’t work.

Do you have any more suggestions?

Thanks!

Hi Maurice!

I tried your first suggestion but no luck. It is set as default program. 
I checked the .NET Framework 3.5, it was already set, unfortunately that didn’t work. 

Do you have any more suggestions? 

Thanks!

The problem is that you need to manually assign the MAPI protocol to emClient. Selecting emClient as standard app doesn’t do that for you, it seems to be “hardwired” to Outlook, but it can be changed manually.

I recently explained the procedure in this thread:
https://forum.emclient.com/emclient/topics/mapi-support

different issue

Please reference the new conversation here: Transferring data between devices

Thanx for The suggestion but still no luck. Everything is set as it should but still get The error that no default e-mail program is set.

Hello Frederik,

Thank you for the update. In that case, can you please post a screenshot of the ‘Turn Windows features on or off’ window and Control Panel\Programs\Default Programs\Set Default Programs\Set Program Associations?

Thank you,
Maurice

I fixed it by changing the registry by hand. Nothing else worked. 
The line where it was suppose to say “eM client” was empty.
Added “eM Client” and after that it worked just fine. 

Hello,Can you please write in detail how the problem was solved.
We have the same problem.

Hello Michal,
if installing neither .NET Framework 2, 3.5 helps, open Run window and enter regedit.
Go to HKEY_CURRENT_USER > SOFTWARE > Clients > Mail
Check if eM Client is set for the (Default) registry.

My  registry is showing Mozilla Thunderbird, which was an earlier client. How do I change it ? mikesang@outlook.com

I assume you are using windows 10.  There are several steps:

1.  In Windows, go to all settings/system/default apps.  Ensure that eM Client is the default mail client.

2.  At the bottom of that page, click on Set default Apps by Type.

3.  Find and click on eM Client in the left panel

4.  Click on Choose Defaults for this Program

5.  Check Select All

You should be good to go.

In my case I have check in booth different Windows 10 pro OS any registry keys contain “eM Client” in data field. One of them has correct setup for eM Client as default app and another not. The comparison show no different.
The solution was

  1. go to eM Client application itself
  2. Menu->Settings
  3. Scroll down and select “Set as default application”