Version 9 Gmail rules - not seeing them

I just got an email from eM Client announcing the release of version 9, so I downloaded and installed. I’m running version 9.0.1708. I have a lifetime Pro license, and use Gmail for email.

According to the new features described here:

under the topic Server-side rules on Gmail, Menu-Rules should have a option to switch between locally defined rules vs. rules defined in Gmail. I do not have that option in my Rules dialog. I have a bunch of Filters defined in Gmail, so I’d like to be able to see and maintain them in eM Client.

Is anyone else seeing the server-side rules option in their Rules dialog? Do I have to do something to enable it? Thanks.

See if the drop-down helps…

Thank you for the quick reply. Unfortunately, I don’t have the drop down. I just looked through all the Settings, and I don’t see one to enable this feature.


Same here; upgraded to v9 but no dropdown to switch between local and server rules.

Dropdown is also missing for tags as well.

See this thread to see how to switch between Local and server side rules in V9.

@cyberzork we’re aware of how it’s supposed to work, but you can quite clearly see in @Guy_Rouillier’s screenshot that the necessary dropdown for switching between local and server-side is completely missing from the rules window. I have exactly the same issue.

Here i have setup Server side rules and Local rules for Google and Microsoft using eM Client V9 latest official V9 1708 release yesterday .


“Right click” Senders name / Email address and then click “Create Rule” and then select “Local or Server Rule”.



Is there a way of setting Local as Default?

It depends on which email account is set as default. If that account has server Rules, then that is what will be displayed when you open Menu > Rules.

If the default email account doesn’t have server Rules, then Local Rules will be displayed by default.

1 Like

If I right click on a sender’s name and click “Create Rule” it jumps straight into creating a new local rule. It doesn’t even give me a choice of local or server.

1 Like

What version of eM Client are you using? You will find this in Menu > Help > About.

Version 9.0.1708 (2cfb4a5)

I have two Gmail accounts configured, so I just tried exporting one of the accounts then deleting it and importing it again. Now I can access the server rules for that account.

Comparing the two accounts, I can see that under “Account Settings > General > Services” the account I recreated now has an additional service called “Google Settings” which is completely missing from the other account that I haven’t done anything to.

Seems like the v8 to v9 upgrade process isn’t adding that service to existing accounts?

It will be something to do with how your prev Google workspace or Microsoft accounts were added into eM Client from V8 to V9 and then upgraded recently. All mine appeared automatically with Local & Server rules.

I’m preparing to open a ticket with with eM Client to figure out why some upgrades are not getting the Server Rules.

For those who did get them during the upgrade, had you defined any rules while on previous versions? Looking at my current configuration, the only rule defined is “Spam filter”, which I did not create; it was a system-supplied rule. All my rules are defined within Gmail. So, I’m wondering if the fact I had not created any local rules caused the upgrade program not to check for the existence of server rules? Just a hypothesis.

Thanks Gary but I have only one account, gmail, and have ever only created Rules in EMc so as far as I know always worked Local. However the display defaults to an empty Sever Rules page.

I had already created some local rules before upgrading and I still didn’t have access to server rules after upgrading, so I don’t think a lack of local rules is the problem.

I feel like in some cases there must be something in the eM Client database that prevents existing Gmail accounts from acquiring the “Google Settings” option under “Account Settings > General > Services”. That seems to be the key.

Once the account is removed and added back again, that option appears and then server rules become accessible.

The question is, what’s blocking it?

Is there some sort of “available_services” field in the database that gets set once per account and is never re-evaluated? If an account was added before “Google Settings” was even an option in eM Client, will that option just never be available until the account is removed and added back, forcing a refresh?

Because your default email account is Gmail, which supports server Rules, when you go to Menu > Rules, it shows the server Rules for the default account.

If your default email account doesn’t support server Rules, then when you go to Menu > Rules, Local Rules are shown by default.

I just did some testing of various sequences of upgrades from older versions of eM Client.

It appears that this issue is only introduced when a Gmail account has originally been added in any version ≤ 6.0.24985.0 and then the user has upgraded to any 7.x version ≤ 7.2.36465.0 at some point.

If they ever did that, then the “Google Settings” service will not be visible after the initial upgrade to 7.x, nor after any subsequent upgrades.

However, if they upgraded from a version ≤ 6.0.24985.0 straight to a version ≥ 7.2.36694.0, (skipping all other 7.x versions in-between), then everything will be fine and the “Google Settings” service will be present. Similarly, if they started off with any 7.x or 8.x version and never upgraded from a version ≤ 6.0.24985.0 then there will also be no problem.

I see that I can Import Rules into my Gmail account, can I export my Rules from eMC, I can’t see how to?

I believe rules can be exported using the MENU>File>Export>“Export settings to .XML file” and just check the Rules to be exported.

Be sure to do an eMC backup first… Menu > Backup Just in case…