Updating problems

I am trying to install updates 8.1.857.0 and 8.1.876.0 but I keep getting a strange error message
that the setup file is not a valid installation package.
eM Client error
I’d appreciate any help to resolve this.

Go to the Release History and download and install the latest release file.

Hi Gary. I’m still getting the same error. The message is:
The feature you are trying to use is on a network resource that is unavailable.

Go to the Release History and download the latest release file.

At the moment that is emclient-v8.1.876.msi

Once the file has been download to your hard disk (usually to the Downloads folder) open Windows Explorer and double click on that file. It will launch the installation.

I still get the same error message:

What version of Windows are you using?

One thing you can try is to first uninstall eM Client, making sure not to delete the database directory if asked, then do the install again.

The feature you are trying to use is on a network resource that is unavailable.

Hello Daren
Usually the message you’re getting is not related to eM Client per se but is rather caused by Windows Installer (for having had the same problem lately with another application on Windows 10).

So if @Gary’s solution doesn’t work for you, maybe you should try to repair the Windows Installer (which simply means checking if this Windows service is actually running on your computer). Here’s how to make sure it is actuallw working:

  1. Hit Windows Key + R, type in “services.msc” (without the “”) then hit OK
  2. Check if “Windows Installer” is enabled
  3. If disabled, double-click the listing
  4. Change Startup type to “Automatic” or “Manual”
  5. Reboot your PC.

It worked for me, hope it does for you.
PS. If for whatever reason you can’t modify the Startup type try at least to run the service if it is stopped, and then reboot your system.

1 Like

I have same problem for quite a long time (2 years or more) and none of the above are the solutions . Also, repair from control panel or a new fresh download of EM client results in that error or similar

How can I solve this issue? for example is there a way to manually remove EM client?

In case this helps: I have the (non based) suspicion that the problem was caused because once I downloaded a EM version from the Microsoft store after having originally installed EM client normally from the EM site. it is possible these problems started after that
thanks in advance for any advise