Unable to send file as attachment from within Microsoft Office 2016 using eM Client. Only Outlook. I am using Windows 10.

I am using notebook Lenovo X280, Windows 10, Office 2016 and eM client, that is defined as default mail application. When I try to send file as attachment from any office program (Word, Excel, Power Point) or link from Edge Browser, Outlook window appears. I have Outlook as part of office, but I don’t use it as mail client and my mail account is not defined in Outlook. 

In later Windows versions - I think since V 1709 - it is no longer possible to assign the MAPI protocoll to any specific mail client. Ever since that time, if you have more than one mail client installed, Windows chooses one of them on whatever criteria it deems relevant. There doesn’t seem any logic behind it. What could help, is to asssign all standards (“chose standards per app”, or whatever it is called in English; see screenshot) to emClient, which is more than just choosing emClient as standard mail app. After that, you could delete all  mail accounts from Outlook and restart your computer. In my case this has worked.

Alternatively, you could do nothing and live with that Windows bug. Outlook is perfectly able to send mails, and if you are on IMAP or Exchange, no harm is done as all messages are stored on the server(s) and are accessible through emClient, even when they have been sent via Outlook. I don’t think emClient can do anything about that strange Windows behaviour.

The Redmond Team thought they were clever by removing the Control Panel method in later versions of Windows 10. :frowning:

The workaround is to change the settings in the registry.

There are two keys that MAPI looks for: 


If they are both set to eM Client, then any MAPI request will use the application.

1 Like

Thanks Gary. That seems to be the most elegant solution. Up to today I was always hestitant to tamper with the registry.

Thanks, Gary.
This brilliantly solved the problem!!!
In general, there is a feeling that those who developed the details of Windows 10, did it based on their own needs at a minimum, and many things to which users were accustomed in previous versions of Windows, were considered redundant. It is a pity that there is no decent alternative version of the operating system.

I hope this fix works as well for all of you as it did for me.  Go to AppData/Roaming/Windows/Sendto.  Open the Sendto folder and delete all the items.  Close the window, go to the recycle bin and restore all the items from the Sendto Folder.  Note: Probably a good idea to empty your recycle bin before doing this.

BTW:  You can’t hurt a thing by deleting the contents of the folder.  Just DON’T empty the recycle bin before restoring the items back to the folder!   :slight_smile:

I now know how to fix the Right Click Sendto problem. But it boggles the mind why one would have to do this process to make attaching files to eM Client work! It’s not eM Clients fault. It’s the enigmatic idiosyncrasies of Windows

It used to be easy to set that in earlier versions of Windows. Then they changed it. Then in Windows 10, you still has access to the FULL control panel and could FULLY configure mail options. Then they changed it.

Thanks for your solution SA.

This recommendation seems less intimidating than editing Registry entries; however, I do not find ‘/Windows/Sendto’ folder under C:<username>/AppData/Roaming/

Hi Tom,

It looks  like it was more intimidating ,since you could’t find it   lol

The  path should be C:\username\AppData\Roaming\ Microsoft \Windows\SendTo
Also  notice the syntax - There are no FW slashes in a local address

Have you enabled (selected) show Hidden Files and Folders  etc?
via File Explorer Options…

BTW - once you’re in the SendTo folder,create a shortcut there to eM Client
and you can send a file with eMC, via r-click and SendTo    eM Client

I don’t see the logic or rhyme or reason to delete the contents of the SendTo folder and then restore it…


I have Office 365, Windows 10 and the eM Client.  I would like to send a Word document with the eM Client, but it continues to default to Outlook.  I have tried both solutions above, but neither of them have worked (I couldn’t find the MAPl keys).  Is there something different that I need to do since I have Office 365? Thank you for your assistance.  :slight_smile:

In Windows 10 go to Windows Settings > Apps > Default Apps, then scroll to the bottom of the window and choose Set Defaults by App. In that list select eM Client then select Manage and set all options.

Unfortunately, this did not work.  When I share a document in Word, Outlook still opens up as the mail program/app to use.

In Windows Explorer, if you right-click on the document and choose Send To, does it use eM Client?

I don’t use the MS application suite so am not familiar with it’s limitations, but I have a feeling that even if you had another email client set as default, it would still default to MS Outlook when you use a menu function within MS Word. 

When I choose Send To, it still uses Outlook.  :frowning:

If you choose Send To from Windows Explorer, and it is not using eM Client, then you have not set the defaults as I have advised above.

Open Windows Settings. Go to Apps > Default Apps, then scroll to the bottom of the window and choose  Set Defaults by App. In that list select eM Client then select  Manage  and set all options to eM Client.

Or to do it manually as I gave above, change the registry values to eM Client for both 


Here is a screen shot of the changes I made to the settings per what you mentioned a few message before.  Everything is defaulted to eM Client. ![](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1808831/RackMultipart20191001-39822-feus5v-2019-10-01 13 inline.png?1569957465)

I have also tried to go into regedit to change it manually.  I am not finding 


Below is a screenshot of what I do have – HKEY_CURRENT_USERS\Software (I don’t have a Clients).

Am I doing something wrong?  Thank you!

![](https://d2r1vs3d9006ap.cloudfront.net/s3_images/1808832/RackMultipart20191001-56183-144x3pp-2019-10-01 15 inline.png?1569957771)

If You do not have HKEY_CURRENT_USERS\Software\Clients\Mail key, check HKEY_LOCAL_MACHINE\SOFTWARE\Clients\Mail.