The body of my emails will not show - Mac

I tried the v9 but still no luck
All emails seem to be importen in the Inbox - bu only the Subject shows in the Reading panel.

When I try to Forward the mail the body of the original mail shows in the “Forward” window! (Only)…

MAC OS Monterey 12.3.1

I’d like to use the eMClient but cannot due to this problem

1 Like

Same here. Only message list appears, no preview. The message won’t open even when clicking it…

Can you open a terminal and type in the following:
defaults read com.emclient.mail.client

Post the result please.

BackupFreq = 3;
BackupIsEnabled = 0;
BackupPreserveNumber = 1;
BackupTargetDirectory = “/Users/pasiloytty/eM Client”;
CurrentCulture = “fi-FI”;
HighestAllowedVersion = “9.9.0.0”;
LastIndexedItem = “”;
NSFontPanelAttributes = “1, 1”;
NSFullScreenMenuItemEverywhere = 0;
NSNavLastRootDirectory = “/Volumes/GoogleDrive/Oma Drive/YritystenLogoja”;
NSNavLastUserSetHideExtensionButtonState = 0;
NSNavPanelExpandedSizeForOpenMode = “{799, 450}”;
NSNavPanelExpandedSizeForSaveMode = “{728, 448}”;
NSNavPanelExpandedStateForSaveMode = 1;
NSViewUsesAutomaticLayerBackingStores = 0;
“NSWindow Frame NSFontPanel” = "497 505 445 180 0 0 1440 875 ";
“NSWindow Frame NSNavPanelAutosaveName” = "320 332 799 450 0 0 1440 875 ";
“NSWindow Frame NSSpellCheckerSubstitutionsPanel2” = "692 407 425 137 0 0 1440 875 ";
PMPrintingExpandedStateForPrint2 = 0;
WebContinuousSpellCheckingEnabled = 0;
WebKitCacheModelPreferenceKey = 1;
WebKitDefaultTextEncodingName = “UTF-8”;
WebKitDeveloperExtras = 0;
WebKitEditableLinkBehavior = 2;
WebKitShouldPrintBackgroundsPreferenceKey = 1;
WebKitTabToLinksPreferenceKey = 1;
WebKitWebSecurityEnabled = 0;

I hope I didn’t reveal any secrets…

It should be OK, but you can delete the comment if you wish.

Can you see the message contents when you open the message with double-click?
Is it OK when you hit Reply?

Double clicking the message shows only the subject but “Reply” opens the body of the message also.

Tried to restart the app, no help. Then tried to restart the machine, didn’t help.

When a message is selected (=always), there’s a “moving horizontal scroll bar” on top of preview windows as if the app was loading something. When double clicking the message topic, similar “scrolling bar” appears on top of message window also. Nothing (no sender, date, nothing) will appeat in addition to subject.

OK, can you send me some more information please. I know it is a lot to ask, but it will help determine what the issue is.

Quit eM Client then open a terminal. Start eM Client with this command:
“/Applications/eM Client.app/Contents/MacOS/eM Client” -cefwritetoconsole

Then wait a second until the main window is fully loaded, and if there is no message selected in the list, then select one that doesn’t display the contents. Once the message is selected, quit eM Client and save the terminal output to a text file.

Quit and then open the terminal again. Start eM Client again with the same command:
“/Applications/eM Client.app/Contents/MacOS/eM Client” -cefwritetoconsole

Then wait a second until the main window is fully loaded.
Select one that doesn’t display the contents in the preview and click on Reply.
Once the message compose window opens, quit eM Client and save the terminal output to a text file.

Send both text files to me, identifying which is the first, and which is the reply version. gary@emclient.com

{
CurrentCulture = “nb-NO”;
HighestAllowedVersion = “”;
LastIndexedItem = “”;
NSFullScreenMenuItemEverywhere = 0;
NSViewUsesAutomaticLayerBackingStores = 0;
“NSWindow Frame NSSpellCheckerSubstitutionsPanel2” = "692 407 395 137 0 0 1792 1095 ";
WebContinuousSpellCheckingEnabled = 0;
WebKitCacheModelPreferenceKey = 1;
WebKitDefaultTextEncodingName = “UTF-8”;
WebKitDeveloperExtras = 0;
WebKitEditableLinkBehavior = 2;
WebKitTabToLinksPreferenceKey = 1;
WebKitWebSecurityEnabled = 0;
}
stalejensen@Stales-MacBook-Pro ~ %

1 Like

It does not help with double-click. Not OK with Reply, but the body of the message shows if I Forward the message!

@pasiloytty

Can you quit eM Client and enter this text in a terminal, then restart eM Client.

defaults delete com.emclient.mail.client

How do the messages look?

This fixed this issue here, I think. (eM Client 9 on Big Sur 11.6.4)
What exactly does it reset/delete? :slight_smile:

It basically changes language in eM Client to en

We are working on this issue, but it seems to be related to the Mac user account settings.

Oh. Yes, I guess that explains why I got the issue today:
Yesterday I was trying to get the time in the email list view/index to change from AM/PM to 24H. My macOS is set to use 24H (English language, but Norwegian/European locale stuff). To make eM Client 9 work as expected, I added a separate setting for eM Client in System PreferencesLanguage & RegionApps, where I set it to Norwegian. Then I set the language to English again inside eM Client … But Now it seems to work fine without that, so … All good! :slight_smile:

(Edit: Corrected the patch to the Apps setting in macOS’ System Prefs)

No luck here… but where do you find System Preferences - Apps ?

Oh, sorry, System PreferencesLanguage & RegionApps
(As in the macOS’ System Preferences, then Language & Region, then the tab called Apps.)

That did the trick!
Set the referenced language to English - then Poof!

2 Likes

Please see our Knowledgebase article about this:

https://support.emclient.com/index.php?/Knowledgebase/Article/View/249/7/em-client-9-for-macos---messages-not-loading

Didn’t help.

I changed the language setting in the app to English. Changed also the System setting to Default-English (and then removed the app specific setting). No help.

I then changed both language settings to Swedish, restarted the app. No help. I then changed both settings (actually removed the app specific setting in System settings) back to English, restarted the app. No help.

Then I made sure I had English/Default everywhere and re-installed the app. No help.

So, still not working…