Task synchronization no longer works with iOS 13

Hi, I remember that with iOS 13 the “Tasks” feature has been updated on my Apple iPhone 7. As far as I can remember, I even had to confirm that this update was being done. Since then, the synchronization of the tasks with the em client doesn’t work anymore (it worked fine before). Is there any way that the synchronization will work again?

Many thanks in advance!

Create a new task in eM Client.

Create a new task on your phone.

Login to the web interface for your task provider.

Do you see the task created in eM Client?

Do you see the task created on your phone?

Hi Gary, many thanks for your help. No, I do not see the task created. And I forgot to mention that the tasks are stored on iCloud. Regards!

So neither the phone nor eM Client are syncing with iCloud. Maybe something for you to discuss with them?

Ahh sorry! The task created on the phone is syncing, I can see it online in the iCloud! I cannot see the task created in eM Client!

I have just tested the functionality in detail. The synchronization between iPhone and iCloud works perfectly. The synchronization between eM Client and iCloud does not work.

You may want to remove the iCloud account from eM Client and then add it again.

Or go to Menu > Operations and see if there are any iCloud errors in the Log tab.

I have removed the iCloud account, restarted eM Client and added the iCloud account again, there is no change, the problem remains. And there are no errors in the log.

I just revived my old Apple ID and setup an iCloud calendar in eM Client. It is all working just fine except that initially I had to set an app specific password otherwise it would not authenticate.

I enter tasks in eM Client and they show just fine in the iCloud web interface.

Can you see the task you created on your phone displayed in eM Client? Is the Reminders folder ticked?


The sync regarding calendars and contact is working fine, so it cannot be the password. Did you use latest iOS version, which is 13.5.1?

I see only this in the task folder


No, I don’t have an iPhone. I am an Android user. :wink:

Those triangles next to the folders means there is a connection issue.

Many thanks Gary! Unfortunately I have still not been able to eliminate the problem. :man_shrugging:

I neither have been able to reminders in apple to sync with em client. I gave up.Installed iCloud deleted readded etc. Should have to do all this. Not once have I got reminders to work.

I can get contacts and calendar.

I had no problem.

This is what I did

  1. Setup an iCloud account through their web interface using my Apple ID.

  2. Created an app specific password in my iCloud settings.

  3. In eM Client I added a new calendar account, and chose iCloud. Logged in using my Apple ID and the app password.

  4. eM Client synced with the iCloud account and I now have both my iCloud Calendar in eM Client’s Calendar section, and iCloud Reminders in eM Client’s Task section. Bi-directional, read-write.

If eM Client is not able to sync with the iCloud account, there will be an error in Menu > Operations > Log tab, or there will be a triangle warning icon next to the folders in eM Client. Going to either will give you more information on what is wrong.

Hi johncesta, may I ask which iOS version you have if you use an iPhone? In the past it worked fine, but with iOS 13 it doesn’t anymore. I mean with iOS 13 came a change in the task application, so that the synchronization no longer works.

Nope, I follow all that’s provided and while I get the iCloud calendar and see the reminders, neither syncs.

This is all I get all the time.


The only thing I can use emclient for is the contacts and mass mail.

I placed a help ticket on Created: 24 June 2020 23:39 Updated: 24 June 2020 23:39

And have heard nothing yet. Not even something that says, Hey John, but the program and we will answer your question.

If I even got that I may go and buy the program. But crickets?

Pro Support is not available for Free License users. If you do not have a Pro License, you will not get a reply.

The red triangle means that there is a connection issue. Please go to Menu > Operations and look for errors in the Log tab.