SPAM filter Rule NOT WORKING

I have attempted, numerours times to mark senders as safe, yet their emails to me are always winding up in the Junk folder. I know that this is an emClient issue because if emClient is not running on my PC (I only use it on 1 machine) the emails are in my native (gmail, yahoo) inbox. Yet the as soon as I open emClient and refresh my mail list the emails are removed from Inbox and placed in Junk.

Both of the red boxed email addresses have been marked save several time. Yet I always have to retrieve them from the Junk folder.

Also, a human being is smarter than any program, so why are you preventing me from editing the SPAM filter rules?
eM Clientissue2

The Spam filter Rule looks for messages marked as spam by your server, but not moved by the server to Junk. This Rule will move them. There is nothing for you to edit in that Rule.

If the server is marking the messages as Junk, or if the server is moving the messages to Junk, then you will need to open your webmail interface for the account, go to the spam folder and mark these messages as not spam. Thereafter they will remain in the Inbox.

That is NOT what is happening. In this case the server is Gmail. If emClient is not running on my PC then the emails from these senders remain in my Inbox on Gmail. In my test I kept emClient closed for several hours and did not read the emails from the browser in Gmail. This sufficiently proves that Gmail is not marking these emails as spam.

After several hours I kept the browser window open to my Gmail inbox while I opened emClient. As soon as emClient refreshed the emails from the severs the ones in question were removed from the Inbox and placed in the spam folder. If you are watching the UI you can see emails appear and then disappear in the emClient Inbox. Then I refreshed my Gmail browser window and the emails also disappeared from the Inbox and were now appearing in the SPAM folder.

I checked my Blacklist and the email addresses in question are NOT in that list. I am telling you that there is emClient either not respecting email addresses that I deem safe, or that it is making assumptions on what is SPAM. For these particular email address I NEVER marked them as spam in the first place.

Have you checked the actions of the remaining rules to ensure one of them is not the culprit?

No it doesn’t. It just shows the Gmail is not moving the messages. It may still be marking them as spam.

eM Client doesn’t have a whitelist for this purpose so there is no way to mark an address as safe. Also, eM Client doesn’t have any spam detection ability.

That means there are two possibilities; Spam filter Rule or Blacklist Rule. That is the only way eM Client will move messages to Junk. Unless you have created another Rule to do that.

So it is either an address or domain you have added to the Blacklist Rule, in which case you can edit the Blacklist Rule and remove them.

Or the server has marked them as spam but not moved them to spam. Then eM Client’s Spam filter Rule will move them. If that is the case, you need to mark them as not spam in webmail, because the server is marking them as spam.

The FACT that the emails get moved/marked as SPAM the minute emClient starts running PROVES that emClient is the culprit. To further this point I have not started nor used emClient for several days now. I will continue to do this for a few more days to allow several emails to remain in my Gmail inbox. I will record the session which will show the emails in my Gmail inbox for those several days and then start up emClient and watch the emails hit the emClient inbox and then get moved/marked as SPAM. I will then show my blacklist which does not have any of these addresses contained within. This will prove that there is an issue with emaCLient where emails are getting moved/marked as spam that are not in the blacklist. Again, I have NEVER marked these email addresses at anytime as spam, therefore they should have never been in the blacklist at all.

Also note that something similar happened once before and I have to completely uninstall emClient, including registry entries, then re-install it to solve the issue.

(1) Are you certain that NONE of your rules, other than the 2 we have been discussing, moves messages to Junk?
(2) If you have resolved this problem once before by uninstalling and reinstalling, perhaps that is an option now as well, while awaiting a possible resolution by eM Client.

Yes, as I said that means there are two possibilities; Spam filter Rule or Blacklist Rule. That is the only way eM Client will move messages to Junk. Unless you have created another Rule to do that.

So it is either an address or domain you have added to the Blacklist Rule, in which case you can edit the Blacklist Rule and remove them.

Or the server has marked them as spam but not moved them to spam. Then eM Client’s Spam filter Rule will move them. If that is the case, you need to mark them as not spam in webmail, because the server is marking them as spam.

miércoles 01 junio 2022 :: 1027hrs (UTC +01:00)

I totally agree with @Gary
Obviously there is a problem.
You state you have checked and everything is as you want it on the server.
Do this…
Disable all the rules in eMC
This will settle once and for all the issue when you start eMC.

1./ If nothing moves to SPAM/JUNK the fault is with your RULES
2./ If messages move to SPAM/JUNK with all rules disabled the fault is server side.

¡Buena suerte!

¡Saludos desde la soleada Sevilla en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

This video shows what I am talking about. I have been getting emails from the person you’ll see in this video for months. Then all of the sudden they start going to SPAM. I did NOT do anything either in emClient or in Gmail to cause this behavior. Yet Gmail says that I did. So my conclusion is that emClient must be doing something. I have completely shut down emClient and watched emails stay in my gmail inbox for days upon days. Then I will start up emClient on the ONLY PC I use it on and within seconds the emails are moved to SPAM.

You should allow short videos!!!




Again, there are two possible reasons for that.

  1. You have blacklisted the sender or their domain in eM Client. Go to Menu > Rules > Local Rules and edit the Blacklist Rule. Remove this sender’s address or domain.

  2. The server has marked it as spam but not moved it. In that case the Spam filter Rule in eM Client will move it. You can disable the Spam filter Rule, or you can mark the message as not spam in the Gmail webmail interface.

As I have stated numerous times. The email and the domain are not in my Blacklist, nor have they ever been at any time. So #1 is out.

I have a real hard time believing that the server is marking it as spam and not moving it. For one, it stays in my gmail inbox for days and days without moving. For two, if I open the email there are no indications that it is spam. For three, as soon as I run start the emClient application the email then suddenly gets marked as spam and moves. It does not just get marked as spam and stay in my inbox. And for four, when I open that email from my gmail spam folder it stats that “…You reported this message as spam from your inbox.” where ‘you’ means the user (me). I have also stated numerous times that I did not at any point, either in gmail or in emClient, indicate that this message is spam.

So I believe #2 is also out. And something else (within emClient) is causing this issue. I beg of you to dig deeper into this problem. What else can I do to explain the fact that the emClient software is at fault for marking messages as spam? I get that gmail tries to think for me and figure out what is spam (and I wish they would not do that), but in this case any many other cases, emails from this sender have been fine for months without being marked as spam. And then out of the blue they do get marked as spam. And every single time I look at the email in the spam folder from gmail, gmail is telling me that I marked the message as spam. But I did not do that. Somehow running emClient is doing that.

Disable all Rules in eM Client and see what the result is.

If messages are not moved to Junk, enable each, one at a time and see what happens.

When you find the one that is moving the messages, if it is a Rule you created yourself, remove it. If it is the Blacklist Rule, edit it and remove the domain or address. If it is the Spam filter Rule, that is because the message has been marked as spam by the server.

Other than Rules, there is absolutely no other way eM Client can automatically move messages to the Junk folder.

I don’t have any rules other than the Blacklist and the Spam filter rule. The email sender in question is NOT in my blacklist, nor is any other email that has had this problem.

The emails in question are NOT marked as spam by the server. I wish I had a better way to prove this.

Nonetheless, I have turned off both the blacklist and the spam filter rules. As expected my inbox is getting flooded with emails that normally were moved to junk as part of one of these rules, the blacklist I assume.

I will see how things go, but typically this problem doesn’t occur for long periods of time and then it does. It is frustrating.

I truly hope I can prove this to be an emClient issue to you. I am a software developer myself and know that unexpected things do happen.

If you have disabled all Rules, and it is still going to Junk, then it is not eM Client.
If you enable them one by one, and it is caused by the Spam filter Rule, then the messages are moved by eM Client, but only because the server has marked them as spam.

I double and triple checked my blacklist and neither this send or their domain is in that list. And then I re-enabled the blacklist rule. That is the only rule active. The spam filter rule is not currently active and no other rules exist.

I will see what happens, but it may be a while before this happens again.

1 Like

OK. Here is the proof. Not only did the same sender get marked as SPAM again, so did another sender.

Prior to turning off emClient I turned off the Spam filter. Leaving only the Blacklist rule turned on. And ensured that the previous sender in question (Jon Bibo) was NOT in this blacklist. I then restarted emClient and checked these settings again to make sure they took, and they did.

Yesterday I got an email from Jon Bibo that got flagged as SPAM. Not only have I never marked him as spam myself, I also clicked the “Report not spam” button for him within gMail. I also got several emails from Shane Hurst, someone I have NEVER received emails for in the past, and they also got marked as spam and gmail claims I did that. The emails from Shane were replies from a thread where I also got emails that were not marked as spam.

At the time these emails were sent the only PC I have that runs emClient was in a sleep state. So it should not have been running. I saw the emails come into gmail (via my phone) from Shane but did not read them. I only read the original message (from Dave Long). This morning I looked at my phone and still saw all these emails from Shane, and from Jon in my gmail inbox. I then went into my office and woke the PC from sleep state. In which emClient was on the screen. I SAW THE EMAILS DISAPPEAR from my inbox. emClient fired off something that caused this to happen. THIS IS AN EMCLIENT ISSUE! I am not marking these emails as spam, and they do not get marked as spam UNLESS emclient is running!

Please, dive into your code and figure this out!

See screenshots.

This one shows my gmail inbox with two senders that did not get flagged as spam. The one that was read was the original email to me in that chain.

This shows the same emails in emClient.

This one shows my rules indicating the Spam filter is not on, and the blacklist is on.

If Jon Bibo (jbibo....@gmail.com) was in the blacklist it would appear here and it clearly does not.
Round2-four

If Shane Hurst (shane....@gmail.com) were in the black list it would show here.
Round2-five

This image shows both Jon and Shane in the gmail Spam folder.

This shows that gmail thinks I marked Jon as spam. Which I did not AND have marked him as a safe sender.

And this shows that gmail thinks I marked Shane a spam, which I didn’t as I have NEVER received an email from him prior to yesterday.

eM Client doesn’t mark messages as spam, as it really doesn’t have that ability. All it can do is move messages by using a Rule to a spam folder.

So please just turn off the Blacklist and Spam filter Rule in eM Client, then noting will be moved by eM Client to spam. Anything Gmail shows as being moved to spam after that has nothing to do with this application.

Turning off both the spam filter and blacklist rules is not an acceptable solution to this issue. That would mean having to still you multiple email systems to have some control over spam messages. It would mean I’d have to login to gmail, and yahoo mail, and every other mail system to mark senders as spam. It defeats the very purpose for paying for an using a program to combine multiple inboxes.

The very fact that these emails are not marked as spam, or moved to a spam/junk folder UNTIL emClient runs some bit of code means that there is a bug in the program. I am a software developer and I know bugs happen. Sometimes they are easy to find and sometimes they are not.

It sounds like you are not even willing to accept these facts. I have now proven it to you, that emClient IS the determining factor in some emails getting tagged as spam.

I do not understand why you will not accept these facts and look into it??? If it were my program I would check the blacklist rule and see if exactly what it is doing. This is where the bug appears to be.

eM Client doesn’t mark messages as spam. That is not possible. All it can do is move messages to the spam folder.

One way that is done is through the Blacklist Rule. So disable the Blacklist Rule and see if the messages are still being moved to spam. If they are no longer being moved to spam, then it is because you have specified the addresses or domains in the Blacklist Rule. So if you didn’t want to move them to spam, remove the address or domain from the Blacklist Rule. Problem solved.

If you have disabled the Blacklist Rule and they are still going to spam, it could be the Spam filter Rule. So disable the Spam filter Rule. This Rule looks for messages marked as spam by your server, but not moved by the server. eM Client will then move them. If this Rule is disabled, and you ruled out the Blacklist Rule, and they are still moving to spam, it is not eM Client that is moving them.