Sorted email folders immediately marked "read"?????

After emails are sorted by rules and I open a folder, all received emails in that folder are immediately marked “read”. How to stop that so that only the email I open is marked read.

Hi, are you sure in your rules, you didn’t set the option ‘mark message as read’? Because rule filtering does not get marked as read by default.

Positive…here is one of my rules:

After message has been received
from ‘w_albach@msn.com
move to Personal

No matter how I adjust the settings, all boxes except for “inbox” immediately open all new emails received.

That not suppose to happen. What version of Windows, .NET and eM Client are you running?

I’m using Windows 7 v 6.1 build 7601 pack 1; eMclient 3.5 /36540 and net v 3.5

I just installed new update version of eM Client and same thing is happening. Really a pain to use the program the way it is…

Hi, are your mail server using IMAP?

Yes I am using IMAP

There’re some issue running rules on IMAP based e-mail account with certain conditions. I’ll bring attention to some of the developers. In the mean time, who is your mail provider?

And just to eliminate the process, do you access your e-mail from different location? Such as mobile, work/home or via the web interface?

Mail Provider is Gmail and I access emclient from Mobile, work and home…not via a we interface. Thanks for the help.

I have the same problem. I have gmail and am using EmClient to read mail from home. I use IMAP and all my emails look as read. I am not using any filters.

I’m tired of trying to figure out what I’ve read and haven’t read in my boxes. If EMClient does fix this issue by the end of April, I’ll switch back to a competitor.

This is still an issue a year later. This should be escalated - I can’t use rules until this is resolved.

Hi,

can I ask exact steps when this issue occurs? I need to know your rules setup and folder causing this issue and if it happens all the time.

Jan

Hi Jan,

It’s easy to replicate it. IMAP account + rule to move email to folder = email is moved to folder then marked as read. This happens on 4 gmail accounts I have tried it on.

Unfortunately I am still not able to replicate this issue,

but in rules there is option “mark messages as read” do you have it by any chance checked? Do you have that rule set to general message receive or is it bound so some email/emails.

Of could you put here screenshots of your rule which is causing this issue?

Jan

Here’s a screenshot of a rule that shows the problem (email addresses removed). This is a gmail account being accessed via IMAP. As you can see the “mark message as read” is NOT checked. The client/rule moves the message to the correct IMAP folder and shows it as unread until it the next sync with the server. At that point it changes to read (so locally it thinks it’s unread, but whatever it’s doing to move the message is making google mark it as read.)

eM Client version 6.0.19861.0

I agree with Ben. This makes using rules that move messages useless unless it gets fixed.

There are additional bugs related to marking emails “read” in addition to this. I had to remove all my rules to be safe because it would intermittently mark certain emails as read - which is awful since it’s a hunt to try and find the ones not read marked incorrectly afterwards.

Another bug I found is that if I reply to an email, it automatically is marked as read - even tho I have all settings set to NOT MARK as read, for any reason. Why?

I had a search filter on (read:no) and replied to the top email - and when the reply window came up, eM marked the email in the list as read, which for whatever reason, changed the reply window to the content of the next email - which marked it as read in the list… and so on, until I was able to close the window (it marked a month worth of emails as read!!!) These kind of bugs just make eM Client non-production ready! I am trying to use it in our company of 30 but it still has these glitches around the most basic things (like marking emails read/unread) and filtering rules.

Please help (paid for 3 copies so this is for paid support).

After gathering and sending the logs they requested it’s pretty easy to see why it’s happening (at least in this case). Here’s what was happening in the log file…

Line 112: message “imap rule test, take 1” is first seen (UID 9002)
Line 114: UID 9002 is copied to “Friends & Family” folder
NOTE: Google does not actually make a 2nd copy of any message. It merely adds the label “Friends & Family”.
Line 116: COPYUID returns success with new UID (1810)
NOTE: Both UID’s still point to the same single instance of the message in Google email. Google only ever has 1 instance of a message. It just adds/removes labels.
Line 117: Set \Deleted & \Seen flags on original UID (which is still the same message). \Deleted removes the Inbox label. \Seen marks it as read. This is the problem. There’s no reason to mark the message read (\Seen) here since you are about to EXPUNGE the original anyway on Line 124.

If you don’t mark the original message as \Seen before deleting, everything should work correctly for any IMAP system.

nice debug, mega. Curious - what’s your handle mean? mega chir ops?

It’s from a character in an old sci-fi book. It’s based on Megachiroptera (Megabats).