Server version problem with exchange account

I’m trying to set up my exchange account from work and running intro troubles. When I enter the login data and em client tries to connect, the program says “Couldn’t get server version.” in the lower left corner. In the end nothing happens and no exchange account is shown in Mail, Calender and Contacts (also no error pops up).

How can I fix this?
The Server seems to be right. Login name is bound to a domain like “myDomain\myName”.

The account does work on my work computer with outlook and on my android smartphone.

I think this can be solved once eM Client supports manually setting up an e-mail account for Microsoft Exchange Server…I know the developers are busy implementing this.

Hi, could you tell me what Exchange server version you are using?

Jan

It seems to be Microsoft Exchange Server 2010 SP2 ( version 14.2.387.4000 ).

I will need your Exchange logs, go to tools - settings - advanced, check Exchange web services under your account, apply and restart eM Client.
Simulate steps that leads to your issue and after that use “send logs…” to galis@emclient.com together with this topic’s URL in subject.

Then you can turn logging off.

Jan

I have the same problem with Microsoft Exchange Server 2007.

Hi, then please follow my previous post.

Jan

The log file remains empty.

I’ve sent you the mail with the logs.

can you tell me how have you tried to follow my instructions step by step?

I have followed your instruction step by step.
I see log files are created, but they are empty.
If I enable other logging, more files are created and they are not empty.

Can you tell me what other options you have checked?

Jan

“Database” and “Network communication”

I have this problem as well, have sent logs.

Hi what version of eM client are you currently using?
Are you receiving the same “couldn’t get server version” error? Can you setup the account or is this issue while you’re setting up the account?

Thank you,
Paul.

I had the same problem, and have solved it.
create an Outlook account … then edit account and change the server address and login.

Hi, can you please try downloading this update? http://www.emclient.com/dist/v6.0.20462/setup.msi , this issue should be fixed now.

Thank you, sorry for the inconvenience,
Paul.

still not working for me after the update (I replaced the email address):

17:54:14  my@mail-address.de [Exchange Web Services]  MailExceptions.ConnectionException: Couldn’t get server version.
17:54:14    at MailClient.Protocols.Exchange.ExchangeAccount.get_ExchangeService()
17:54:14    at MailClient.Protocols.Exchange.ExchangeFolderSynchronizer.GetFolderList(Folder homeFolder, CancellationToken cancellationToken)
17:54:14    at MailClient.Protocols.Common.FolderSynchronizer.<>c__DisplayClass5.b__0(WorkerStatus status, CancellationToken cancellationToken)
17:54:14 at MailClient.Protocols.Exchange.ExchangeGenericCommand.Execute(WorkerStatus status)
17:54:14 at MailClient.Commands.Command.Process(WorkerStatus status)

Hi, can you please go to Tools > Settings > Advanced and turn on Exchange Web Services logging for your exchange account?

  1. Save the settings
  2. Restart the application
    When the issue occurs, go back to the advanced settings window and click on the “Send Logs” button, please send the logs to mcgregor@emclient.com and please include a reference link to this forum topic.

Thank you, sorry for the inconvenience,
Paul.

This update solves my problem. Thanks!