Sent mail stuck in draft folder

Hi there,
First of all let me tell you that I am using eM Client for the last few years and is very happy with it. I am using the free version.
Few days back there is one mail which got stuck in my draft folder (although I have already sent it successfully). In gmail web version there is no mail in the draft folder but in eM Client I can able to see it (I am not able to see its content though). I tried deleting it but it is not going away. Did multiple syncs but it didn’t work.
I went through the eM Client forum where I saw someone mentioned about Repairing the All Mail folder to fix the issue, did that too but it didn’t help either.
Please look into the issue and let me know if any other detail I can provide to help you people fix the issue.

One thing you can try is to upgrade to the latest version available in the Release History and see if there is any difference.

But there have been some posts on this forum about draft message issues with Gmail. I don’t use that provider for email so I have no experience with the issue. Hopefully someone else may offer you some useful advice.

Tried that Gary but it didn’t work.

I have the same, or very similar, issue. An already sent copy of message is stuck in my Draft folder list.

Some specifics:

  • It is a Gmail account.
  • The body of message can’t be read.
  • It only shows as an item list.
  • Can’t delete, move or anything.
  • Already checked the Gmail (web) and this message is not theret, but only showing in eM Client.
  • Updated the eM Client today with the new version (8.1.979) and it didn’t fix the issue.

Please help.
Thank you.

Right-click on the All Mail folder and choose Properties > Repair.

Hi Gary, I tried that. It didn’t work.

Does this stuck draft email show in the eg: Local Folder Outbox or Drafts folder at the bottom left of EM Client ?


In my case,the issue is not on Local Folder items, but in Gmail account Drafts.

1 Like

@crisoliv ok no probs.

I only queried it as I have seen some of my friends Gmail Drafts (Sent emails) still stuck in the local folders due to they had eg: tried to send attachments that were 25mb or over, and due to the Gmail limit and would never go & then we’re sitting in the local folder outbox.

As you have then already tried the repair Gmail option and have the latest version of ElMC, I would next do an EMC backup via Menu / Backup and then remove your Gmail account and add it back in again as might be some corruption in your Gmail local email account in EMC.

If that still doesn’t work, do another backup via Menu / Backup and the uninstall EMC and delete your database on uninstall. Then reinstall EMC and setup your Gmail as new and see if that problem goes away. As Gmail is IMAP all your email and folders will come back.

As @Gary says usually the Repair via the Gmail (All Mail) properties will normally fix that type of thing.

For me also it is not the local folder but in the gmail drafts folder. The repair option also didn’t work for me.
I eventually resolved it by deleting the problematic account from emclient and then adding it back again. I took a backup before deleting the the problematic account.