Rules not working

Rules for words in subject are  not working. I have a rule setup with various forms of the word “ship” to move emails to a Shipping folder but it doesn’t work at all. What’s going on with the rules?

You can use a Rule to find words in the header.

So searching the header for Subject: ship , will in effect search for *ship* in the subject.

See if that works for you.

That didn’t work either.

One thing to note is that Rules only apply to new messages as they arrive. It will not apply to existing messages unless you manually apply the Rule.

This can be done by right-click on Inbox and choose Apply Rule.

It doesn’t work either way. Incoming mail is not going to the appropriate folder (i.e., rule doesn’t work) and it doesn’t work when i Apply Rule on a specific folder.

Can you post a screenshot of your Rule, like the one I posted above?

I’m not sure how. I don’t see a way to attach an image.

Click on the camera icon

Subject: shipped should be in the header not the body.

Sorry, I recreated the rule as I had been trying many variations and misclicked. I do have found in header checked but it didn’t work.

If you remove the using account option, does it work?

No, I actually added that to see if I limited it to just the one account if it would work. I’ve tried every combination I can think of.

The messages that need to be moved are in the Inbox of an IMAP account?

Inbox of an Exchange account.

The folders are on the same level as Inbox. I don’t have any subfolder of Inbox.

A few things happened that required further testing.

Initially when I created the Rule to move to a sub-folder of Inbox, after the account had synced the Rule lost the link to the folder. This usually happens when you rename or delete the destination folder. I don’t know if somehow syncing the Exchange account temporarily altered the folder, but somehow the Rule thought that the folder had changed, so it then will not move anything. You can check if this is the case when after it is not working, open the Rule and see what destination folder is selected. If the Rule still has move to Shipping then it must be something else. If it has move to folder , then the link has been removed.

This did not happen for me with folders on the same level as Inbox. I removed and recreated the Rule, and then it seemed to work on both destinations.

This does not happen when the destination is a local folder, so all I can say is that on my test computer, it seems that the problem was caused by Exchange somehow changing the folder, and the Rule subsequently losing the link to that folder.

If you have a Pro License, I would recommend that you open a support ticket, and hopefully they will be able to fix your problem.

Thanks for your help! I do have a Pro license so I’ll go that route. It’s so weird. All of the other rules that I have setup work perfectly. It’s just this one rule that  never works.

I have the same problem but with IMAP (not using Exchange).  I’ve tried various things and none have solved the problem.  The rules don’t work AT ALL on my system and neither did the “remove duplicate emails” (or whatever they call this function) when I set the system up initially - I had to remove them manually.  I have used MS Office and Outlook for years with dozens of rules set up and it worked flawlessly, so it’s not like “rules” is a foreign entity to me … go figure?  I’ve got other annoyances with the functioning of the program but that’s another story/thread, I guess ;-(


The rule failed on 2 emails this morning but worked on 5 others. I was just looking at them to see if I could spot a different and I did spot “something”. The two emails that failed the rule had “…shipment!” at the end of the subject and the 5 others had “…shipment…” in the middle of the subject. Don’t see why it would make a difference but maybe.