Rules fail on imap account

I’ve experimented with several rules, all of which work fine with pop3 accounts.
However, the rule that says" if received from [specified account] copy to inbox (that’s local inbox) never triggers. Even when at the top of the rule list.

If I try the same thing with pop3, it works.

The rule also works fine on other email clients, so it’s just emClient it seems?
Looks like a bug in imap handling?

Rules only apply to new unread messages as they arrive in the Inbox.

Is that where the target message is?

Yes, correct. They land in the account specific inbox and are untouched!

Just an idea… have you checked for typos in “specified account”?
Can you display the actual rule?

The account can only be specified from a drop-down, so that’s not it.

@gpauk where are the messages coming from?
Some sources, like security cameras, do not include the Date header in the message, so it can’t be processed.

Yes, it is correct. There’s actually no opportunity for typos, as account and folder are selected from drop downs or lists.

After message has been [received](wizardRule: //invocation)
received using [xxxxxx](wizardRule: //usingAccount)
make a copy to [Inbox](wizardRule: //moveCopyToFolder)

Having never used it (only 1 account), was not aware… thanks for the heads up.

Perhaps the rule should end with “stop processing other rules” in case other rules come into play.

The only other rule at the moment is the one you can’t remove… I disabled the rest for testing purposes…

As a way to solve the problem without solving it, and it does appear there is a weird problem. But, if you turn on Archiving, you might be able to get what you want - moving to local folders. Not the right solution, but perhaps useful if no one can figure out the issue.

Seems that archiving stores to a specific archive folder not inbox?

Checking around it seems that I’m not the only one to experience this issue, and it’s not on the v9 list of fixes either. That’s all a bit worrying, adding new stuff but not fixing the old bugs?

Server archiving, so clicking the Archive button, moves the message to an Archive folder on the server. You will see this folder below Drafts and Junk folders.

Automatic Archiving moves messages based on age from the server to your device, thus freeing up space on the server. You set this up in Menu > Settings > Mail > Automatic Archiving.

Yeah, as I thought. Doesn’t move it to a useful folder, ie inbox, and doesn’t do it immediately. So not really a viable alternative…

Automatic Archiving does keep the folder structure, so moves from Inbox on server to Inbox in local Archive folder. You can set the frequency of the move but this is not meant to run continuously; the overhead would be too large. So run it once a week, or every other day.

But this is really off topic.

Your question was about Rules.

If the messages do not have needed header information, like the Date field, they will not run automatically.

I’ve never seen a mail without a date header…
Here’s a typical one:
X-Received: by 2002:adf:d0cd:: with SMTP id z13mr18102027wrh.91.1643110077084;
Tue, 25 Jan 2022 03:27:57 -0800 (PST)

Rules set to the same function work in other clients I’ve tested - eg outlook, thunderbird, the bat, without any issues.
There’s no sign of any errors logging either, unless it’s hidden somewhere?
Still definitely looks like a bug to me…

Does the message have a Date: field?

It will look like this:

Date: Tue, 25 Jan 2022 12:19:21 +0000

They all do, eg:
Date: Tue, 25 Jan 2022 05:55:02 -0500 (EST)

Does the Rule work if you apply it manually?

Good thought. But I can’t see how to run the rule on a single mail?

You run it on a folder.

Right-click on the Inbox and choose Apply Rule. Then select just this Rule from the list.