Removing collected and remembered email addresses

I have changed the email address of one of my contacts. In the “To” drop down, both email addresses still appear. I’d like the old address to be deleted please. How do I do that? (Clearing Recipient History from within Settings does not clear he old email address.) Thanks

There are only two places eM Client stores email addresses: the recipient history and contacts.

Maybe restart eM Client and see if there is any difference.

Thanks for responding. eM Client and PC have been restarted, Recipient History has been cleared (again), Local Folder Contacts and Address Book are both empty. The only address book I have is contacts from a gmail account and the “old” email address of my contact is definitely not in that. (It was changed to the new email address in my gmail contacts account.) Both addresses still show up in the To or Cc fields when I start typing the contact;s name. Those addresses must be being stored in another location or  eM Client is storing old email addresses somewhere - or perhaps google contacts is storing old email addresses and not displaying them. 

Furthermore, if I remove Google Contacts in the Accounts Section so all contacts disappear completely in eM Client, I still get offered the old email address (only the old one) in the To and Cc drop downs. Odd!

Very odd. There may be some corruption in the database. Can you close eM Client and run C:\Program Files (x86)\eM Client\ DbRepair.exe.

OK, I’ve run that and the old address is still in the drop down.

I’ve gone a bit further and made sure the address books (contacts) are all empty. Then I’ve tried entering other alphabetic characters in the To & Cc fields and the drop down has a lot of email addresses stored - non of which are in my real google contacts so they are collected from emails or one of email addresses used in the past… Is it possible that eM Client has another address book (that is not displaying)? Perhaps a hang-over from an earlier version? Something storing collected email addresses?

This is an old and ongoing problem that has never been adequately addressed.

Thank you. Is there a work around to delete them all?

Hi Norman. Do you have a link to the previous thread for this?

Not that I know of. I’ve got incorrect addresses that I deleted four or five years age that still appear in the drop-down list. I went through a back-and-forth with eM Client support several years ago to no avail. I’ve done a complete computer search and  a search of my Gmail account for the location of the incorrect addresses and have not been successful in finding them. 

I’ll try to find it.

If you have no local data stored in eM Client, you can remove the database and start again. If the old address shows up, then it must be somewhere in your Google Contacts.

To delete the database, close eM Client, and then delete or rename C:\Users[username]\AppData\Roaming\eM Client. You may have to show hidden items in Explorer to do that.

Thank you - I’ll give that a go later today.

Thanks Norman.

Hi Gary:

I cannot find my communication with eM support about this issue. However, here is a link to someone else having the same problem:

https://forum.emclient.com/emclient/topics/remove-cached-email-address-from-dropdown

Norman

I see the same thing on v6.xxx and assumed eMC has a cache where it stores recently used email address like Outlook does. Outlook remembers deleted email addresses forever till you clear it from cache. Note some of these have a red “X” at the far right. If I click that “X” it clears it permanently, but not from the contacts repository. This makes me think eMC has a temp cache area associated with the red "X"s.

I see the same thing on v6.xxx and assumed eMC has a cache where it stores recently used email address like Outlook does. Outlook remembers deleted email addresses forever till you clear it from cache. Note some of these have a red “X” at the far right. If I click that “X” it clears it permanently, but not from the contacts repository. This makes me think eMC has a temp cache area associated with the red "X"s.

Here is a thread that might be helpful:

https://forum.emclient.com/emclient/topics/how_to_delete_suggested_address_in_drop_down

Hasn’t helped me because there is no red “X” next to my incorrect drop-down option (see Paul’s comment) and the incorrect entry is not in list (see Hans Nieuwenhuis comment).

Seems that was with Google Contacts as well. What contact provider are you using Norman?