Periodic Backups not working anymore

“Periodic Backups” used to work, but not anymore.
No errors in the Log.
No task created in Win10 Task Manager.
Backing up manually runs fine.
Win10 fully patched as of October 03, 2022.
eM Client up to date: “no newer versions”.
I am in the “Administrators” Group.

Is there a command line I can use to set up a task in Task Manager?
What else do I have to know/do?

Have you tried setting up Auto-Backup again: MENU > General > Backup
Perhaps changing the target directory of the backup might be a good idea.

Tried it. No luck.
I am an “Administrator”.
Inspected folder permissions, and they are fine.
No errors in the eM Client log.
Used to work. Now doesn’t.
I would like to set up a Windows Task but never got a reply regarding a command line entry.
I wonder if a Win10 update is the culprit.
WHERE is a reply from the VENDOR? (not yelling at you)
Thanks anyway.

Sure looks that way.

You do understand that this is a user-supported forum and eMC employees do occasionally drop in with a response.

Good luck


See the following thread for further help on the periodic backup in regard to the Task scheduler.

Thanks for your reply. You confirmed that it’s not all in my mind.

What is aggravating is that it worked fine until late September. And no log errrors.

If there was a command, I could run it as a batch file or something.
for example: “c:\something.exe”.

My needs are few, and the free version is quite enough for me.

I wonder if reverting to an older version would work.

Meanwhile, I’ll just do it manually. It does leave a bad taste in my mouth though.

Thanks again.

Hi Al,

I realize that. I just don’t like it.

Free or not - some kind of reply from them is warranted.

BTW, If you are in Sunrise, FL, I used to live next door across the street from Plantation High.

Like your avatar.


If there was a command, I could run it as a batch file or something.
for example: “c:\something.exe”

Sorry I don’t know of a command line to auto run the eM Client backup, but if there is one someone on this forum will let you know.

I lived there 1975-~1988.
Avatar :wink:

BTW, I am not having any issues with auto-backup, but I am still using Windows 10, not using Avast.

I’ve seen/heard of some strange occurrences with eMC/Windows over the years. In this case I suspect Windows 11 but have nothing concrete to back that up.

Have you tried running in Windows 8 compatibility mode?
Did you install a Windows update just prior to the auto-backup problem? Perhaps rolling it back is worth a shot?

Just throwing stuff against the wall…

I have the exact same issue. The periodic backup does not work, but if I start it manually, emclient can write the backup to my network share.

  • I reinstalled emclinet - does not help
  • Deleted the Task and added it manually - does not help
  • Changed setting diff. settings in the task like “highest privileges”, “Disabled all energy options” - does not help

For the task, I get always 0x3 for last action (dont know how its in EN Windows)

The last backup at 17:30 was manual backup

How I made em Client Version 9.1.2109 Periodic Daily backups work in Win10 Pro

Note: I am part of the “Administrator” Group. My solution may, or may not, be possible in Win10 Home.

To test my work, I waited until the scheduled time. It has worked for two days.

Steps taken - in this order:

  1. In em Client, disable Periodic Backup, don’t forget to Save and Close.

  2. Shut down em Client.

  3. Access the Windows Task Scheduler.

  4. There are 5 Tabs. Each tab shows an aspect of the final setting.

  5. If the “History” tab says “(Disabled)”, click it then in the right pane click “Enable”. The Disable flag disappears.

  6. Highlight any em Client tasks. I saw only one.

  7. In the right pane, click the Red “X” Delete - to delete the Task.

  8. Exit Task Scheduler

  9. Enable em Client in the “Startup” Tab in “Task Manager”, so it can run after rebooting.

  10. Start em Client and set up Periodic Backup the way they say to do it.

  11. The Task Scheduler should show the new task.

After em Client sets the new task, you can tweak it to suit yourself. I suggest waiting a few days to be sure it is fixed.

Here’s how:

  1. Open Task Scheduler
  2. In the left pane, click on Task Schedule Library.
  3. Click on em Client.

In the right pane, click on “Properties”. This opens a window giving detailed access to the settings for each Tab.

I strongly suggest only changing: Trigger Time, Idle and Power settings.

My settings:

General Tab
eM Client Database Backup (S-1-5-21-4015931021-1247709775-190805195-1002)

Triggers Tab
Daily At 12:53p every day - Enabled

Actions Tab
Start a program - c:\Program Files (x86)\eM Client\MailClient.exe/dbbackup-backup-silence

Conditions Tab

Idle Settings

  • Start the task only if the computer is idle for 15 minutes - unchecked
  • Stop the task if the computer ceases to be idle - unchecked
  • Restart if the idle state resumes - unchecked

Power Settings

  • Start the task only if the computer is on AC power - checked
  • Stop the task if the computer switches to battery power - checked
  • Network Settings - unchecked

Settings Tab

  • Allow task to be run on demand - checked
  • Run task as soon as possible after a scheduled start is missed - checked
  • If task fails, restart every: - unchecked
  • Stop the task if it runs longer than: 3 Days - checked
  • If the running task does not end when requested, force it to stop - checked
  • If the task is not scheduled to run again, delete it after 30 days unchecked
  • If the task is already running, then the following rule applies: Do not start a new instance

History Tab - Shows events. No action needed.

I’m interested in knowing how this works for all of you.

By the way, if em Client tries to blame this on users, they are wrong. Their failure to interact properly with Windows is the cause.


Well done getting your periodic backup working :+1:

Could be something then in the Windows 10 (Pro) that’s different than the Win 10 Home OS version as i’ve never had to modify anything in the Task Scheduler to get eM Client periodic backup working.

@cl33 do you also have Win 10 (Pro) ?

Yes. Windows 10 Pro.


EDIT: I tried your guide and set the time for the backup to 00:06. And it seems to work :slight_smile:

1 Like