Not all Thunderbird messages were imported

I read the other suggested questions/answers and did not find a solution. I just imported from Thunderbird and found that many messages are missing from my inbox (especially older ones), some are just skipped. The sent messages also are missing a whole lot. I didn’t bother to check all of my folders, because if import does not work, then eM Client is out. The only reason I tried switching is because one particular email message in Thunderbird gets Thunderbird stuck, so I thought I might try a different client. But if I lose a significant number of my messages, then it is a no-go.
Any assistance is appreciated.
Thank you.

Try to import smaller amount of Thunderbird folders at a time. See post extract from @Gary from the following thread.

Also see alt Thunderbird export / import options you can do further down the thread If that still doesn’t work.

“One thing you can try, rather than importing everything at once, is to import selected items a few at a time”.

“So, when starting eM Client, if it prompts you to import from Thunderbird, just cancel that. Then go to Menu > File > Import > Thunderbird > Import selected folders”

Also, the messages may have been imported, but you are using Conversations. If you import 100 messages, and those messages make up 60 conversations, the count for the folder is 60.

Disable conversations using Menu > View > Conversations > Disable Conversations and see if the count is the same as it was in Thunderbird.

1 Like

Thanks - my problem was different. em did not freeze. It claimed to complete the task, but lots of messages were missing.

Nope, that’s not the problem. Totally unrelated messages are missing, with no conversations, and a whole lot of older messages. I managed to get rid of the problematic message in TB (though it did open in em), and I’ll stick with TB in the meantime. I have too much important correspondence to lose it and I don’t want to keep two sets of mail - everything up to yesterday and then newer stuff. Thanks for trying.