Multiple drafts in trash

I’m using eM Client 7, connected to my GMail account. 

Since upgrading, I am seeing multiple drafts being created while I write an email, and all these are ending up in the trash folder.

If it’s a particularly long email, after I’ve sent it there might be 6 or 7 versions of the email sitting in the trash.

This is a problem because the GMail web app and mobile app show these drafts as part of the conversation. So it looks like there are lots of emails sent by me, but actually there was only one.

This didn’t seem to be an issue with eM Client 6.

Please advise if this can be fixed by changing settings or if it is a bug?

Thanks

I noticed this too in EM Client 7.  This is because EM 7 has a default setting to save a draft of every email that you compose every 3 minutes.

Then, EM Client attempts to delete all the intermediate drafts when you finally click “Send”.

This actually causes a big problem in Gmail because Gmail sometimes thinks the entire conversation is “trash” when so many of these drafts get moved to “trash”.

To fix: In EM Client: Click on “Menu”, “Tools”, “Settings”, “Mail”, “Compose” and uncheck the setting to “Automatically save emails to drafts every X minutes”.

@railsaverdan Thank you so much that’s really helpful, cheers! 

Hello Andrew,
does this issue still happen in the latest version of eM Client available on our website? http://www.emclient.com/download
If so, let us know so we can analyze the issue further.

Regards,
Olivia

Hi Olivia

Yes.

Hello Andy,
I’ve tried to replicate this issue numerous times, but the drafts that get sent to Trash do not get included in the conversation.
Can you try removing your Gmail account from eM Client and setting it up again, to see if the resynchronization stops this issue?

Regards,
Olivia

Be sure to test with and without attachments.  The problem is very intermittent.  Gmail sometimes tags the conversations as “trash” but usually does not.  I think the problem happens more frequently when deleted drafts contain attached PDF files.

Hi Olivia,

Please see attached image below. This is what I see in GMail every time I reply to an email through emClient if it takes longer than a few minutes to write the email. (It only seems to happen when replying, not creating a brand new email). If I click on “view messages” I can see the drafts of the email at various stages of completion. 

Thank you for the additional info, I’ll try to test the issue further.

Is there an update on this ??

Hello,
what version of eM Client are you currently running? Can you copy the full number from Menu>Help>About section?

Do you have a correctly set Trash folder? Some users experienced this issue when the server-side Trash and Trash in eM Client weren’t set to the same folder.
Please copy the Folder settings from Menu>Tools>Accounts (in the IMAP folder of your Gmail account) and the Folders in Gmail’s settings on the webmail (Settings>Labels)

Version 7.0.27943.0 - updated from previous version

eM Client Settings
Automatically detect special folder names is ticked
Sent > Gmail/Sent
Drafts > Gmail/Drafts
Trash > Gmail/Bin
Junk > Gmail/Spam

Gmail Webmail Settings

System Labels
Inbox
Starred
Important
Chats
Sent Mail
Drafts
Drafts
All Mail
Spam
Bin

eM Client saves multiple drafts of emails. When the email is then sent, the drafts appear in the sent folder in eM Client. When the email thread is viewed in eM Client or Gmail webmail I only see the final email as sent. When I view on an android phone or tablet via the android app the sent email and the email thread contains all the saved drafts as well as the final sent email. If I delete the drafts from the sent folder in eM Client then the sent email and the email thread viewed on an android device do not contain the multiple saved drafts.

I updated to the latest version of eM Client several months ago.

Yes - I noticed a similar problem between EM Client and Gmail android app.

Here’s the scenario that I saw:

  1. I sent email to recipient
  2. Recipient replies to me
  3. The email conversation continues for several more emails between each other
  4. I then compose a particular reply, save the draft, but I did not click send button.  I decide not to send this reply.
  5. I then composed a different reply and I click the send button
    The Gmail Android app shows the reply (that I never clicked “Send”) in my Sent folder.

The Gmail website does not show this reply.

I do not know whether the recipient received this reply or not (hopefully not).

I have the latest version of EM Client.

Hello,
could you please take send actual screenshots of the Labels tab to rust@emclient.com ?
Add a link to this forum thread in the message body, please.

Regards,
Olivia

I can say that the problem of multiple versions of a draft (even when not expressly SAVED as a draft) appearing in Trash is still a recurring problem in version 7.1.30794.0 and I have certainly had them them occur more frequently than the 3 minutes that is set in Settings - Mail - Compose. I don’t want to remove or change that setting as I want the protection in case the app or computer freezes mid-composition. I have also seen where one of the partial compositions appears as the final sent item and the full composition is nowhere to be found. It always makes me a little nervous to empty the trash folder and I hate having to double-check to see if sent items are correctly saved. I’ve seen where I’ve had up to 12 versions of a messaged appearing in Trash which I know only took me maybe 3-4 minutes to compose and not the 36 plus that would be the case for that many versions to be saved. (And these were at successive points in the message and not just multiple copies of the full message at the end because I didn’t send it immediately after finishing composition). I also notice that it doesn’t seem to be consistent. Sometimes multiple drafts appear in trash and sometimes they do not. I think maybe sometimes the timer from settings works as configured, and sometimes it does not resulting in either fewer or no drafts or many more than should be.

Wish they would get some of these glitches worked out.

And I certainly HATE (or am confused by) the All Mail folder, but understand that is more an IMAP issue than a eM client issue.

I also discovered that when I open and read a message that I have previously moved to a local folder after I close the message (having made NO edit or reply or forward), it then appears in the trash. The original message still appears in the local folder where it was moved originally. I find I am always checking when I empty the trash to make sure that messages that I want to keep are not being deleted.

Are you still using 7.1.30794, or have you upgraded to the latest version?

Which Trash folder do the read messages appear in - local or on the Gmail account?

I think that this read message may have been entered in Trash when you originally moved it to a local folder, and not when you opened it to read it from the local folder. Can you empty your Trash and then open a read email from a local folder and confirm if it reappears in the Trash?

I was referring to the Trash folder under my Gmail account in the eM client. NOT the trash folder in the Web Gmail account. They do NOT appear in the trash in Web Gmail.

I will test this behaviour with the latest version to see if it still occurs. I see what you mean about the timing of when the message appears in trash. At this point, I can not say for sure that I had emptied the trash before I opened it in the local folder, so I will have to test that.

As I’ve related on another thread, EVERY TIME I move a message to a local folder it ALWAYS appears in trash. Makes no sense. That certainly didn’t happen in Thunderbird. In fact none of these glitches that I see in eM ever happened in Thunderbird and I would go back to it but for ONE reason. The syncing of the Gmail calendar was kludgy to set up and often stopped working, which was a deal-breaker for me. THAT does work flawlessly with eM, and so I stay.

Perhaps I was a little harsh just now. There were other things I didn’t like about Thunderbird. I just don’t remember them now and I have gotten used to eM and it’s quirks.

I would also add that I was perfectly happy using MS Outlook when I had a license to do so, but … I am loathe to give ANY more of my money to Microsoft. I avoid Microsoft where I can. Sorry … this is a totally unrelated rant.

This issue is still present in version 7.1.32088.0 - happened to me yesterday.
I was writing an email from my Gmail account for about 7-8 minutes. There was no attachment. Today I found out that what I was writing was being send (or not - both Gmail and eM Client show them as actually sent but I’ve verified it on the account thas was CC’ed and it was received only once) to the recipient every minute. I found one final version of the message in my “sent” folder and another seven in the trashcan (both web Gmail and local folders).