Multiple copies of drafts showing and not being removed after send

Hi, I’m using emClient 9.2.1735 with google hosted mail. Since updating from 8 to 9, in some cases I’m seeing multiple copies of message I write show up in my google drafts folder, and they aren’t being removed after I send the message. If I restart emClient, the drafts will disappear after a few seconds. It doesn’t happen with all messages, and I haven’t been able to detect a specific pattern either. Before writing this message, I spent some time trying to find a consistent replication scenario and wasn’t successful. Has anyone else ran into this issue and have any insight into the cause?


This issue is still occurring. I’ve tried a DB repair, but that didn’t resolve it. There also still doesn’t appear to be consistent duplication steps. However, it seems to trigger more frequently for messages that I start creating and leave open for a while before sending.

As before, the drafts don’t show up if I log into gmail via the web, and restarting emClient will clear them out.

In case anyone else lands here, this is a known issue and discussed in more detail in another thread.

For anyone who is still having this issue, please download the latest version in the Release History.