move to folder

Why is it when I open a particular email message window, press a “Move to Folder” button, choose a folder, the system simply copies the message to that folder instead of moving it there?
Is it only me?

I think it may only be you.

Maybe some more details Dmitry. What version of eM Client are you using? Who is the email provider? From what folder to what folder are you trying to move the message?

I am currently using the latest beta version, but I had the same with the previous version as well.

Provider: Gmail
from Inbox to a created own folder

Please note - this happens only when I use the “Move to Folder” function from a dedicated email message window. When I do this action from the main message list - it works as required.

I was not able to reproduce this on the latest beta, but it is not uncommon for Gmail accounts to have peculiar issues with moving messages, and I am not using Gmail.

I use this function quite a lot with my gmail account and I am also using the latest beta (8.0.1018.0).
I don’t have this problem, no matter wether I use it from a dedicated email window or from the message list. The only difference seems to be, that  I don’t move the message within my gmail account but from gmail to a folder on my Outlook account.

I just created a folder on my gmail account (named Test) and moved a mail into that folder. I get the same behavior that Dimitry discribed: From the message list everything works, from the email window (via right-click) the message is copied. i am not sure if that is a problem that eM Client or Google should tackle.
I reported the problem to testing(at)emclient.com.

Yes, I think this is an issue with the label being changed, but the old label not being removed. That results in a copy rather than a move.

I am currently using EM Client V8 Beta 8.0.1018.0 and using my Gmail account, and i’m moving emails ok to brand new or existing folders ok.

I highlight the message subject and then use the Move to Folder button on the EM Client Toolbar along the top.

I create all the Gmail folders within EM Client.

Just to add on top of this, folks. Have noticed not for the first time already.
Sometimes, when I move my mail while using my Gmail account’s web interface and then open emclient - I find that the mail appears/remains in the Inbox folder there (nothing has been moved).
If I use Outlook 365 for PC or other Android mail app (Gmail, Outlook, etc) at the same time - it all looks updated - the way I assigned within Gmail.
Something seems to be malfunctioning here.

Dimitry that just sounds like Emclient hasn’t yet automatically synched / updated since the email was moved online. It usually only automatically re-syncs every aprox 15mins.

So if you have just moved emails online & Emclient hasn’t updated yet the same, then manually click the (Refresh) button in Emclient at the top left which will force the synchronise.

If the mail in the folders still doesn’t synchronise, then download the latest Emclient V7 or V8 Beta from the release history .There was alot of recent fixes.

If you do install a new version, click (Menu backup) first before installing any new version incase u have to restore.

https://www.emclient.com/release-history

@cyberzork, thank you for the reply. Yes, the Refresh button was the first thing I tried.
But I will try to download the latest V8 beta. See if this was fixed. Thanks

Installed the latest version - tried refreshing. Still the same thing - message locations in relation to folders are not updated. All other email clients show the synced version - as in Gmail web. Really strange stuff.

Dimitry that is strange nothing is automatically synchronizing from Gmail when clicking Refresh manually & all other clients are.

Check in Menu / Settings / General / Synchronization that you have “Synchronize items at startup” enabled which then normally automatically synchronizes the IMAP server mail folders etc on startup with EM Client mail folders.

Example V8 Beta

@cyberzork, I keep this box always ticked.

Just to clarify, maybe I didn’t word it properly.

The inbox is being synced, but the email message locations are not. Let’s say I receive an invoice from eBay to my Inbox and read it via Gmail web, then allocate it to Invoices folder. If I would then go to emclient and try to find that letter - it would be there but would appear under Inbox, whilst other apps would properly see it under Invoices folder.

Dimitry the synchronise items at startup should normally not only sync the email in the inbox, but also synchronise all the email folders to match your IMAP mail server folders similar to refresh. So as you said when you copy or move mail in Gmail online, EM Client should then sync / match.

As you have already tried the latest V8 Beta & still not working, I suspect then there maybe something on your computer that is not allowing Emclient to synchronise. Do you run any optional eg: firewall, security, antivirus programs etc ? If you do, try disabling them temporarily to see if that then works.

If you don’t have any optional programs like the above, you then might just have a corrupted em client database. To create a new database, click Menu / Backup again to make a new backup. Then uninstall Emclient. Part way through the uninstall choose the option to (delete the database) and then reboot your computer. Then reinstall the latest version again from the release history page.

Then finally resetup Em Client with Gmail setup & near the end of the setup, your browser should open with the Gmail (Allow dialogue box) which you accept to allow EM Client access to your Gmail account and then see if the mail folders sync ok.

I’ve experienced the exactly same behavior in all v8 beta versions.

I am currently running emClient 8.0.2088 with multiple accounts and the issue is happening with a mail account that is hosted on a custom domain, but I am not using public services like Gmail etc. in emClient often so those might be affected too.

It drives me crazy that the mail is copied to the new folder but fails to disappear from the original folder.

I did fresh installs from zero (all settings wiped) and the issue is still there and appears to happen at random. Although I did notice that it never happens with inbuilt (default) folders, only when I try to move mail between custom IMAP folders I’ve made. Maybe a good starting point to look for the bug.

I’ve come to a point where this one thing is seriously affecting my decision to just go back to v7 until the bug is fixed.

EDIT: I forgot to say that I can actually move the stuck mail to Trash and then to the folder where I initially wanted to send the mail. I don’t see duplicate mails in the target folder after that so what actually happens… Beats me…

Still an issue.

Two weeks later I have no other option than to go back to v7.

Yes, beta versions can be very buggy. I am having major issues with 8.0.2531.

Please send your comments to testing@emclient.com.

Already did that. Sent full logs, detailed description and even a video demonstrating the issue.

I will wait for a full release before checking out v8 again.

Can someone please confirm if the issue has been resolved with the official release version of v8?

The issue may be that the folders are just not refreshing.

Can you download and install the latest version available in the Release History and see if the problem is still there.

If it is, can you move a message and confirm that it appears in both locations, then open the web interface for that email account and confirm that there are also two messages.