Message missing after being rejected by GMail due to size

Tried to send an email earlier today. Apparently it was rejected by Google (GMail) due to the size of the attached images. No problem there. I can resize the images and reduce their sizes. However, I cannot find the ‘Sent’ copy of the email anywhere. Where did it go? Any suggestions? I would really like to not have to retype the message if at all possible.

Check Gmail “All Mail” folder for the rejected Sent mail.

1 Like

Thank you for the suggestion. Sadly, not there. I do keep copies of sent emails. To this recipient I sent a follow on asking if they received my first. I have that ‘Sent’ copy. Since it my initial email was a reply I searched for the unique subject text and I see the initial message and my followup messages.

FWIW - I am still getting error messages saying that Google has rejected the email due to size restrictions. Which leads me to believe eM Client still has it somewhere and is badgering GMail with it periodically.

Yes you will still get that message due to Gmail tried and failed. Sometimes this message can also come from the eg: Gmail “Drafts” folder , Gmail “Trash” folder or even the Local “Outbox” folder at the bottom. So if there is nothing in Gmail “All Mail” folder, check those other folders. When you find it, delete it and clear that email from the trash and then close and reopen EMC. Obviously copy the email first to a new email.

Note:- If you still cannot find it anywhere, go online to Gmail and search for the message as eM Client if you use IMAP merely mirrors Gmail online.

Once you find / fix the problem , if you then want to send file attachments over 25MB in size via Gmail check out this thread for how to link a file attachment via Google Drive to eM Client. How to attach files (as a link) in Google Drive to eM Client - Frequently Asked Questions - eM Client


1 Like

Still looking. FWIW - While I have a Google Drive account from Google by default I do not use it ever. I am currently using Dropbox. However, the images were attached directly from my computer and I did not use the “link to image” on Dropbox.

I have located several Drafts folders both in em Client and GMail. None have the message.

I have looked and looked and find no “Show Local Folders” in online GMail settings. In fact my GMail settings don’t look anything like what your image shows. (Thank you for that BTW). However…

In em Client I found and clicked the ‘Attachments’ link at the bottom of its drop-down. When I checked that all 5 of the images I tried to send are shown. Uneeded; but, <Sherlock Holmes: A clue Watson!> Futzing with it, cuz that’s what I do sometimes, I right-clicked on the first image in the Attachments display and discovered/saw a drop-down link to “Open Source”. Clicked that and my entire composed message was displayed.

I have now copied the original text. It is copied and is safe. Thank you!!!

It were a dumb mistake to try to send the raw phone-camera images. Normally I am more careful as I know about mail message size limits. Quarantine induced drain bamage! I now know what the size limit is, so lesson re-learned with added knowledge attached… i.e. what the size limit is exactly.

Thank you so much for helping!

1 Like

Yes, a message will be kept in the Local Folder Outbox until it is sucessfully uploaded.

In eM Client, go to Menu > Settings > General and make sure Show Local Folders is ticked as @cyberzork indicated in his screenshot.

Then go to the Local Folder Outbox and delete the message.


Thank you. It wasn’t clear to me that @cyberzork was referring to eM Client and not Gmail. My misunderstanding. It is now checked.

The good thing is that I was nevertheless, and albeit in a round about fashion, able to open and save the message text thus saving me quite a bit of time.

1 Like