Linking to Teams not Skype

Hi, when I attempt to add Microsoft Teams in Settings > Online meetings Skype is added instead of Teams even though I have a personal Microsoft 365 license and Teams is installed on my computer. Does anyone know how I can link Teams instead?
Thank you

When setting up the meeting account in eM Client, the Microsoft server will offer the correct Teams or Skype account based on the type of Microsoft account you have.

If it is a Personal Microsoft account, you get Skype.
If it is a Business Microsoft account, you get Teams.

If they are offering the wrong one, you will need to contact Microsoft directly and have them assign Teams to your Business account.

I’m having this issue as well. I believe there is an issue on emClient’s side, because there are two distinct “Microsoft Teams” versions. One is for business and one is for Personal. EmClient looks like it’s not able to use the personal version at all, which is a big downfall. I pay yearly for a family Microsoft365 account, which includes use of the personal MS Teams application, and I’d love to use this as my default online meeting application for my personal microsoft account on emclient. Could your development team do some investigating to see if you can separate the options for linking to a personal teams vs skype account?

The type of meeting is determined by the Microsoft server, not eM Client. Their server makes this decision based on the type of Microsoft account you have. That is the account that you authenticate when adding the Online Meeting provider. So Menu > Settings > Online Meetings > Add > Microsoft Teams. You are passed to your browser and login to an account. If that is a personal Microsoft account, you get Skype.

Please contact Microsoft directly if you have a Microsoft Business account and are still getting Skype.