Large attachments still do not go through

I love eM Client, but it sucks big time when trying to send large attachments. Anything less than 1M goes through, but larger than that it seems to get constipated. Please fix this guys, as it forces us to use other email clients and soon we may not want or need to come back to this.

Maybe this has to do with your anti-virus/firewall application or your account settings.

Who is your email provider?

What settings do you have in Menu > Accounts > SMTP?

Hi Gary, thanks for your reply. My email provider is a company in NZ and I don’t have problems with any other client. I specifically moved away from Microsoft as I don’t like them, but while I was using their Outlook, I never had one problem. I’ve tried to get into SMTP, but don’t see the tab for it. See attached what I have.

Yes, you are using Exchange so there is no SMTP tab.

From what I can gather this is an issue with a setting on the Exchange server. See Olivia’s comment on a similar issue:

Thanks, Gary, I have sent this on to the service provider. Hopefully something positives comes from this.

I have spoken to mt service provider and they have opened up Exchange for up to 100M! I can also log onto their web-base server (Outlook and from there I have no problem. It must lie with some configuration in eM Client.

eM Client does not have any restriction on size of attachments; that is always up to your email provider.

If you completely disable any anti-virus/firewall or VPN on your computer, are you able to send attachments larger than 1MB?

I have the same problem, and ONLY with eM Client. Mailbird works fine, no problem with large attachments. So the problem is NOT the provider or the settings of my computer, it’s YOU.
Solution, please ? As far as I know, you cannot change the limits of attachments in the settings of eM Client. Pity, for large mails I’ll continue to use Mailbird. Greetings from Belgium, Ronald

eM Client has no limit on the size of attachments. That is set by your email provider.

However, we do have options if you regularly need to send attachments larger than what they allow.

The first is you can change the warning in eM Client. So if your provider limits you to 20MB, go to Menu > Settings > General > Confirmations and change the warning to 20MB. That way if you try to send a message over their limit, you will get a warning.

The second option is to use cloud storage for attachments. We have an article here that explains how to setup and use that, but essentially what happens is the attachment is separately uploaded to the cloud, and only a link for that is in the message.