Office 365 Email with large attachment fails to send

My Office 365 email is set to send or receive emails up to 150MB in size.  I have confirmed this works in Outlook 2016.  I prefer eM Client however.  When I try to send an attachment that is 21MB (to my Office 365 email as a test to ensure it’s not an issue with the receipient’s email) eM Client fails and the email continues to sit in the outbox.  I can send the same file no problem using Outlook 2016.

The error message seems to be an attempt to connect failed.  From the logs it looks like eM Client operation times out trying to send the email.

As I test I double clicked on the email sitting in the Outbox and changed the sender from my Office 365 account to my gmail account and the email was sent.  So this is an issue just with Office 365/exchange accounts.

What can I do to enable sending large attachments with my Office 365 account using eM Client?

One other question.  With my gmail account in the imap account settings I can check the boxes to download messages for offline use.  I do not see that option for the Office 365 account.  Is it not available for Office 365/exchange accounts?

Thanks in advance for any help.

As a follow-up, I sent myself a 90MB file as an attachment.  The email came through, but when I try to download/open the attachment eM Client fails in doing so.

I can open it almost immediately in Outlook.


Can anyone from em client please respond?  If large attachments is a known issue with an Office 365 email just confirming that would be helpful.  If it is an issue is it addressed in 7.1?


Hello Timothy,
he EWS protocol has built in limit for request length so maybe the larger messages that you send hit the limit. Please try to adjust the server settings and make sure that the setting “httpRuntime maxRequestLength” is set to 20000 for 20MB limit or to 50000 to 50MB limit.
If this does not help, we will need full EWS logs.

As for the downloading for offline use - this setting is present only for IMAP accounts. Exchange accounts download all content as default.

Olivia, thanks very much for the reply.

I am not running an exchange server though.  I just have the one Office 365 email address.  Through the administration panel of the Office portal I have properly changed the email size.  However as I am not running an exchange server there is no possible setting for me to change “httpRuntime maxRequestLength”.  I have seen posts on this forum to make that change but an Office 365 user cannot do so.  I have googled that extensively and cannot find any way to do that.

Is there anything else that can be done to try to fix this for an Office 365 user?


Olivia, any updates?


I really want to buy this program as it suits my needs other than this one major issue.  I cannot rely on an email program if it won’t send or receive even moderately sized emails (4 MB).  And we are talking about Office 365 here not some home grown IMAP/POP setup.

I don’t want to buy eM Client just to get better support only to find out that the issue can’t be fixed.

So can the issue be fixed or should I move on?  If it can be fixed is it fixed in 7.1?

Thanks in advance.

Surely I am not the only one with an Office 365 account that has experienced this?  Can we not get any more help on this issue?

Hi Timothy,

I have unfortunately the same problem as you. Unfortunately, I could not find synonymous solution. As it looks, your last post is 3 months ago, no one has responded to the support. I will not buy the program as long as it also advise everyone until this problem is solved.