Keyboard shortcuts

I absolutely love eM Client - the feature set and visual appeal are both outstanding!  There is only one thing I like about using Gmail’s web interface - custom keyboard shortcuts using only a single keystroke.  I can move so quickly through mail that way, and moving quickly through mail is essential.  All relevant keystrokes are using left hand.  W - mark read.  E - archive. V - move to folder (and then typing the first few letters of the folder and done!).  D - delete.  SPACE - scroll the message window.  I can’t get that speed of processing with eM Client.  Is there any way to accomplish this?

1 Like

Hello Tom,
unfortunately our shortcuts can only be set to special keys or to combinations with Ctrl or Alt at this time.
Thank you for sharing your idea on the forum though, so out developers can consider this change.

Regards,
Olivia

It would be great to have this - I also heavily use this feature in Thunderbird.

1 Like

I just installed eM Client and this is the first thing I looked for, to be able to use e to archive my gmail and achieve inbox zero.

1 Like

1 more vote for single-key shortcuts. Yes, this would be very nice, and so fast. 
Orson

1 Like

+1 for single keyboard shortcut - “gmail shortcut” checkbox support in options will suffice.

I like how you have option to change shortcuts, but it’s not really that customizable if forced to use modifers like CTRL or SHIFT or w/e.

1 Like

There could be an option so that some users can elect to use single-key shortcuts. I agree that it would be very handy.  I suppose that the single-key shortcuts would be active only in the specific windows or controls that eM designates, so that these keys could also be used for regular text when completing messages, search forms, etc. (as Gmail and others do). I currently use function keys for the most common actions, so that already saves time, but the ability to use alphabetical characters can be even faster.

You can assign a single key to an existing shortcut. Go to Menu > Tools > Settings > General > Shortcuts and select the one you want to change. 

Click your mouse in the area indicated by the arrow above and hit the single key you want to use.

Very good!

It is a little dangerous because changing Send from Ctrl+Enter to D, will mean your message will be sent when you type Dear right at the beginning. :wink:

That’s right, so I don’t use those. That is why I was suggesting that the use of single-key shortcuts needs to be mediated by the program to ensure that the single keys are active at only the right times-- generally when not focused on a text-entry field, as I think Gmail uses that approach.

1 Like

You say that it works in eM Client now, but I am on macOS Catalina and single key shortcuts don’t register at all. Is this fixed or not? Quite a deal breaker for me unfortunately.

I’m considering making the switch to eM Client, and as far as I can tell single-key shortcuts are still not possible. This is almost a dealbreaker for me. What is the status of this issue on the development side?

Hi David,
single-key shortcuts are actually possible now, we have added this option in version 8. Can you perhaps provide more details on which shortcuts are you having trouble setting to a single key and which key is used?

Hi Olivia, thanks for your reply. I’m trying to set the shortcut for “Archive” to “E”, but the editor won’t accept it, or any other single character. It will accept CTRL+E or CMD+E.

The default shortcut for “Archive” was CTRL+CMD+A. I’ve got it set to CTRL+E at the moment.

I’m using the latest release of eM Client for Mac, 9.1.2082.0.

Thanks for your help.

Hi David,
thank you for the additional details, we were able to replicate the issue, and it seems it depends on what you click before setting the shortcut.

What you need to do to set the single-key shortcut is select the shortcut in the list and then click the new shortcut right away. Do NOT click into the text field at the bottom, as that will not work for the single-key shortcut.

We will of course get it fixed so the shortcut can be changed no matter where you click, but as a workaround please try setting it this way for now.

1 Like

I don’t mean to hijack this thread but since I have a related issue with single key-shortcuts, I thought this might be a good place to ask :slight_smile:

The setup with the hint from @Olivia_Rust works fine and since it is only done once-ish, that’s not an issue. For some reason, the single key-shortcuts also work when focussing the Search field in the main window’s upper right corner. However, only sometimes. I have the feeling that when pressed quickly, the shortcut activates and when pressed deliberately, the letter is written.

To me, this feels wrong. I understand that I can’t have single key shortcuts when writing a mail, hence I would expect they are always disabled in text fields.

Is this intentional, or can I fix this on my end? It is really confusing when I accidentally reply or archive a message when I want to search :smiley:

Thanks

Hi DrBones,
the single-key shortcuts should be disabled when you have focus/active text fields, but you can have focus on the search box (via the settings, for example), but not have the text field active (ie. blinking cursor) at which point the shortcut would get precedence.
But that does not mean there might not be a bug, I’ll have our testers try to replicate the issue, but if you notice anything specific about when it happens to you, please let me know.

Edit: I was able to replicate the issue now and reported it to our devs, there indeed seems to be a bug when search history or suggestion line pops up.

Wow, that was fast! I was just preparing to answer when the edit appeared!

Thank you for your quick assistance!

Thanks for your investigation and reply, Olivia. This solution worked for me.

1 Like