JavaScript not enabled

Been facing this issue and not sure what to do. I searched the forum and realised many are facing similar problems. I reset my pc yesterday and reinstalled EM. However, i keep getting this error message. I have enabled JavaScript on all my browsers(including IE11). I have also installed .NET framework but nothing works. Need to sync my Google account so i can access my contacts for my work email.

Lenovo S410 
Intel i3
4gb RAM
EM 6.0.23421.0
Windows 10

Hi Jason,
unfortunately this is an issue we know about at the moment and are trying to find solution for.
Please try logging into your gmail account through webmail using Internet Explorer.
Try removing eM Client either from your connected apps (…) or from your App passwords (…) and then logging into eM Client, giving it the permission anew.
This has managed to help some users, but it might not work.
I’m sorry for the inconvenience this issue is causing.

Best regards,

I’m also running into this problem and none of the solutions are working for me.  After I log in I see the javascript error message.  I’m running Win 10 with the latest patches.

Is there any way to bypass EM’s built-in auth dialog and have it just open the auth process in the default browser?  Whatever you’re doing in the dialog is at least part of the problem.

So, a workaround that seems to be holding for the time being…

  1. Change your google account so that two-factor verification is disabled.  I chose to have google save my 2f settings when I disabled it.
  2. Remove and re-add the account to EM.
  3. Let EM re-sync everything
  4. Turn two-factor back on.

Thanks for the tip Michael. It worked for me also. I hope when I will restart the computer, it will still work…

Surely there must be a better fix from emclient

Would be really great if you could provide us with a reliable fix soon. I’ve got the same problem as I’m using several Google accouts to sync private and work calendars. They both worked fine in eM Client until yesterday, when I moved to a knew PC and by that had to install eM Client freshly.

Ian, given that people have been complaining about this for at least 7 months and EM have been giving the same canned responses, I’m guessing it’s not a priority.

I too have recently been having problems with this issue. I have eMclient on three different PCs and they are all reporting problems suddenly. The root cause of this cannot lie with the browser settings on independent machines.  The only common link is that I have a Google account on all 3 machines.

I have yet to see a solution to this issue which is preventing me from using eMclient.

This MAY be to do with the 2-step authentication which I use, but I don’t want to turn that off at the moment.

Hi Clive, Michaels solution involves only a temporary switch off of the 2-step authentication. Step 4 is to turn it back on. If you are quick enough you may not get hacked in the meantime. ;) 

If this is the type of support eM Client supplies then I am moving to a different e-mail client.  This is the first company that is aware of a problem by field reporting and doesn’t provide an immediate fix.  In terms of customer support this is being non-responsive to a known problem and in terms of security, especially those of us who access work related emails from home, this is a no-go to suggest deactivating Googles two step verification process.  This is unfortunate as I have enjoyed using eM Client for over a year but i need the two step verification to work in the e-mail client that i use.  Shame on you for not being more responsive to not only customer needs but also to providing the most secure, non-VPN solution for our e-maills by not enabling/supporting something so basic as JavaScript support.

This did work for me on my current machine. Will I have to repeat this process on every device that I have eM client on or is this fix across all of them?

Hi Lisa, as I had mentioned before: The two step verification just needs to be turned off temporarily to allow initialisation and as soon as the client is registered you can turn it back on.

A bit a pain but it seems to have no many other reported solutions yet.

There are all chances as this solution seems to work for most that the problem is not high priority.

As for the JavaScript I am not sure if that is always a bad thing. I have noticed a sharp increase in JavaScript viruses in the recent past. Actually one new one yesterday. (The forecast was anyway that script viruses become popular again and it seems true)

But I have not looked into this as my client has kept working. Sometimes error messages can be quite misleading. 

I personally switch off scripting wherever I can and love text emails rather HTML but that is just personal taste.

I have tried the method of turning off two factor authentication which works fine on one PC but then my laptop’s emclient says I have to log in again - I repeat the procedure on my laptop then guess what - my desktop goes off again AAAAAgh !

Some people have account policies in groups that disallow disabling two factor auth, so this is not a good solution for this problem. The only other workaround I can think of here is by switching on app passwords for individual features, but that process is tedious. :-/

What worked for me:
Create an app-specific password in your Google account.
When adding your email account, don’t choose “Gmail”, choose “Other”.
Enter your email address.
In the next step, enter the incoming pop / imap server ( /, your email address as user name and your previously set app-specific password.
In the next step enter the outgoing smtp server (, your email address as user name and your previously set app-specific password.
Then click “next” to test the configuration. It will try for a short while, but then you’ll get an error for both incoming and outgoing servers. Simply click “fix” on both and wait until eM client picks the right settings and that’s it.

Sorry folks, doesn’t seem to work permanently.
After closing and restarting eM client, the usual Google authentication is required again. App-specific password won’t work. You’d have to repeat the whole process above every time you open eM client. Yeah, not gonna happen :frowning:

There seems to be a presumption here that it is possible to turn off 2 factor authentication. If you are using a Google business account and are not the admin for the account, then this may not be a possibility at all. The end result? You can’t use eMClient. And even if you can, you still can’t get a Google Apps account to work because of the JavaScript problem.

Turning 2FA off and on is not a solution. At best, it is a hack that works for some. The problem either needs to be fixed or eMClient needs to throw in the towel. Other apps seem to have this fixed - non-Google apps, even.