Is there a way to set up a default task account?

I have three accounts, two of which have google calendars. It’s easy to turn an email into a task in the two google accounts. But I really would prefer to put all my tasks in one account.
Is there a way to set a default task account so that any email I turn into a task selects that account automatically regardless of what account I’m in?
(Currently, the non-gmail account fails to find a “folder” and prompts me to enable local folders and put the task there. I don’t really want to use local folders. So my workaround at present is to move the email into another account and create the task there. Not very efficient though.)

I have similar problem. I want to create task form email.
I have 2 account - imap and google.

When I want to create task on email i automaticly ascribe to google account. Ok, I can choise local tas but when I create it on email all textes in task descriptions are unformatted.

Me, too. Somehow my tasks default to my Family folder, and I have to move them each time I create a task. I don’t know how the default location became my Family folder, but it wasn’t there initially. So there must be some way to change the default.

Go to Tasks and highlight the task folder where you want the default tasks to be created. Now go back to your Inbox and create a task. It should default to that folder you highlighted.

Your position in Tasks is remembered across restarts, so that choice will remain there until you highlight another folder in tasks.

Your solution is not working when you have gmail account and want to create task on email attached to local folder.

Go to Menu > Tools > Settings > General, and make sure that Show Local Folders is selected.

Then go to your Tasks section and highlight the Local Folder Tasks. Repeat the solution I gave above.

It should now default to Local Folders.

It doesn’t work…
As far as I can tell, if you you use the “Add new task” window under agenda, it will default to the first email account you set up.  The work-around that I have found is to delete all  email/calendar accounts and then set them back up one by one taking care to setup the one you want to use with “Add new task” first.   At least this worked for me.

Or you can just select which is the default by clicking the star icon. By default that is the first one you add, but you can change it to any of them, and it’s position in the list is not important in this instance.

You can also change the order of the accounts by using the up and down arrows, so no need to delete and re-add them in a specific order.

Sorry to necro, but this solution does not work for Local Folders… I don’t have access to most advanced task options when I make a new one because it’s created on my primary (gmail) account. Is there a way to set new tasks to go to Local Folders/Tasks by default?

The default folder is whichever folder you are in when you create the new task.

So go to the Tasks section of eM Client, and click on the Local Folders Tasks folder. Now any task you create will have Local Folders selected by default.

The exception is if you create a task from a message. That will use the Task folder associated with that email account instead.

This is simply not the case:


If you create a task from the sidebar, it will use the default account.

Yes :sob: Where can I report inconsistent behavior / make a feature request regarding this?

It is not inconsistent, but by design.

Is there somewhere I can make a feature request regarding my edge case, then?

Hi there,

may be this workaround will help you:

Good luck. Bernhard