Incoming mail marked as "important"

Every message I received is marked as “important” by default. I cannot find this option is Settings — Tools. How do I disable this?

Hello Jim,

This is a default Gmail server setting. You can read more about it here: https://support.google.com/mail/answer/186543

How to hide Important labels as described in the link above:

  • Using a browser, open Gmail. You can’t change this setting from the Gmail app, but the settings you choose on your computer will apply to your app too.
  • In the top right, click Settings.
  • Click Settings.
  • Click the Inbox tab.
  • In the “Importance markers” section, select No markers.
  • At the bottom of the page, click Save Changes.
    Regards,
    Maurice

eM Client just did a update to Ver. 7 from 6. When all was complete not only is new emails marked as Important, but existing emails in my inbox was also marked important that where not marked before. This has to be a Ver. 7 bug and not gmail. 

Actually, it is gmail. When you upgraded to version 7, eM Client re-synced all your data, including the “important” markers from gmail. eM Client does not add any category, just receives what gmail passes over.

It is not gmail. I update the gmail settings as instructed and it is still marking all incoming mail as IMPORTANT.

1 Like

Trust me, it really is gmail.  eM Client does not mark anything.  I could never get the important labels to not appear either.  But then again, I actually like them, just wish they could be used as filters (which they cannot).

That being said, I do believe emc should establish an option to remove (ignore?) the important labels as they are passed through.

I don’t know how you can say it isn’t gmail when I changed the gmail server settings to NOT MARK ANYTHING and still every incoming message is marked important in eM Client. They are NOT marked important when I login to gmail via a browser or the app so this is clearly on the client side.

Gmail still “marks” them, but just doesn’t display them.

The point is, though’ emc should also have the option to not display.

Hello Jim and Jay,

I’m sorry for making a mistake, I didn’t realize at first that this setting only hides the label on Google products. To completely turn off Gmail’s classification of Important/Not Important, you can create a filter for all messages addressed to you (at any email address that you use in conjunction with the account) and choose “Never Mark as Important”.

We realize that eM Client doesn’t work in the most elegant way with this label, you can however used it in Advances Search/Creating search folder by adding parameter category:"\Important"

Regards,
Maurice

Nothing seems to work …filters etc …

Its truly annoying and very frustrating

Scott, you need to set up the filter in gmail, not emclient.  To do this, go to settings in the gmail web interface and choose Filters and Blocked Addresses.  Then:

  1. Set up a new filter
  2. In the To: box put your email address, and press “Create filter with this search”
  3. tick “Never mark Important”.
  4. As you create the filter, also select to have it applied to all matching messages as well. That should empty your Important folder and as it will remain empty as long as the filter is in force, you can just ignore it.

Let us know fi this works.

The search parameter does not work for me.

Does not fix it … i have been playing with it for months

Hello Jay,

Please paste the category:"\Important" into the ’ Search Query’ field. Afterwards you can use the individual fields below the line as usual.

Regards,
Maurice

Hi Maurice–I get an invalid query (cut and paste from your post).Jay

Hello Jay,

I’m sorry, in that case I haven’t realized that this feature hasn’t been merged into a public version yet. It will be possible in 7.1.

Regards,
Maurice

This worked for me

from:(*)
Do this: Never mark it as important

YES!  @Jay Ogram, I love you, lol. 

Ok, I finally figured it out… I just set everything over 1kb to not mark as Important. 

But now we have set this filter. What happens if something comes in as marked important? If you where using this for personal usage, I guess it dose not care, but people that are using this as for a business that do get the odd email marked as Important.

I removed this irritating flag in eM Client. Here’s how: Click Menu, Click Tags. Under Mails, RightClick Important, then click Remove. Click Save & Close.