IMAP synchronization flag read/unread

I share the same IMAP email address between 2 clients.

Unfortunately it does not work properly the synchronization of flag read/unread.

When read an email from a client is not read in the another client.

Everything else works properly.

What configuration solves this problem?

Thanks for the help

Luca

Hi Luca, are you completely sure you’re using IMAP on both your computers?
What mail service are you using and what version of eM client are you currently using?

Thank you,
Paul.

Yes, i use IMAP on both clients.
I’ve been using email services to a small local supplier, and has always worked with other clients (OSX Mail, Thunderbird and Windows Live Mail). 

eM Client works very well, has many good features, but will not sync the flag read/unread of the clients.

Thanks
Luca

So is that a private domain mail service? What provider are you using then? Can you make a screenshot of your IMAP settings on both of your computers?

Can you please go to Tools > Settings > Advanced and turn on IMAP logging for the problematic account? Save the settings and restart the application…
…also can you try right clicking your mail folder and select Properties > Repair and click on the repair button?

Once you do so and the issue persists, go back to the Advanced settings window and click on send logs, please send the logs to my email mcgregor@emclient.com and please add a reference link to this forum topic.

Thank you,
Paul.

Hello,
i’ve done other tests. Every now and then it works.

On a group of 3 emails read by the first client, in the other client 2 are read and 1 remained unread.

The flag was not updated even after restarting the clients.

Luca

I have done the following steps:
 - i turned on the IMAP logs on 2 clients
 - i requested 3 times the configuration test
 - I read on the first client the 3 emails with subject: “POSTA CERTIFICATA: Messaggio di prova”

After synchronization on the second client only 2 email with subject “POSTA CERTIFICATA: Messaggio di prova” have the flag read active. The last email received with this subject (the first in the ordered list) is unread!

I sent the logs of 2 clients by email

I also have this issue - running eM Client on 2 PCs as well as several mobile devices all accessing the same set of IMAP accounts.  If a message is marked as read on a phone it does not change to read in eM Client.  No folders are set for offline use.

Hi Luca, just to make sure, the emails have been marked as read on the first computer right? The delay before the message is actually marked read is quite long in eM Client…

Thank you,
Paul.

I have also set the delay to mark as read to 0 seconds on both PCs

Hi Paul,
yes the 3 emails have been marked as read on the first computer.
But also after along time, on the second computer, only 2 email have been marked as read. One of this email (the last received and the first on the ordered list) result unread.

Luca

Hello Hugh,
i have to investigate the problem, but also happens to me with other clients.
If the message is marked as read with Thunderbird never change to read in eM Client. 
Even for me no folders are set for offline use.
I have yet to verify first to be sure.

Luca

Agreed - if I set a message to read in eM Client it also marks as read on my mobile device but not on my other eM Client desktop.  If I mark a message as read on a mobile device it is marked read on all devices (both mobile and eM Client)

Hi Hugh, what mail service are you using?
Can you turn on the logging for the account as well and send me the output as Luca did? You can find the instructions on how to do this in my above posts.

Thank you,
Paul.

Done - sent from the email client with email address s**@sco*****tiles.co.uk

Hello,

Have the same problem also.

Testing machines: iPhone running iOS 7, PCs running Windows 7, SmarterMail Professional 12 email server.

Action: Flag on iPhone
Reaction: Server web interface - flag, emClient - no flag

Action: Flag on emClient
Reaction: Server web interface - flag, iPhone - flag

Action: Flag on server
Reaction: iPhone - flag, emClient - no flag, no read

Action: Flag in emClient
Reaction: other PC running Windows 7 with the latest emClient - no flag

Seems like emClient reacts only to actions performed by itself somehow. It’s like it’s flagging it in a certain way and doesn’t recognize the way other apps flag it. 

New lead: If I close emClient and then launch it again, flags are being synchronized, but only this one time. If I continue to flag/unflag, the behavior described above resumes.

This is the only thing stopping us from switching from Outlook to emClient. We flag the messages that have been replied to, so we really need this feature.

Have a nice day,

Samuel

Hi Samuel, what version of eM Client are you currently using? If you press send and receive are the flags synchronized eventually?

Thank you,
Paul.

Agreed, this is my problem. I have checked and eM Client does update flags when first opened but then stops until it is closed and reopened again.

I am using the latest client (6.0.20320.0). The flags do not synchronise if send and receive is pressed either at the global or single account level.

Thanks,

Hugh

Hi Hugh, what mail service are you using? If you’re using a private domain, what host are you using?

Thank you,
Paul.

Hi Paul,

I am using version 6.0.20498, and flags and unread count don’t update even after doing a send/receive. I saw in another thread that this, or sa similar issue, was solved in a previous version. Could the bug have reappeared in the latest version?

Looking forward to a solution.

Thanks,

Samuel

I’ve just installed 6.0.20433 linked from another thread and that has solved it for me. Thread here: https://forum.emclient.com/emclient/t…