How to resume editing a draft email

Hi there,

When I am writing an email but I don’t send it, I save it and close the window, to finish and send it later.

However, in eM client, I don’t see how to do that. I don’t see any Edit option or button that lets me re-open the draft in edit mode.

The only thing that is different from other emails is the red [Draft] tag at the right top, that tells me the email hasn’t been sent yet.

Could somebody help, please?

Thanks a lot.
Cheers, Manuel

This will save to the DRAFTS folder

To reopen, double click the email in the DRAFT folder and it will open in “edit” mode exactly as it was when you saved it.

2 Likes

I am having trouble with this too. Usually when I save a draft, when I select it in the folder list, the red ‘draft’ tag does not show, and when I open it, it opens in a non-editable window. But in experimenting with this, I see that occasionally the draft is editable and the red tag shows. But even then, once I further edit it and re-save it as a new draft, the draft tag no longer shows and I cannot edit or send. I have not yet figured out what triggers the two different behaviors. It seems random.

To save a new email to drafts to edit later, (when composing the email), I also click “Menu / File / Save” apart from the Save button as @sunriseal already advised.

I also edit them again via the email account Drafts folder by dbl-clicking on them as @sunriseal advised too.

@walkdraw

I am having trouble with this too. Usually when I save a draft, when I select it in the folder list, the red ‘draft’ tag does not show, and when I open it, it opens in a non-editable window.

So if your drafts are “not editable” and “don’t always have the red tag at the top right”, then might be something to do “with your specific account” that might need eg: “removing and re-adding”, or you “might have an older version of eM Client” that needs updating.

Have you tried already removing and readding your account in eM Client? Also what mail account are you having this issue with ? Lastly what version of eM Client are you running

I posted a solution elsewhere for Yahoo! accounts with this issue. If your account is not with Yahoo!, give it a try anyway. It will force all messages in the Drafts folder to be editable.

1 Like

Wow. Thanks! What a bizarre bug with an obscure workaround. Curious that my searches on this forum had not found your previous post. (Some testing had suggested that the draft flag was getting removed after any refresh, which is why it seemed intermittent at first.)