How does one alter the width of EM Client scrollbars

My scrollbars are too narrow for ease of use.  I would like to widen them in the Mystic theme.  can anyone suggest a method?

You can either use a Theme that has wider scroll bars, or you can edit the Theme yourself and change the setting.

Gary, thanks for the info.

I assumed that you can but I don’t know what I should enter in the Theme.emtheme file or, if the entry I need to change is already in the file, what i need to alter.  I’ve found the entry for hiding/displaying the scrollbars but not for  changing the width.  Do you have you the information I need?

Thanks,
Paul R.

Yes sorry, I hit Submit and then forgot to come back and edit it to include the details.

You need to find the section, and change the UseSystemScrollbar to True.

So:

 True

I’ve changed the setting from False to true as you described but with no effect.  The scrollbars are still hidden until the mouse is hovered over where they are located.

I changed the setting in the Theme.emtheme file in the  C:\Users’Me’\AppData\Roaming\Themes\ folder.  Then to be certain the changes take effect I restarted the PC.

In addition, what I really want to also do is increase the width of the scrollbars but i can’t find a setting in the theme file that controls that.  As I noted in my original post I’m using the Mystic theme.  Would that have any bearing on on my queries?

1 Like

Go to Menu > Tools > Settings > Appearance > Themes. Select the Theme you want to edit then click on Advanced > Save current theme as …

Save it somewhere other than the eM Client database directory. Open it in your preferred text editor and make the changes. Now back in eM Client go to Menu > Tools > Settings > Appearance > Themes and select Import. The edited theme should now be at the end of the list, so click on it and choose Apply.

1 Like

Great Gary,  I’ve finally sorted what you told me and solved the problem.  Many thanks.

I’ve had the same dissatisfaction as many others with eM Client’s extremely narrow scrollbars. I’m using the Arctic theme. I carefully followed the steps described above (changing False to True) for [True]. The change had no effect on the width of the scrollbars. Actually, I didn’t expect it to. I would anticipate changing a property called something like ScrollbarWidth. Any advice?

1 Like

Once you have exported the theme and edited that line, you need to import it again into eM Client, then select the edited theme, which will be at the bottom of the list.

I did that. I followed all of the steps above. Import, selected my edited theme file, clicked Apply and OK. Even closed and restarted eM Client after that. No effect on scrollbar width, which remains very narrow.

Send me an email and let me know which Theme you want to use. I will modify and send you the theme file. gary@gmx.se

Gary, I sent you the file a couple of days ago. Did you get it?

Yes, and I replied to your email minutes later.

That theme file is already correctly edited. I simply imported and selected it and it looks just right.

You did select the last one in the list after importing it, right? It does not replace the existing one, juts adds a new one on the end.

Thanks, Gary. It’s working now. I sent you a couple of follow-up questions by replying to your email.

The normal wide scroll bars worked like a treat Gary. Thanks for the info :slight_smile:

I just dropped it straight in the EMClient Themes folder in Win 10 - C:\Users\Profile\AppData\Roaming\eM Client\Themes and appeared at the bottom.

Ah, it’s the step of re-importing the edited theme that was missing. That part isn’t intuitive and wasn’t explicitly stated elsewhere. Thanks.

Can I have the wider scroll bar but in auto hide?

Can the scroll bar be made to any width I want or does that have to be done globally through the win 10 system settings?

Yes! it works fine, thank you

Thank you so much Gary for your help! Indeed, it worked only from Menu>Tools.