How can I stop calendar defaulting to UTC?

Sorry, have read through the forums and unable to find an answer.

My EM Client calendar entries are defaulting to UTC. However, my MAC system settings and Google accounts are correct (Melbourne, Australia). Why doesn’t this carry over to EM Client??

I don’t wish to keep updating time zones for every entry - plus all my existing entries have UTC as the preset time zone.

Confirming I am updated to the latest version.

Thanks in advance for your help!

eM Client uses your computer’s date and time settings by default, or those you specify when creating the event if it is different. Unfortunately, if the calendar is synced with an online provider, in some instances that event data can be changed during the sync when the provider and this application are not fully compatible.

If you are syncing your calendar, who is the provider?

Is your computer set to the correct time zone?

Hi Gary,

Thanks for getting back to me. Confirming my computer is set to my local time, as is my calendar account.

All settings in all locations are set to my local. EM Client still continues using UTC so have gone back to using the native app.

I remember some time back I was testing eM Client with one server and the same issue was there. As soon as the event is synced with the server, it defaults to UTC.

Probably some incompatibility between this application and the provider. Who are you using for your online calendar?

Hi Gary, I use Google

The interesting thing is that Google was not the server I experienced the same issue with. 

I just created a new Google account, so the settings there are absolutely the defaults, and unfortunately I cannot reproduce this problem.

Is this only happening with events created in eM Client, or do you experience the same if you use another application?

Gary, think i have the same issue. However, in my case, it has to do with automated booking where I receive an ics invite calendar file. The online system confirms 9 kl, but when I open up the ics file in emclient it always shows minus 2 hours. Same principle with Zoom scheduling. Since I live in an area where it is UTC + 1 hour.
I do many automated bookings with emclient, and it is very annoying that the client always sets the time 2 hours back. I am pretty sure it has to do with the default UTC setting. How do I change the setting to UTC +1 hour.
And yes my system etc show all the correct time.

When you edit the event, as in your screenshot, the original ics data will be displayed. So that will have the time zone that is in the file as it was sent to you.

But in your calendar preview, the event will be displayed correctly adjusted for the time zone and daylight saving (if applicable) that is set in your OS time settings.

But that’s it, its not the case. I am not editing, I am just opening the ics file sent to me in order to save it in my calendar, and the ICS file always shows -2 hours.

Yes, opening it is editing it. That is the original ics details sent to you. The time zone will be whatever they have set it to.

How does it look in the calendar preview?