Gmail stopped working and now won't connect

Connection with Gmail stopped working. Red exclamation. I tried to reconnect several times without success. I removed the Gmail account and tried to add it back. I get the allow em Client access page in my browser. When I allow em Client access it thinks for a little bit looking like it is going to work, but then my browser goes to the google search page. At first I thought em Client was locked up, but then realized the new account window went behind. I brought it back to the front and it has back, finish, cancel. If I click finish, it goes through the same routine with the browser. So I cancel and Gmail isn’t connected. I then uninstalled em Client and reinstalled it. Same issue. My yahoo account connects with no issues. I have em Client installed on my wife’s pc and so far it is still working fine. Any thoughts on why this is happening.

Hello.
It’s very strange what happened to him.
Try adding your Gmail email account as follows.
If your Google account is not suspended.
Open eM Client, check that you have the latest version of the program v.9.1.2109.0. Here you can download the latest version: Release History | eM Client
try to install your Gmail mail, if you still have the same problem follow these steps.
Open eM Client, go up to “Menu” click on “Accounts” “Add Account” “Mail” and click on “Other”, NOT on “Gmail” and “Next”, put your Gmail email, and everything that you ask.
In Spain and I suppose it is worldwide, the incoming and outgoing servers are:
Incoming Google: imap.gmail.com. 993
Outgoing Google: smtp.gmail.com. 587
I hope it works for you.



3

miércoles 17 agosto 2022 :: 0932hrs (UTC +01:00)

Hey @RGL

The first thing to do is be certain you Gmail account is OK
Use your browser to connect to your account.
Have you been making regular eMC Backups?
If so you could try restore of a known working date… Make certain you have a TODAY
Backup before you do any restore.

We do not use Google/Gmail so can not help with speific setup.
Have you checked the settings on your wife’s machine are the same as on your own?

¡Buena suerte!

¡Saludos desde Valencia la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks for the reply. I was not on the latetest when the issue started but when I uninstalled and reinstalled, I put on the latest.

I have tried ‘other’ but it didn’t work either. After I pick other and click next, I get an ‘Identity’ popup window with the only option to enter my email address. The next window is ‘Incoming server’. Here I pick 'IMAP and put in my incoming server, user name and password. No place to enter port, security, etc. Next I get outgoing server with user name and password prepopulated. Again, no port etc. Next I get test configuration. It shows testing for a while, then ‘server not responding’. I continued on anyway and it setup a gmail account but I get the red exclamation. Mye yahoo account works. My wife’s gmail is still working with the older version of emc. Here are some of the popups:




Thank you also. Unfortunately I did not do backups. I can connect with my browser and also with Windows mail. I don’t like Windows mail. I am looking at Thunderbird. It connects with no issues, but it is way different and will require some learning curve. I have been using emc for several years and liked it a lot. But if I can’t get connected, it doesn’t do me any good.

You can’t setup the Gmail account manually, because they no longer support username/password logins.

Please add the account by selecting Add Account, then entering the email address in the Automatic Setup. If the browser part of the setup is not working, set a different browser as the default in your Windows settings, then try the setup again.

Thanks Gary,

I tried the automatic setup first and it didn’t work. I just tried changing my browser. I was using Firefox. I tried Chrome and Edge. None of them work. Edge did ask for my login credentials and sent the message to my phone (I picked yes it’s me) but then acted the same as the others. When I click ‘finish’ it opens the browser (whichever one I have set as default), I click allow and the 'new account box goes behind emc window but doesn’t connect. I can do the loop over and over if I click on ‘finish’.

miércoles 17 agosto 2022 :: 1933hrs (UTC +01:00)

Did you check that eMC is still working on your wife’s machine from my earlier post?
If it is, as a test, make an eMC Backup and transfer this to your machine.
Now make an eMC Backup of your machine in order that it can be returned to is current state after the test.
At this point copy the Backup from your wife’s machine to your machine and run:
Menu ->File ->Restore pointing Restore to this file.
At this point check if you can connect with eMC

If it does connect you now know that it is not eMC that is causing your issue and confirms that it is something on your machine or your gmail account IF it is different from the account on your wife’s machine.

I have presumed that you will have cleaned the browser cache on your previous attempts to create the Gmail account.

¡Buena suerte!

¡Saludos desde Valencia la soleada en España!

skybat

emc_forum@compucall.com

Hablo español, luego portugués e inglés, con conocimiento de varios otros idiomas.

Thanks skybat,

I thought I replied that my wife’s gmail is working on her pc with emc, sorry. She is on version 9.0.1708, as I was until I started having issues. I uninstalled and installed version 9.1.2109.

I did find an old backup from 7/31/2016. I ran a restore of that backup and it asked for my yahoo credentials and connected to yahoo. It gave me the same exclamation point for the gmail account. I then tried what you suggested; restored my wife’s backup on my pc. It came up with her gmail account, but has the exclamation point (connection failed when you hover over it).

edit:
I did clear cache.

I looked at the operations log and every time it tries to connect to gmail it gets an ‘authentication aborted’ error.
example: 2:29:10 PM my gmail address [IMAP] MailClient.Accounts.AuthenticationAbortedException: Authentication aborted

I have seen similar issues in Outlook, haven’t tried EMClient yet with Gmail. You need to use an app password from gmail. Login into your Gmail account, got to your account settings, security, enable two-step varification if not already and create an app password for mail on a Windows computer (or whatever you are running, there are different options) Use that password when using the automatic Gmail setup in EMClient and not your regular Gmail password.

Works every time when Outlook won’t work with Gmail.

In the automatic setup, you are passed to your web browser to authenticate the account. You need to use the account password, not the app password, when doing that.

Gary,
It makes sense that you would use your account password. That is how every other app I use does it. However; this does not seem to be working. It seems to be hanging with the authentication.

Here is what I am doing and how emc/gmail are acting:

  • I put my gmail address in the automatic setup and click start
  • I get the New account window and all is filled in. I click next
  • I pick continue without encryption and click next.
  • The next screen is filled in and I click Finish.
    I see this next:

I get this on my browser

  • I click allow on the browser
  • EMC comes to the front and the new account screen goes behind it.
  • I do not get a confirmation screen from EMC like I do with other apps, saying I have allowed access
  • After a few seconds my browser goes to this:
  • Nothing happens after this point
  • I can bring the new account window back to the front and if I click finish, it opens the browser again. It will continue this loop as long as I keep clicking finish. I cancel at this point and of course gmail is not added.
  • I have looked on my gmail account (security) and it shows emc has access
  • Any suggestions?

Thanks Gary,

I think EMC supports two-step, but maybe Gary can verify.

I have two-step enabled. I think gmail forces this. If I generate a password for my windows pc for mail, will it also allow EMC to connect to calendar and contacts.

Also, to make sure I understand, are you saying when I get the login on my browser, I should login with my email username and the new generated password? I don’t think gmail will let me login with those credentials.

Just a thought, but have you tried temporarily disabling anti-virus. AVG can be particular with affecting email.

I had not thought of that. I just tried with anti-virus disabled and it acting the same. Thanks for the suggestion though.

@RGL

  • EMC comes to the front and the new account screen goes behind it.
  • I do not get a confirmation screen from EMC like I do with other apps, saying I have allowed access

Once you click on the Google “Allow” button to allow eM Client access to your Google account, you are not meant to then get any message to say its been allowed. When the allow window goes away that means its been allowed.

If you want to dblcheck if its works, go to your Google Security section online and

  1. Go to the Security section of your Google Account.
  2. Under “Third-party apps with account access,” select Manage third-party access.
  3. Select the app or service you want to review.

Also 2 step in Google is supported in eM Client and i have used that no problem for years. You also don’t need to use “App Passwords” either with 2 Step. See example 2 Step in Google Security.

cyberzork,

Thanks for the reply.

The allow window goes away, but emc doesn’t have my gmail account loaded. It just sits there with the Account window behind the main emc window. I have let it sit for a long time with no results. I then go to the Account window and cancel.

I know how to check my Google account security. Please see my previous post. I checked and it shows that emc has access.

I too have been using emc for years and it has worked well. It just started about a couple of weeks ago to have issues connecting with my gmail account (exclamation next to that account on the left side). So removed the gmail account and tried to add it back. Didn’t work. Uninstalled emc, Reinstalled latest version. Same results; won’t add gmail account. Still works on my wife’s pc with gmail. I thought it was my pc, but windows mail and thunderbird have no issues connecting to all my gmail account from my pc. I tried to add my account to my wife’s emc and it won’t work on her pc either. I didn’t remove her gmail account and try to add it back because I didn’t want her to loose access if it didn’t work.

@RGL

I would then suggest to remove all eM Client instances / tokens from your Google account Security / Manage third party apps, and then close and reopen eM Client.

If that still doesn’t work, reset your Google password and then close and reopen eM Client.

Failing that if you have any security or firewall security or Antivirus programs monitoring your computer or browsers disable that temporary to test.

Also try clearing your browser’s cache as might be corrupted somewhere.

Lastly if you haven’t already try setting another browser as the default. Any Chromium browser should work fine.

I had tried some of that already, but not all at once. I tried it all and still same behavior.

Blockquote
Once you click on the Google “Allow” button to allow eM Client access to your Google account, you are not meant to then get any message to say its been allowed. When the allow window goes away that means its been allowed.> Blockquote

I know you say I am not meant to get any message, but when I changed my password, I had to re-verify my Thunderbird and it did have a popup window asking if I had responded on my phone. I click that I did and gmail loaded up.

When trying to add my gmail with automatic setup, EMC never asks me to put in my gmail password. Is that normal operation?