GMail Authentication

Since updating to 6.022313.0 I am getting repeated requests to provide my email account passwords.
Can this be fixed or do I have to roll back to the previous version and if so, where can I find it?

Thanks
Peter

Same issue here. Hopefully there will be a patch soon. You can download old versions on the releases page here http://www.emclient.com/release-history although I don’t know if they will work since Google is scheduled to drop support for the old API today.

It looks like Google sprung this change rather unexpectedly and the guys at eM Client were forced to release a poorly tested implementation of the new API.

We had to change eM Client to access Google accounts using OAuth authentication. This was forced upon us due to Google shutting down their password-based logins to Google Calendar and Google Contacts services. The old version will stop working today for these features if you rollback to it. You have to enter the credentials in the new version.

Note that we are aware of issues with some rebranded Google services, such as Virgin Media or oi.com.br. We are currently trying to address these issues and workarounds are available elsewhere on this forum.

The issue seems to be that the credentials have to be re-entered repeatedly with eM Client not remembering it has already been granted access to the account. It’s happening with regular Gmail accounts for me, not just rebranded services.

Hello, if you’re having issues while authenticating with your mail server and being re-prompted for authentication, please make absolutely sure you’re using the latest available release, and that you’re not using any proxy software or firewall that may have caused this issue. In case the issue persists, please download this utility, http://www.telerik.com/fiddler, and navigate to Tools > Fiddler Options > HTTPs > Decrypt HTTPs, save the settings and start capturing traffic using this utility.

To successfully replicate the issue, please open Fiddler and replicate the issue once you’re again prompted for password, please go back to fiddler, save and submit the logging archive to us for more information about the issue.

You can submit the data to mcgregor@emclient.com with a reference link to this forum topic.

Thank you.

Thanks for the responses. I was using the version stated in my post but I see there has been a new release today which I have now installed. Fingers crossed the problem is fixed. I don’t want to go back to Outlook 2013 !!!
Ta to all.

I just installed the 4/20 version. When I enter the pw and click Sign in nothing happens. I am already signed into my Google account and have no issue accessing GMail directly.

Tried again. 1st retry took me to permissions, Accept. That returned me to the authentication window again. Re-entered the pw again and that time it worked.  Flaky.

Twelve hours later the problem seems to have been solved by the new release, 6.0.22338.0
Thanks for the fix.

Pushing my luck can I post the top items of my wish list !
A rule import, by account, from Outlook
A ‘always move to’ rule create right click option for emails in an Inbox.

Thanks

I’m also happy to consider this issue resolved. I’m not sure if it was from re-adding all the accounts or updating to the new version but either way it seems to be fixed.

Glad it works, please make sure to let us know if you come across any other issues or questions about the application, we’ll be happy to help.

Oh deer. It’s started happening again. It seems to be a particular problem when I resume my computer from standby. I’ll do my best to get a Fiddler log for you guys.

I think the problem is something to do with not having an internet connection during a sync. eM Client seems to decide that means the OAuth token is no longer valid for that account.

Hello again, I’m not completely sure what exact release you’re using on your computer now, but please try to update to this release as there was a couple of more fixes, 6.0.22336.0 .

I’m currently on 6.0.22328.0. The automatic updater seems to say it’s the latest version. I’m unsure whether I’m ok sharing the full Fiddler log since it contains OAuth tokens that may or may not still be valid. I will summarize the log as best I can.

Firstly a request is made to www.googleapis.com/oauth2/v3/token. No authorization is sent. It contains the parameters

refresh_token=[redacted]&grant_type=refresh_token&client_id=920743529221-8ikrugee0v4sdcthfsven8cgmjfr85qd.apps.googleusercontent.com&client_secret=[redacted]&redirect_uri=urn%3Aietf%3Awg%3Aoauth%3A2.0%3Aoob

The response is
374{
 “access_token”: “[redacted]”,
 “token_type”: “Bearer”,
 “expires_in”: 3600,
 “id_token”: “[redacted]”
}
0

Next a request is made to www.googleapis.com/userinfo/email with the authorization of “Bearer [access token from previous response]” and returns a 503 error code and the response

dBackend Error
0

Then the authentication page is loaded. I believe part of the issue is that eM Client is deciding that a wide variety of errors mean OAuth tokens have been revoked when in reality they might just mean the server is having problems.

I can send you a more detailed log if you really need it but I would prefer not to if it’s not needed.

If you’re a developer like me, it seems that when you run a debugging proxy (like Charles, Fiddler) on your machine, it breaks the OAuth and forces re-authentication.  

I am on 6.0.22344.0 and after a while without the annoying questions for gmail credentials it is now back again. 

Can you please fix that asap ?!

Thanks, Urmel

I am on version 6.0.22344.0 and I continue to have the Gmail problem of: request for login, password, and acceptance of permissions whenever I return to the program from sleep or standby mode.  This is occurring multiple times while remaining connected to the same, stable internet signal.

I am also on version 6.0.22344.0  and have the same issue.  Very annoying problem.  Please find us a fix asap

Ray

i’ve got the same problem. :confused:

Hello Urmel, not completely sure what you’re referring to, the OAuth, Gmail authentication window should not reappear using the latest release that you’re running, but if you’re still experiencing the issue and being re-prompted for password, what do you mean by “without the annoying questions for gmail credentials”, are you seeing an OAuth window without the option to use your credentials?

Are you using any proxy utility on your computer or possible moved to a different network with your computer?

Hello Justin and Peter, are you by any chance running any proxy utility on your computer? Are you able to replicate this each time you put the computer to sleep?
If so, please send me an email to mcgregor@emclient.com with a reference link to this forum topic.

Thank you.