Events on calendar disappear immediately

Started having this problem about a week ago. When adding a new event to my calendar I go edit each tab, general, recurrence, scheduling and frequently attachments. Click on Save and it appears on the appropriate date, then disappears less than 2 seconds later.
I checked all my other devices to see if it just wasn’t visible, nope its gone. If I use a device to create the event it appears almost instantly in emclient


What calendar protocol are you using? CalDAV, Exchange or Google Calendar?

i just had the same problem. entries just disappear after about 2 seconds. i am using google calendar.

Hello Mario,
what version of eM Client are you currently running? Can you copy the full number from Help>About section?
Is this your own calendar (belongs to your google account) or a shared one?


hi olivia

tried to reply - without checking on the sender address - so here we go:

it is my own calendar and the version is

Hello Mario,
please install the latest available version and see if the issue continues: 7.0.27943.0


will do - however it happened twice for one particular event. i then entered it directly in google calendar. then i entered another event - same day, different time - and that went without a problem. more after the update.

tested again before the update: no problem
tested after the update: no problem

it has happened again! i wanted to add an entry into a day where my wife had an entry on her calendar (we are sharing) and also showed a public holiday. my new entries showed up a second in the colour of her entry then dissapeared. i stopped sharing her calendar and reentered. this time it showed up in the colour of the public holiday calendar, then dissapeared. after i also stopped the public holiday calendar i could make a new entry that stayed and showed in my colour. after sharing the other calendars again everything is working as normal. now i can add entries and they stick.

1 Like

Experienced the same issue. But the reason (in my case) was trivial: I display several shared calendars (my wife and children) in eM Client and the issue occured exactly when different than my own calendar was “clicked” in left “calendar tree”. De facto, I tried to add an event into my wife’s calendar, which is read only, so the event disappeared immediately. Of course, I would much prefer the transparent message about permission problem, or adding into my own calendar as default behaviour, but…

I am having this problem, but I don’t see the actual solution outlined anywhere in this post - can someone tell me how to fix it?

1 Like

did you ever find a solution to this?

1 Like

I have same problem today … new calendar entry is gone within second.

1 Like

The first thing to check is that you are creating the event in a calendar to which you have write access as Václav discovered.

The problem Mads was having, looks like he was trying to save the event to a read-only calendar. When he saved it to his own, then it remained. One problem with eM Client is that there is no indication whether the calendar is read-only, nor does the app prevent you from creating an event in a read-only calendar until the amazing disappearing event. When I first started using eM Client, I had created an event with lots of information - participants, notes etc. only to find it disappear after a few seconds because I had not selected a calendar to which I had write access. And there is no way to get it back. Only happened a few times before I learned from that “feature”.

New events are saved by default to the focused calendar. So one method to create an event in the correct calendar is to first select that calendar before you create the event. The other is to select the calendar in the new event window. (see my arrow below) As with a few other things in eM Client, it may not be obvious that you can change the calendar. Maybe a drop-down arrow next to the calendar name would be useful.

1 Like

the problem is caused by the fact that when you click on a read-only calendar yours it is still showing as if nothing has changed. it would help if you could declare a default calendar - your own. ok - if you have different ones then that wont work either. but there should be away around that.

I have been having this problem the last few days too.
I found if I restarted eMClient it would add a new event ok, but now that is not even working.
The calendar isn’t read-only to my knowledge as it is one I created myself as a local calendar.

I went back and turned diagnotics off, had turned them on for Calendar the other day when trying to identify sync issues.
didn’t seem to make any difference when creating new event on the calendar space, item still disappears. Howver I have more success when creating a new event from the pull-down menu on the toolbar - which implies at least it can’t be a read-only calendar issue.

As Gary said above you need to check the calendar focus, but you can’t do that if entering a new event directly in the calendar view. 
As Mario said above one needs to be able to create a default calendar.

it would be great if this issue was addressed - along w others :slight_smile:
as a personal user it is annoying enough, can’t see how business users can get by with the bugs I see everyday.

I am not so sure it is an issue as an intentional feature. The event will be created for whichever calendar you are in, unless you change it in the new event window. The same as with email. It does not matter which email account you have selected as default, the account folder you are in when you create a new email will be the from address. Fortunately, in both calendars and email you can change that when creating the item. It just takes some repetition before it becomes normal procedure.

That said, I would certainly welcome an option to set a specific account as default regardless of which folder you are in when creating an item.

good point.
and I have just realised something. doh.
I am using dark theme and it isn’t obvious that calendar (or email for that matter) has changed focus. focus is highlighted as dark on dark!!