emClient 9 creating incorrect reply-to address

I have emClient connected to my outlook.com mailbox via EWS. When I send a mail, the reply-to address is incorrect - it’s obviously reading it from outlook somehow - the address structure is

imceaex-_o=first+20organization_ou=exchange+20administrative+20group+zxxxxt+29_cn=recipients_cn=xxxxx@namprd00.prod.outlook.com

and this address is unreplyable - so people can’t reply. I don’t have this problem with other email clients on the same account (outlook, mailbird are both fine). If I connect emClient to this mailbox by IMAP, it’s fine, but then I guess it’s not syncing this info from outlook.com. IMAP is no good for me though since it doesn’t sync my sent mail.

If I override the reply-to on an invididual message, that works, but not if I set it to the same as my normal email - sadly, it’s smart enough to ignore that.

So, why does emClient pick up an incorrect email address which other apps don’t, and/or how can I override it?

pete S

The primary logon on my account is an alias. I wonder if this is the same problem as reported back in 2017 Setting up outlook.com alias - Mail - eM Client. Does emClient not support aliases on outlook.com still?

Any thoughts on this? From other comments, it seems like this has been around for quite a while - basically you can’t use emClient if you use aliases on outlook.com as the reply to address is incorrect. Been around since 2017. I’ve had to give up on emClient completely sadly and go back to Windows Mail :frowning:

You normally just put your alias email address for both your “email address and reply address” in your Outlook account via “Menu / Accounts”.

Have you tried doing that ?

Hi @cyberzork . Yes, sorry, my earlier post was more explicit. When I say using aliases, I mean as your primary login. So, I have a custom domain, and an associated email address - outlook.com allows you to link a godaddy managed domain to your outlook.com account. I never use my outlook.com address. emClient doesn’t seem to be able to cope with using aliases as your primary logon. If I change the primary login to my outlook.com address, then the replyto address is fine. I’ve tried a few clients, and only have this problem with emClient.