Emails in eMClient going to Junk while Gmail correctly does not route them to spam

I and many other people using this program have had issues with TONS of emails from friends, etc. getting routed to spam folder when they should not be. In Gmail I created some rules to NEVER send emails from any of my contacts (including myself) to spam. It works well on my phone, but when I open emails on my home computer in eMClient they invariably get routed to spam. It’s very frustrating because even if I select “move to inbox and remove blacklisted email” eMClient NEVER fixes the problem. It’s bad enough that I’m thinking of using a better email service program. Any suggestions to fixing this within eMClient? Again, it’s not Gmail routing it to Junk Email, it’s specifically eMClient.

This really depends on what is moving the messages to Junk to begin with.

Normally, it is your server, so you will need to login to their webmail interface, select the message in spam, and mark it as not spam. Thereafter the server should always leave messages from that sender in the Inbox.

If the message is moved to spam by your server, using eM Client to move to Inbox and remove blacklisted will not have any effect.

But it can also be caused by eM Client moving the messages if you have previously blacklisted the sender or their domain. If that is the case, go to Menu > Rules and edit the Blacklist Rule if you have one. The Blacklist Rule will be in Local Rules, selected from the dropdown option next to the New Rule button, not in server Rules, so make sure you are in the correct section. See if the sender’s address or domain is in the list and remove it.

Thanks for the reply. In eM Client I see the same rules I created in Google for not routing emails from any contacts to spam, but there are no other rules in eM Client. The very frustrating part is the eM Client is doing all this on it’s own rather than just taking the emails from Google and placing them in the same folders! Why can’t eM Client just keep emails in the same folders as it finds them rather than moving them to Junk after grabbing them from Gmail?

eM Client will only move messages to Junk on your instruction. So only if you added the email address or domain to the Blacklist Rule.

Look in Local Rules (not server Rules) and edit the Blacklist Rule. If eM Client is moving the messages, either the sender’s email address or domain will be listed there. The only way the address or domain can get into the Blacklist, is if you added it yourself. Maybe you did it unintentionally, like if you Blacklisted a whole domain. If either are there, remove them.

Okay, I just found the Local Rules section that had a box with Blacklist and another box. I deleted them both and hopefully that will correct the problem. It’s strange that eM Client would just randomly add a Local Rule like that which is obviously causing a great many users a lot of grief. If they can change eM Client to default install without those Local Rules we’d all be happier I suspect.

eM Client doesn’t do that. As I said the only way the address or domain can get in the Blacklist, is if you added it. There is no other way.

Is it possible that by doing some action when opening or reading an email that it can create a local rule? I never new about that section and never added the server specific rules either, the server specific rules got imported by eM Client from Gmail which I would expect it to do. Since I had no idea about the Local Rules and have never specifically added a rule of any sort in eM Client it seems weird that they would be there. I’m just hoping this will finally cure my woes.

The only Rule that is there by default is the Spam filter Rule. That is a Rule that only applies to POP3 accounts, so it will not be affecting your Gmail account at all.

Any other Rules, Blacklist or otherwise, will only be there because you created them yourself. It requires a few clicks so it is not really possible to do it by mistake. For example if you want to add the sender’s address to the Blacklist, you will need to right-click in the email and choose Move to Junk > Move to Junk and Blacklist email. The same if you wanted to create a standard Rule. You would need to right-click and choose Create Rule from message > then select one of the options. But we don’t have an option in that section to move to Junk. It would take quite a few more intentional clicks while editing the Rule to change a standard Rule to do that.

So if the address or domain is in a standard Rule or the Blacklist Rule, then you added it.

1 Like

Sorry, this cannot be true. I have done everything you suggest - over and over again - and nothing changes. I have checked every backlist, etc. The server is Gmail. All addresses sent to spam are on my white lists.

Is there anything else you can advise?. I have been with you for about 12 years and never had any problem like this. Am I missing something?


I have done everything you suggest - over and over again - and nothing changes. I have checked every backlist, etc. The server is Gmail. All addresses sent to spam are on my white lists.

If your Gmail account Inbox emails are showing ok online in your Inbox, but going into the Junk folder or another folder in eM Client, then you normally have some sort of rule setup in eM Client causing that as @Gary advised.

So as you cannot find it in your eM Client rules, Try then for a test “unchecking everything in your Local Rules” and then close and reopen eM Client. Then see if your Gmail inbox emails stay in your eM Client Gmail inbox.

Also as @Gary advised you in another thread on this subject, you may have added the Gmail domain to your Blacklist, so “dbl-check your Blacklist again” via either Manage Blacklist, or via “just dbl-clicking Blacklist in the Rules window”

Much thanks for your time and advice. I’ll check it out soon. Do you know if there is a way to save the rules data to reinstate after testing without rules?