eM Client has no longer access to my gmail

Since my internetprovider updated the modem-software (and gave me a.o. a new IPv6 address) the connection to gmail.com is blocked for eM Client (free version) on my Win10 PC.
I tried to fix the problem by removing and adding the account, by removing and re-installing eMclient, but nothing worked.
The next step was try a different mail app (Mozilla) that uses the password, and there was no problem. So the problem is the way eM Client connects to gmail - without using the password that protects my mailbox. I tried to do the same in eM Client but there is no way in eM Client to add an emial-account with the password to use for the connection. After adding my gmail-account google asks me to confirm that it is OK, and google-settings show that eM Client is granted access, but it doesn’t work.
Is there a way around to let eMclient use the password to connect?

1 Like

miércoles 01 septiembre 2021 :: 1358hrs (UTC +01:00)

Qué tal @RobK

First Item:

I know nothing of your computer its setup or your ISP, however, on my test laptop with eMC
installed with 3 Gmail accounts (1 POP3 & 2 IMAP) other accounts (1 Exchange, 2 IMAP & 2 POP3)
with both IPv4 & IPv6 configured.
I do not have any problems receiving emails, all my mail is sent via a dedicated SMTP server that is independent of the ISP for Gmail and the other 2 ISP’s in use.
Remember you will need to enable:
IPv6 in your LAN, [vEthernet (LAN), vEthernet (WiFi) both are a Hyper-V Virtual Ethernet Adapter]

Second Item:

If you have IMAP this will sync with your new client.
ALSO
If you have a problem with email Export/Import you can use a 3rd party utility to overcome the issue.

https://www.aid4mail.com/

It works very well we used it when upgrading from Eudora (10’s thousands with no errors)

¡Saludos desde la soleada Sevilla en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo principalmente español, portugués e inglés, también un conocimiento práctico de varios otros.

I’m running into this, too-- but with BOTH EMC & TB!

I even tried to manually set-up the acct. with the settings recommended by Gmail and it simply won’t allow the connection!?

It is similar to my problem; the update my ISP gave to my modem should give better security but it now prohibits access to my mailbox. However .in my case Mozilla thunderbird has no problem.
eM client does something extraordinary with gmail, i.e. connect without using the password. I tried to add my gmail account as “other” mailservice so I could add my password but eMclient still gets no access with the message “invalid password” (I doublechecked that it was the right password, the same that gave TB access).
And all the time my google-settings tell me that full access is granted to eM Client (and to my smartphone)
Something that eMclient and Google should explore and solve together

“…eM client does something extraordinary with gmail, i.e. connect without using the password…”

@RobK Right! That’s what was happening with me, too. I wasn’t being asked for a password, it asked to allow EMC, I clicked “accept” the Google terms, EMC opened with a red error next to that account.

I didn’t have any luck using “other” mail service and inputting everything myself-- same error.

WT actual F is going on???

Can you go to your Google settings: https://myaccount.google.com/permissions?continue=https%3A%2F%2Fmyaccount.google.com%2Fsecurity

Remove the eM Client certificate. There may be more than one, so delete all eM Client certificates.

Restart eM Client and it should ask you to re-authenticate for oAuth.

When that is done, are you able to sync the Gmail account?

What I suppose is that some security-measures or settings that your and my ISP have made prevent the way of access. Or maybe the problem is in google’s environment as in your case both mail-apps are refused, in my case Thunderbird works fine.

Thanks @Gary I didn’t try that, I will later, for today I’m tired of these problems

1 Like

I have to wait until I can contact my friend again.

/off topic rant
Regardless, I’m a techie-person, capable of helping-- what is a regular human being supposed to do? This sort of stuff is becoming ridiculous, really. Between MS & Google, they spend more time breaking and dodging complaints than working on anything which actually helps people. I’m personally suspicious of all of their (& Amazon’s) “listening devices” that people welcome into their homes? And Win 11 insisting on a camera on mobile devices to install? I am def not a conspiracy-theorist, but no thanks. Can’t even get an email through as they work to tighten their surveillance, is my call.

PS: I run Linux. I wouldn’t touch Apple nor M$ if you paid me.

/off topic rant ended

Well, @Gary and @TThompson, I tried out the suggestion of removing my account from eM and removing the granted access for eM in my Google-safety setings. After adding my gmail account again in eM the result was the same. A red triangle says that eM cannot connect to imap.gmail.com
I’ll have to say goodbye to eM forgood

This may be caused the router. Is it possible to connect to another network, like using your phone as a hot spot, and see if there is any difference?

That my modem/router is part of the problem is clear; it all started after my ISP updated the software.
For now I can access my mail on the smartphone and with Mozilla TB, and I hope that changing of ISP will solve this forever.

viernes 03 septiembre 2021 :: 1317hrs (UTC +01:00)

Hi @RobK

For the sake of others can you say which is your ISP?

¡Saludos desde la soleada Valencia en España!
¡Mis mejores deseos y mantente a salvo!

Skybat
emc_forum@compucall.com

Hablo principalmente español, portugués e inglés, también un conocimiento práctico de varios otros.

My current ISP is “KPN”, as far as I know only active in the Netherlands. I’ll switch to T-Mobile and hope there will be no problem in their connection.