eM Client 6 Released

I am happy to announce that we officially released eM Client 6.

Download link:
http://www.emclient.com/dist/v6.0.196…

New version includes these new features and enhancements:

  • Microsoft Exchange support (Exchange Web Services)
  • Full Touch support
  • Support for calendars on Outlook.com (former Hotmail or Live)
  • Deduplicator tool
  • Reworked calendar allows displaying more events than before
  • Subject editing
  • Customizable reply and forward headers
  • Spell checker in chat, subject and other fields
  • Customizable shortcuts
  • Improved GMail and Google apps integration
  • and much more

Great!
Onto version 7 with conversation view!

Still Exchange related issues in the final release :frowning:
I installed EmClient in VMWare to make sure that the problem is not related to some kind of database corruption. So clean install.

Using Exchange, the most recent email is not shown in my inbox, I see all emails but the most recent one?? In the OWA and in Outlook 2013, all emails are shown.

In addition, email flag sync is still missing. Is there no way to fix this? Supporting ONLY Exchange 2013 is a bad decision, as most companies DO NOT use it today.

Even more wierd: I just sent myself an email, the new email is shown in the inbox. However, the previous email is still missing!! The email that is missing has a large attachment (12 MB), perhaps this is causing the problem? Really, this is a serious bug, when some emails are not shown!

Please look into that soon!

I enabled logging on the exchange account to send the log file to you, but no log file was created for the exchange account?

OK, tried it myself. I sent me two emails, one without an attachment, the second one with an attachment of 16 MB (rar file). OWA shows the email, emclient NOT!

Beside the slower performance I like the release.

OK, found the logs… my mistake :confused: I was looking for them in the wrong folder. But the error that EM Client does not receive emails with large attachment over Exchange is reproducible here. Tried a clean install of EM Client in Vmware now two times, in both cases the same result: Emails with large attachments are not synced.

Hi,

I have received logs from you but, those are IMAP not Exchange… please send me Exchange services logs and send them to my email galis@emclient.com

Jan

Yes, those logs were regarding another issue using IMAP. Were you able to identify the IMAP problem?

We support older Exchange versions (2007 SP1+), but unfortunately not with all the features due to protocol limitations. Synchronization of flags is supported only in Exchange 2013 (http://goo.gl/LFbGBK). We may implement workarounds for older Exchange versions in future.

OK, thanks for the info. I’ll try to live without email flagging for now. But the issue with emails not showing up at all is worrying.

Hi Michal,

Is there a detailed change log including information such as bugs fixed etc. available?

Thanks,

Chris

event reminder issue still there…and now an app crash on every start…

eM Client (6.0.19690.0)
Windows: Microsoft Windows NT 6.2.9200.0, Framework: 2.0.50727.7905
The following error has occurred:
System.ObjectDisposedException: Cannot access a closed file.
at System.IO.__Error.FileNotOpen()
at System.IO.FileStream.Write(Byte[] array, Int32 offset, Int32 count)
at System.IO.StreamWriter.Flush(Boolean flushStream, Boolean flushEncoder)
at MailClient.Utils.Tracing.SafeFileWriterWithTimestamp.Write(String value)
at MailClient.Utils.Tracing.SafeFileWriterWithTimestamp.Write(Char[] buffer, Int32 index, Int32 count)
at System.IO.TextWriter.WriteLine(String value)
at MailClient.Jabber.JabberManager.jabberClient_OnWriteText(Object sender, String txt)
at jabber.connection.XmppStream.jabber.connection.IStanzaEventListener.BytesWritten(Byte[] buf, Int32 offset, Int32 count)
at jabber.connection.SocketStanzaStream.bedrock.net.ISocketEventListener.OnWrite(BaseSocket sock, Byte[] buf, Int32 offset, Int32 length)
at bedrock.net.AsyncSocket.WroteData(IAsyncResult ar)
at System.Net.LazyAsyncResult.Complete(IntPtr userToken)
at System.Net.LazyAsyncResult.ProtectedInvokeCallback(Object result, IntPtr userToken)
at System.Net.Security._SslStream.StartWriting(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
at System.Net.Security._SslStream.WriteCallback(IAsyncResult transportResult)
at System.Net.LazyAsyncResult.Complete(IntPtr userToken)
at System.Net.ContextAwareResult.CompleteCallback(Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Net.ContextAwareResult.Complete(IntPtr userToken)
at System.Net.LazyAsyncResult.ProtectedInvokeCallback(Object result, IntPtr userToken)
at System.Net.Sockets.BaseOverlappedAsyncResult.CompletionPortCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* nativeOverlapped)
at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)

Had to completely uninstall and remove data folder.
used exported settings after re-install…
Still getting a reminder that wont dismiss, but i went into google and removed it’s reminder setting.

I’ll keep an eye on new ones…

BTW, my export of settings did not include signatures…wasnt that supposed to be in v6?

+1 - really a missing feature: Settings should be complete!

App crashes: Had 3 crashes since release of 6.0, but only 1 during beta and RC phase. ?!

The uninstall and full clean seemed to help the crashes…

I still can’t get exchange setup to work for me. The new manual exchange setup that was added after the beta is a step closer, but its settings are too limited. I need to be able to manually specify both the internal and external exchange server addresses (EWS auto-configuration never gets this right with my work’s exchange server), and I need to be able to enable SSL for both or else it won’t work (these are the settings I’ve needed to change when setting up exchange EWS in other mail clients, such as apple mail)

(and yes my workplace’s exchange server is 2007 or newer, its using 2010 afaik.)