Dragging emails to Gmail folders doesn't work any more

Version8 seems to have broken the ability to drag an email from my Gmail account inbox and drop it into an existing Gmail “folder” (which of course is really just a label as far as Gmail is concerned).

I’ve noticed this happen several times and now I feel I can’t trust it to do the job. Instead of adding the folder label to the message, it merely deletes the “inbox” label, meaning that the message actually gets dumped into “All Mail” without a label, when it SHOULD inherit the label for the folder I’m dropping it into.

Bizarrely, if I drag the message from the AllMail folder and drop it into the folder (the same folder I tried to drop it into before), it DOES inherit the correct label and the message appears correctly in the folder I wanted it in.

What happened in v8? This worked perfectly in all previous versions of emClient!

If you can’t fix it, I want v7 back.

Regards,

Tony Heath.

@Tony14 I personally don’t have a problem dragging emails from Gmail inbox to any Gmail sub folders with V8. Could be you might have an eg: earlier older version. Check out the latest V8 via the release history page. Before installing any new update, click “Menu / Backup” to first backup your current version.

https://www.emclient.com/release-history?

@cyberzork No it’s 8.0.2951 - the very latest version according to the release history. Have you got that version yet? It’s only a week old. It’s certainly been happening all the time since I installed that update, possibly the one before too I can’t remember.
[EDIT] - I just tried a couple of moves right now and they worked ok, so it’s not easy to repeat the problem - the worst kind, an intermittent one!

@Tony14 yes I have the latest version 8.0.2951.

Along time ago I had that issue in the early V8 Betas, but with the later release versions that problem seemed to go away eventually.

I would suggest to remove your Gmail account and Re-create as new account again & see if that resolves it. Might be a corruption in the existing Emclient database on your comp.

I don’t really want to remove the account as it took me ages to set it up and it was a long time ago so I don’t remember how I got it just right!
I’ve done some further tests this morning to try to pin it down, and I can reproduce it now.
If I move a message (by drag and drop) to another folder, it actually goes there. However, as soon as I go to the folder the moved message is visible briefly and then vanishes before my eyes. emClient is applying the correct label, but as soon as I look in the folder it removes that label so the message vanishes from the folder and only appears in AllMail.
BUT if I move it back to inbox and try again, it WORKS.
All further moved messages during that session move perfectly,
However, closing emClient and then running it again, the FIRST message I try to move to another folder suffers the same fate, and every other moved message after that behaves again until I close the program and reopen it.
So, the error occurs only on the first moved message after starting emClient. All subsequent moves behave until the program is restarted.
I close the program overnight so that my backup routine can copy files (it can’t copy open files). This problem therefore strikes once a day, on the first moved message. That doesn’t sound like an account database corruption to me, sounds more like a glitch in emClient. Also, now I know when it happens, I can deal with it. It’s a bit naff but at least I know when it’s going to happen rather than having it happen randomly without my knowledge :o) I look forward to the next version in the hope of a cure!
Tony.

@Tony14 yes that disappearing problem after a few seconds when moving Gmail messages from the Inbox to Gmail sub folders & then only showing in All Mail exactly happened to me on early Beta V8 builds which I reported prev too & was resolved in later builds for me anyway,. I will re-test mine again and see if I can replicate that same problem again.

Btw - Does this happen for you with or without attachments or both ?

@Tony14 I have retested dragging emails (with & without attachments) from the Inbox of Gmail to any Gmail sub folder and is all working fine for me currently. The emails are not disappearing after they are dragged to any sub folder like they were in the early V8 builds. I cannot replicate that problem now.

If your Gmail account is a standard IMAP account, i would still suggest to remove your Gmail account from EM Client and add as new and your Gmail email & folders etc will all come back. Obviously EM Client will need to re-read / cache all your old messages, but its the only way to troubleshoot it.

Ps Remember to Backup your current EM Client first via “Menu / Backup”.

@cyberzork I’ve now tested with and without attachments, same problem either way, and still only on the first email I move since starting emClient.

In case it’s relevant, when I move a message to another folder I often mark it as “unread” just before moving it so that it is left as unread in the destination folder until I’ve dealt with it. This is pretty much guaranteed to cause the bug to occur on my system with the first moved message. I did have one instance today when moving the first message and leaving it as “read” and it didn’t vanish, but when I tried that again later (re-running the program again of course) it vanished again.

It won’t be as simple as just adding my account back in, I have various settings and aliases which would all have to be set up again, frankly it’s easier to live with the bug until it can be rectified or somehow sorts itself out like it did on your system. I’m experienced at PC stuff but I’m no guru and I’m not keen to mess with something that’s still (mostly) working in case I end up breaking it!

@cyberzork I tried a different test this morning and instead of moving the most recent message (which is what I normally do, working backwards from the bottom of the list) I moved the next one up.

This time, the message I moved stayed in the destination folder, but the most recent message in the inbox (which I hadn’t even looked at yet) disappeared and I found it in AllMail. Yes, emClient had taken away the “inbox” label from a message I hadn’t even read yet! Aaaaargh!

Looks like removing my account is going to be on the cards then, as I can’t have an email client randomly taking emails out of my inbox, that’s just dangerous.

If I backup emClient the way you mentioned, and if my attempts to add my Gmail account and all its settings fails in some way, would restoring emClient from backup at least bring me back to where I am now with all my settings and aliases intact?

Thanks for all your help with this :o)

@Tony14 yes when you restore the backup, all your existing Gmail folders , settings , rego etc are restored. I’ve done it a few times before for testing purposes. Back it up twice via menu backup to be on the safe side.

I would personally uninstall EM Client and then (delete the database) part way through the uninstall when asked. Then download the latest version from the em version history page and install that and setup gmail as new account & see what happens.

Or

Uninstall EM after doing backups and again delete the database on uninstall and then reinstall the latest version from the em history page and straight away restore your backup (without setting up as new account).

I’m having the same problem as @Tony14 although I currently don’t have the patience to try different things to determine a pattern.

I don’t mark my emails as “unread” before moving them so I can say that this is not a cause. I also have had this happen to multiple emails I’ve moved around the same time so I don’t think it has to do with being the first one after starting eMClient. Today I noticed another quirk. After moving an email from a folder back to Inbox, eMClient showed both the original folder label AND the Inbox label and the email was in both folders! I tried it again but was unable to duplicate it.

Is there a way to identify all emails that are not in any folder without scrolling through All Mail one by one? I’d like to be able to easily identify them and put them in the correct folders before the list of these gets too big.

Other than that, I’ll wait to hear the results of @Tony14 's re-installing his account.

If you are accessing a Gmail account you can go to the web interface and use the following search to find messages with no labels.

-has:userlabels -in:sent -in:chat -in:draft -in:inbox

1 Like

Hi everyone,
it should still be possible to drag and drop messages to other folders.
Please try this newest update if you still experience any trouble - https://www.emclient.com/dist/v8.0.3283/setup.msi

@Olivia_Rust It’s always been possible to drag and drop messages to other folders, the problem is trying to persuade emClient to make them STAY THERE!
I’ve just tried the update you recommended - strange that it wasn’t available as an official update through the program itself, I had to download the MSI and manually install it. However I’m pleased to confirm that without doing anything horrible like uninstalling or rebuilding databases etc, I am no longer able to replicate the problem I was having (moved messages losing their labels as soon as I look in the folder I moved them to), so far so good :o) It would therefore seem to have been an emClient problem all along, rather than a corrupt messagebase or anything else frankly.
I also note from the FAQ that if I had uninstalled and gone back to v7 to deal with this issue, I could have lost my locally saved folder messages because the v8 database isn’t compatible with older versions - you can upgrade to it but you can’t downgrade so anything that’s not been carefully exported and saved elsewhere will be lost unless reinstalling v8 again. SCARYYYYYYYYYYY!
Note to emClient programmers, PLEASE do not let this happen again, it’s extremely frustrating to have emails disappear from the folders in which they have been carefully filed. These could be health insurance invoices, car insurance renewal notices, medical appointments, all kinds of critically important things, really it’s like having someone grab the contents of your in-tray and fling some of it in the dustbin.

@Olivia_Rust Oh no, I spoke too soon, it did it again today, dragged/dropped a message from inbox to a folder, went to the folder, did a manual refresh and the message vanished before my eyes and ended up in AllMail without the folder label. Dragged it to folder again and it stayed there through the next refresh. So it seems I can no longer trust emClient to leave a message where I’ve put it, and will always have to go to the destination folder and do a refresh to check it has stayed there. That’s really infuriating…

1 Like

Hi Tony,
if the issue keeps happening, we will need IMAP logs to analyze the issue further.

Please go to Menu>Settings>Advanced
Enable IMAP logging for the affected account
Restart eM Client
Replicate the issue with a specific message (note down its IUD from right-click>Properties, where you tried to move it and time this happened)
Send these details and the log files (location set in Advanced settings) to olivia@emclient.com

Thank you for your cooperation.

@Tony14 Was this issue resolved? How?

@Peter_Bedell No, it wasn’t. Last contact from anyone was 25th August asking me to replicate the issue and send the log files in, which I did, I got acknowledgement and that was the last I heard. I’m so fed up with the issue (which didn’t exist in v7 as far as I’m aware) that in the last 24 hours I’ve gone through several thousand locally stored emails and uploaded the ones I want to keep to Gmail, so now I have none stored locally. That means I can delete v8 entirely and start again with v7. I couldn’t even backtrack to v7 without going through that because of the v8-v7 database incompatibility which could have risked me losing my locally stored emails. I haven’t done the downgrade yet because I’ve got various aliases and other settings which I need to record before I finally delete this horrible “upgrade”!
Rgds, Tony.

You can always login to Pro License Support and increase the priority of your ticket.

@Gary No I can’t, I don’t have the Pro licence, why do you think I’m on here? :o)