Deleted mail reappears in Inbox (8.0.2951)

On default IMAP based email account when I delete email it appears in the trash folder but also reappears in the Inbox. Does not occur on other IMAP, icloud or Exchange accounts.

Also now seems to happen with rule to move spam missed by inbuild spam filter to Junk E-mail folder - same occurs if move to a different non-system folder.

1 Like

Happening to me too so frustrating needs to be fixed asap has happen with last two versions i have uninstalled and reinstalled still same thing

Same here. It marks them as deleted. Then I empty trash, they dissapear momentarily and then reappear.

My mail box is plain gmail. And have disconnected the account and reconfigured it, problem persists.

I have the same problem.

1 Like

It also appears to be intermittent. Earlier to day worked fine but this evening moving email to any folder resyults in the mail being moved and reappearing in the inbox.

Happening to me with gmail too. Any sign of a fix for this?

It seems to be a problem for me if my iPad decides to connect to the IMAP server at the same time as Em client.

I spotted this in the IMAP server logs as I run my own mail server and since turning off the iPad while using Em Client it does not seem to be a problem.

I know this sort of defeats the purpose of em client but it seems like it is happening only when you delete and/or archive from em client. if i delete 10 msg on em client, then i log into gmail.com, i’ll see 5 of them still there. 10 secs later those 5 email will appear in em client again. if you delete/archive everything directly on gmail, then it actually deletes/archives.

Is this ever going to be fixed?

I have this issue every day on all my google accounts access via EMClient. Its worked fine for several years with no issue now happens all the time. often takes 2 or 3 deletes before finally they stop reappearing. Very frustrating to have to repeat.

version 8.0.3385

Same thing happens in unified inbox when marking ‘all mails as read’ in the component gmail accounts…

very frustrating. emails deleted/archived on browser and ipad actually get deleted/archived, it’s only on the em client we’re having this problem.

hi, any update on this?

Can you make sure you are using the latest version available to download from the Release History and see if there is any difference.

just downloaded 8.1.876 and not getting the issue so far.

thanks

2 Likes

I’m a new user - just downloaded the app yesterday - and exactly that problem occurs. It makes your nice app unusable - I have to log in to gmail every time I wan’t to delete the mail.

When I click ‘delete’ message is marked with Tag “Trash”. When I’ll go to trash and mark to empty the trash - that message disappears but after one/two seconds it comes back. When I click ‘Shift+delete’ it also disappears for one or two seconds and come back.

When I delete it through gmail itself - it works fine.

Can you update to the latest version in the Release History and see if there is any difference.

Thanks for Your fast reaction.

As I said - I’ve downloaded and installed app for the first time yesterday. I’m using version 8.1.1087 (d63975c). At that given page last version is 8.1.1060.0 - so I would have to downgrade to that version. Is it correct?

No, 8.1.1087 is a newer version although it is not listed in the official Release History.

Maybe there is some corruption in the message database. In eM Client, right-click on the Gmail All Mail folder and choose Properties > Repair.

I do not have that option visible
Maybe I’m looking at wrong place.
Either way I don’t see that could be a problem - it looks rather like to command to delete mail was not been sent to Gmail. But that is just my opinion - you know better.

That is the only thing that stops me from buying your great app.

obraz_2021-03-17_123331