Deleted email is not actually deleted

Having been surprised how close I am to my free Google storage limit, I now know why but don’t know how to solve it.

I exclusively use eM Client for my personal email but driven by what I now write I have also experimented with gmail via web browser. Conversation Mode is disabled in both places.

When I click ‘delete’, the selected email gets marked for deletion and then deleted when I hover over the Trash item in the navigator and press right mouse button “Empty Trash”… Except I just found out by accident that it doesn’t get deleted at all; it still exists in All Mail (which I never normally look in) even though it doesn’t exist in any other folder or with any label as proven both in eM Client and gmail via web browser

Experimenting further in eM Client and gmail in a web browser I see that email deleted in eM Client goes to a folder called Trash and when it is there it never displays in Bin or Trash (I have both for some reason) in gmail via web browser.  When I delete gmail in the web browser it goes to Bin as expected and if deleted from there really is deleted, forever.

Two questions please:

How to ensure that eM Client uses the gmail Bin for email marked for deletion

What parameters to put in the gmail web client search to return only the orphaned email that I thought I had deleted and now want to ensure that I really fdelete before running out of space?

Many thanks.

My first question remains valid – I would much like to know how to make gmail deletion work properly via eM Client – but I think I have worked out a solution to my second question that I share for the benefit of Others:

Create a temporary folder in eM Client or gmail web client.

Copy everything in the Inbox to the temporary folder.

In gmail web client run search command has:nouserlabels -from:me -folder:inbox

In gmail web client delete all the email that displays from the above command

Return the contents of the temporary folder to the inbox.

Delete the temporary folder.

   

This is strange, because for me (a Gmail user), If I empty the trash, the email is gone and no longer exists in All Mail.  Even as I delete an item sending it to the trash folder, it is no longer in my All Mail folder (note-- Gmail has only 3 real folders, All mail, Trash and Spam).

This actually might be a Gmail setting that instructs clients to archive when deleted rather than deleting (archiving leaves a copy in the All Mail folder).  Upon first inspection, I really can’t see such an option, but I will keep looking.

Thank you, Jay.  That’s appreciated.

Two updates from me: 

The first is the command in my workaround is  has:nouserlabels -from:me (without the -folder:inbox as this does nothing and is why I used the temporary folder approach)

The second is the command worked correctly and did not touch anything in folders (so with labels).  My gmail account just shrank from 14.5GB to 4.6GB with just under 22,000 undeleted emails that I wanted deleting now actually deleted.

Free of this clutter, I will continue to experiment but this will be in some hours’ time as it is 00:50hrs here now and time for bed!

So close.

I thought that I had solved the problem as follows in eM Client.

Open Menu / Tools / Accounts
Select required account
Select IMAP tab
Uncheck Automatically detect special folder names
In the entry for Trash replace Trash with [Google Mail]/Bin
Press OK

gmail deleted via eM Client then went in the the gmail Bin as confirmed via web client.

Unfortunately, when I closed eM Client, paused to ensure it really had closed, and then reopened, it I get the following error:

[IMAP] Unable to create folder “xxxxx@gmail.com/Trash/” on the server.
([ALREADYEXISTS] Duplicate folder name (Failure))

This is strange because I am no longer using folder Trash - I am using [Google Mail]/Bin

Any ideas, please?

Thanks!

Try as I might, I cannot get this to work.

Please will another forum User who uses eM Client with gmail share two things with me:

  1. The four folder names in Open  Menu / Tools / Accounts / IMAP tab , and whether  ** Automatically detect special folder names** is checked or unchecked (ticked or unticked)
  2. Confirmation that gmail deleted in eM Client really is deleted.  This can be checked by opening gmail in a web browser nd then searching for the deleted email in the gmail Search dialogue

Thank you.

Yes, it is checked on my configuration.  Yes, they are being deleted.  It has to be because of your Bin folder, which I have never seen before.

Also, there is some interesting stuff here about the Bin file, which is for the UK setup.  this explains why I have never seen it before.

https://productforums.google.com/forum/#!topic/gmail/ZHgilTVP7ts;context-place=topicsearchin/gmail/a…

Mine has Bin, and they are being deleted.

Thank you Jay and Gary.  Much appreciated.  I cannot dig in to detail and act on your posts right now but will hopefully do so before UK work tomorrow morning.

Bingo!  Solved.

In the gmail web client I opened Settings / Labels and took a careful look at what was set to show and what was set to hide.  In doing this I saw that in addition to Bin , I had [IMAP]/Bin and [IMAP]/Trash and both were set to show.  I am certain that I did not manually create either of them.

With eM Client closed I set both of the above labels to hide and unticked (unchecked) " Show in IMAP" for them too.

I then opened eM Client and did not receive the described error message even though gmail existed in the bin.

Having checked that the trash location was still [Google Mail]/Bin (it was) I then conducted a full test that included double-checking each step via the gmail web client, and found deletion to work perfectly.

Thank you both, Jay in particular.

I am glad you got it to work!!!

I am also glad you got it sorted!

It is interesting to note that Gmail actually don’t recommend using the online Bin/Trash for your deleted email. But unfortunately you can’t change that setting in eM Client like you can in Thunderbird.

Thank you, Gary.

A bonus is that solving this issue has solved another question I posted on this forum but didn’t manage to receive any guidance on or solve by myself.

This is that for gmail, pressing the delete key marked the email for deletion but left it visible in the inbox (or wherever) until Right Mouse Button "Empty Trash’ was used.  Since the change described in this thread, email marked for deletion now instantly disappears from the folder it is in and can only be seen in the Trash folder - exactly as preferred and exactly as happens with Outlook email. :slight_smile:

I think that I have solved it. Just go to Google IMAP tab in Accounts and associate the special mailboxes (Spam, Trash, Sent) with the Gmail correspondent folders with [Gmail]/ in front of the folders’ names. For example, Trash = [Gmail]/Trash. Now, when I delete a message, it goes to the Trash folder instead of being tagged.

Weren’t they already like that?

This is the default, which is automatically detected from the server:

In my settings, the default was without the [Gmail] and it didn’t behave correctly but instead it tagged the messages. After I included the [Gmail] prefix, everything worked as a regular IMAP account.

1 Like

Re [IMAP]/Bin [IMAP]/Trash

Ive personally had both folders appear only when i installed “Thunderbird” as a test years ago on a Gmail Account. eM Client never did that. Was just something weird with that client.

Bin or Trash.

My experience is that this is named dependent on your Gmail language settings.

Choose English (US) you get Trash.

Choose English (UK) you get Bin.