Delete Mails only with Tabs Shift and Del

Why can I only delete emails with the shift key and delete and not with the recycle bin icon

Your recycle bin may have become corrupted. Try “right clicking” on your bin / trash folder and click “Properties” at the bottom. Then click the “Repair Tab” at the top and finally click “Repair”.


Failing that “if you Windows” try running the mail database repair option manually via the “command line dos window” as per Garys post from the thread below.

Note:- Make sure eM Client is closed before running the below database repair command.

(@Gary post

“Close eM Client and open a Windows Command Prompt. Not a powershell, but a command prompt”.

Paste in this command:
“C:\Program Files (x86)\eM Client\MailClient.exe” /dbrepair

Restart eM Client. Any undeletable messages should be removed


If that still doesn’t fix it, go online to your email via webmail and see if you can clear trash. If you cannot clear your bin / trash online then contact your mailbox technical support to get that fixed.

However, “if you can delete the trash ok online” in your webmail, then “remove and re-add” your email account in eM Client as the account must have then become corrupted in some way.

So if it’s an IMAP, Exchange, Office 365, iCloud (Non-POP) account, then go to “Menu / Accounts” and remove and re-add your account and all your email will come back and that should fix then issue.

Now if its a POP setup, before removing “Create a folder down in Local Folders” at the bottom left in eM Client called eg: Old Mail and then “Drag / Move” all your current POP messages and folders down under Old Mail. Then once you are certain all your email is in Local Folders, remove and re-add your POP account via “Menu / Accounts”.

Note:- Before doing any of the above, backup eM Client via “Menu / Backup” incase anything goes wrong. You can see when the backup is completed via “Menu / Operations”.

Hey Cyberzork, thanks for your help.
After the command " C:\Program Files (x86)\eM Client\MailClient.exe /dbrepair" it worked again.

1 Like