Delete "ghost" folders

I recently bought a new computer and installed the eM Client. Then I transferred all my emails from my old to my new computer.  (In my old computer I also used eM Client).  I store my emails to folder and subfolders I have created in eM Client.  The problem is when I try to delete some folders and subfolders. I delete them and then after a few seconds they reappear. When they reappear their names are not in bold letters as it is with the other folders. They look like “ghost” folders. Why does this happen? How can I get rid of these “ghost” folders?

The best way to move eM Client to a new computer is to use Menu > File > Backup on the old one, and Menu > File > Restore on the new one. This should make an exact duplicate.

Or, if your account is setup as IMAP or Exchange, you just need to add the same account to the new computer and it will sync with the server. No need to move anything.


Thanks for the reply. What I asked is not how to move eM Client to a new computer. This is already done. What I asked is how to get rid of some folders and their sub-folders. I have 2 folders named Trash, each of them with other sub-folders. These sub-folders were not created by me. They just appeared after I moved eM-Client to the new computer.  One of the Trash folders has 3 sub-folders named Trash, Trash-1,  Trash-2.  I delete these folders and then after just a few seconds they reappear.  I don’t know why this happened. It seems that eM-Client duplicated some folders and their sub-folders and put them all under one folder named Trash.  

By following this method, you will end up with an exact duplicate of what was on the old computer. So if the ghost folders were not there on the old, they will not be there on the new.

Now if they were there on the old, that is something else . . .

If you don’t want to follow that route, then you can check in Menu > Tools > Accounts to make sure you don,t have your email account setup more than once.

Or, if the account is setup as IMAP or Exchange you can also try removing your email account from eM Client then adding it again.

If that does not help, then please provide a screenshot showing these folders.

Me too, same problem, already tried all suggestions and then some more.  LOL

Mine are still there in spite of deleting them on RoadRunner’s service, trying the DbRepair.exe, and un-installing emClient and re-installing it.  I wish I could get rid of them.  I am constantly checking in my trash to see if there is anything I forgot to delete, only to find those 4-6 folders.  I would give anything to solve this…  anybody have anything new I can try?  I got so frustrated last night that I search for other email clients and tried four, but none of them are anywhere near as good as emClient, even with this crazy glitch.

I have given up trying to solve this issue. But if you do find a solution please post it so we know what to do.

Remove the account from eM Client. Then add it again. 

If the folders are on the server, they will show in eM Client. If they are not on the server, you won’t see them in eM Client. eM Client is good, but it can’t manufacture something that is not there. :wink:

If you cannot see the folders using the web interface for your account, but they show up in eM Client after removing and re-adding the account, then you need to contact your provider.

I’ve done what you said and it doesn’t work. There aren’t any folders in the web interface. I make folders using an email client. I don’t make folder on the provider’s website. The “ghost” folders were added by eM Client when I transferred my emails from my old computer to the new one. Something went wrong through the transfer process. In your previous post you say that the best way to transfer emails from an old to a new computer is to use Menu>File>Backup on the old computer and then Menu>File>Restore on the new one. I didn’t do that. I did Menu>File>Export and then in the new computer Menu>File>Import. I don’t have my old computer to do it again using the method you say. And I didn’t have these ghost folders in my old computer.

Remove the IMAP account from eM Client.

Go to the web interface for your provider. Delete these unwanted folders.

Back in eM Client, add the account again.

Let it sync.

eM Client can ONLY sync what is on the server. It has no ability to ready your mind and create folders that you might have previously had. If they don’t exist on the server there is nothing to sync. It is a very good application, but all it can do is sync what is on the server. If these folders re-appear, then they ARE on the server.

If you cannot see them in the web interface for your email account, contact you provider and tell them that unseen folders are syncing when adding the account to an email client.

I did the above (many times) and if they are on the server, they were not showing in my folders in the website RoadRunner account.  I kept looking for answers and ran across an entry from emClient (lady, don’t remember the name) and she stated that when you delete the folders, you have to delete them on the lowest tiers and work you way up.  I went back into emClient and opened every bad folder in the trash and finally noticed that some had recreated themselves in lower tiers (sub-folders) from the first subfolder.  So, I decided to try that.  IT WORKED!  When I deleted them by working my way up in each folder, they disappeared and stayed disappeared.  There are a lot of people in our forum that I hope see this because you have to do your steps first, but then you have to do the second part of deleting them in order going back up or they just come back.  Strange huh?  Anyway, at least I will know what to do if it ever happens again.  Thank you for your assistance and patience.  I will take a screen print of this and try to share it with others if I can.  Donna

Yes, seems a very odd server configuration. But you can just contact your provider and have them fix it. The folders ARE on the server, maybe they are not visible to you, but if they weren’t there how could eM Client show them after the initial sync?

What I have recently noticed and i try to figure out how on earth that happened is that the folders i have created in eM Client appear also in my Yahoo web account. That has probably caused all this problems with duplicate and ghost folders that appear on eM Client.  But how is it that Yahoo imported all the folders i have in eM Client? It seems as if i have authorized Yahoo to import all the folders i have made in eM Client but I’ve never done that. The Help section in Yahoo is not that helpful. 

When your email account is setup as IMAP, all eM Client provides is a similar function to your webmail interface. What you see in eM Client is just a reflection of what is on the server. What you change in eM Client is changed on the server.

So if you create a folder in eM Client, it is actually created on the server.

Can this be changed? I do not want the server to access the folders I create in eM Client. But i have accounts with google and hotmail too. They don’t have the folders i have created in eM Client. 

Yes, you can create folders in Local Folders, and these will not be synced with the server. If Local Folders are not visible, you can enable them in Menu > Tools > Settings > General > Show Local Folders.

The other option is to setup your email account as POP3, as this will not sync with the server. It will just download messages from the server and store them, and any folders you create, on your computer only. You can find out how to setup your email account as POP3 in this page in the [Help File](| _____ 3) (F1).

Thanks Gary. Very helpful what you said!

One thing to bear in mind if you are going to go the POP3 route, is that you should first setup the POP3 account, then move the messages and folders from the IMAP account to the POP3 one, and lastly remove the IMAP account.

With the POP3 Inbox there may initially be some duplication, so just use eM Client’s handy Deduplicator to remove the extras afterwards.

I decided to go with the Local Folders option. Thanks